Bookworm 6.6.30 for the uConsole and DevTerm

@SandDanGlokta
Check out the kernel folder in the mega link. Try that out and see if it works and let me know.

@SandDanGlokta did that new script work for you?

Just tried it out. It appears to work? I can see the transmission icon in the system tray… just before the device shuts down. There is something else going on now causing the system to crash.

Are you on battery? Is there anything else with the 4g?

I am. I just saw this thread.

I’ll try on USB. Guessing I need new batteries.

4g will suck some juice apparently a spike as it’s powering up to. Run it off USB and let us know if it works.

Yup, that was the issue. It powers up (blinking light) and down. I see an IP obtained without internet access. The firmware is 9011 so it presents as a USB connection. My guess is I need to run some other command? (Edit: dhclient usb0, all good!)

As far as the script goes, I’d say it’s working as expected. Thanks!

1 Like

I’m not part of that project, but I suspect there’s some others in the community working toward that. I hope at some point the various patches get upstreamed into vanilla linux. Really, the sooner that happens, the better it would be for everyone.

I’m not part of the kernel project, either, but I do have time on my hands.

Hello,

I don’t have 4G module to test, but I have installed Lite image successfully and everything works out of box. Even installed xfce on a top of it. I didn’t encounter any issues or obstacles.
Good job and thank you for your efforts.

1 Like

Any chance this could get uploaded on a serious filehoster? I’m not paying mega money to download a measly 3 gigs of data.

It doesn’t cost anything to download

I started the download and they canceled it halfway through, then threw up this screen. As it stands, it’s impossible for me to download the files without giving them money. I haven’t downloaded anything else from mega, so it’s not a case of me using up their garbage quota elsewhere.

I can throw it up on google drive for you. I’ll update the OP with a Gdrive link when it uploads.

That’d be awesome. Thank you!

Added a Google drive link in the OP for you.

5 Likes

May I ask the commands for restoring brightnessctl?
I tried to duplicate lxde-pi-rc.xml into $HOME/.config/openbox/lxde-pi-rc.xml and used 0xE1 (Fn+.) and 0xE0 (Fn+,) for brightness up and down, copying the actions there were already defined inside the configuration, but I didn’t manage to setup.

Thanks!

1 Like

Added a updated image to the mega link in the OP, with the following additional fixes.

  • Audio speaker pop on shutdown fixed.
  • DevTerm printer fixed.
  • Updated driver overlays - easier config.txt management.
    • dtoverlay=clockworkpi-devterm
    • dtoverlay=clockworkpi-uconsole
      • Just comment out the device you’re not using.
5 Likes