clockworkpi

Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

i am using a fresh image, but expanded and added the music direct using a linux machine, I can try doing it through ssh instead, I loaded the music into the music folder, and the seperate pso music into a pso directory inside the music folder (like I did on the .4 software)

ok removed it and transfered over ssh seems to work now… wonder why direct transfer didnt work

Great! Thank goodness there wasn’t anything wrong with the image.

As to why you couldn’t see them to begin with, it could have been a variety of reasons. If using a command line (cp), it could have been a file transfer in progress without a progress bar, prematurely interrupted. Likewise with a drag and drop launcher.

Some file transfer programs initially get you to give input to move your selected files into place, then hit a “transfer” or “execute” button. This can be a good safe guard against accidentally dragging and dropping files while scrolling. This could have been forgotten.

At the end of the day, it’s probably best to just follow instructions perfectly, without taking any shortcuts. Pretty much all tutorials get you to transfer files via SSH. Sure, it’s faster to do a direct file transfer with HUGE batches of files, but hey! If it doesn’t work, try the recommended method before panicking. :slight_smile:

On a side note, do you actually use your game shell as a music device on a daily basis? Like, seriously? I just find that the sound quality on the board is sub par. The only thing I use it for is streaming music/podcasts via air play while playing existing games. If only you could stream music from your game shell to airplay/sonos devices! Sure you can use bluetooth, but honestly, who has a 24/7 always on bluetooth speaker system? If you do, Great! :slight_smile:

I have gotten MPD to play while playing existing games, but until I sort out some hooks to control MPD with shortcuts, similar to the volume shortcuts, it’s just too finicky and annoying. If you’ve got a machine SSHing into the GameShell, you might as well just use that machine to play music. I just prefer using my phone for music, like PSO, Final Fantasy etc.

One thing to consider using the MPD for is perusing the dumped music files from ROM images. Eg, SNES SPC files. The diminutive sound that comes from the GameShell is almost perfectly suited to this kind of music; just like the low res interpolated screen.
Check this out: http://snesmusic.org/v2/
(there are other formats for other consoles too)

(Also, thanks for using the edit button! :slight_smile: )

1 Like

I dont know the speakers on the gameshell dont sound too bad. usually just use it when in the car, (Im weird like that, used to use my xperia play til the screen went. I just want everything to work properly lol

Very interesting! Using the onboard speakers as a means to play music live.
I’ll consider adding a pre-amp and/or equaliser modification to MPD for a future rendition. Something to have more of a flat response curve for the speakers. They’re just far too treble heavy; something expected given their size. Amazing for what they are, but without much bass reflex, possibly given the small housing behind the speakers; which is funny, given how much space there is behind the speaker unit, assuming you haven’t modified your rear housing.

Something along these lines: https://patrick-nagel.net/blog/archives/180

I’ll add this on the todo list.

1 Like

nope my gameshell is stock with the lightbar setup

If you are using PCSX, the location of scph1001.bin wasn’t working for me. I had to place it here:

/home/cpi/launcher/sys.py/bios

2 Likes

Hey @javelinface, I just saw your mention - of course you can use my script if it helps you! :slight_smile:

1 Like

Thank you so much! Would it be possible to modify your code as well, possibly removing the retroarch related scripts, rick dangerous, and prince of persia? Just want to be completely respectful of the original coder’s great work!

@John_Bach Great! I don’t want you to void your warranty, or break your unit, but compare having no housing for the speakers, and the empty void behind the speaker, to the stock configuration. That’s more what the speakers are meant to be capable of. Having an EQ adjustment globally would have a similar outcome, just without having to modify your housing. But that’s a discussion for a new thread!

@GadgetRat Thanks for that! I’ll definitely include it in the references! I’ve actually never tested using anything but the HLE Emulator, so this is extremely good and useful information! Thanks again! On a side note, was there a BIOS file left over in the image? I thought I got rid of all of the ROMs and BIOSs. If there was any, it wasn’t supposed to be there! Oops!

You don’t even have to modify anything, the main script is modular and the resize part is a script of it’s own, you can just use it independently. Here’s a link to the resize script: https://github.com/hpcodecraft/gameshell-setup/blob/master/system/resize_root.sh

2 Likes

Fantastic! I’m a huge fan of your user friendly CLI echo notifications in your scripts as well, so will probably keep them there. :slight_smile:
Thanks for saving me the trouble of finding the script. It’s on my todo list! :slight_smile:

1 Like

You’re welcome :slight_smile:

1 Like

This is awesome and a much appreciated contribution. I am a noob so have run into a bunch of bugs using your image but the tinkering and learning is part of the fun! Thanks!

1 Like

@Ahrjaydee Thank you so much!! Glad you’re enjoying it. :slight_smile:

Please let me know what the bugs are, and I’ll tinker with it to fix it, if it’s on my end!! That’s the beauty of the community. We ARE the beta testers! Haha.

That said, also compare it against the stock DEOT and 0.4 image. I won’t be able to “easily” fix anything that’s inherently wrong with the stock release.

Also check out @Rebusmind ‘s custom 0.3 image, as some people report a better experience with the earlier version. Personally I find them to be practically identical stabilitywise. 0.4 just has a few more features, and more current upgradeability/compatibility.

I’ll help out as much as I can! Most crashes/bugs appear to happen in Retroarch. In particular image stretching is less than ideal for text. For now, use Lima for anything besides Retroarch, and potentially change scaling to only be a whole number integer variable.

It sounds like a new release with an updated kernel and graphics driver is right around the corner. I’ll put something together similar to this once it comes out; using the DEOT interface, and the custom launcher chooser as mentioned in another thread.

Sources for all things referenced here are listed in the first post. It’s also here so you can read up yourself how things are done, ask questions pertaining to your problem in the right thread, and even have a bash at doing it yourself. It’s the best way to learn! :slight_smile:

did find one issue so far, cave story doesnt load

Have a look at point 6. in the feature list from the original post.

Cave story uses Retroarch, so you need to change it to the FBTurbo driver.

That said, hold onto your horses. Retroarch 1.8.0 was announced earlier in the week. I’m in the process of compiling it now. That along with the updated kernel, and lima driver, we’re going to hopefully get a much more stable system. SOON!

this sounds awesome, love how usable the Gameshell is now, i’ll try the other driver for now and see what I get. well tried that and it does the same thing, dumps me out to the main menu (both when running DEOT launcher, going to try normal launcher now

1 Like

Thanks, @John_Bach! That’s what I’m hoping to do; make something that has some universally wanted and desired features existent in an image that everyone can use; specially since it can be extremely hard to troubleshoot for people having problems with their image, not knowing what they’ve done. If you’re having trouble trying to add any other features, or have anything installed that you believe to be essential, let me know. Judging by your posts, you seem be quite the tinkerer!

Interesting! For my original card I dumped my image from, it’s fine. But when I burn a new one, it crashes! Sounds like a permissions thing with the game files or something. Thanks for pointing it out. I will investigate deep into it!

Also, ha! I think I’ll need to manually change my git-pull server location to update to 1.8.0 RA - just did it last night, and got a fresh 1.7.9. Good news is, I’ve isolated that it’s not a problem with my RA installation re: Cave Story.

Didn’t upload yesterday. Being sick means, suddenly you just need to sleep. On the other hand, it also means that you can take the day off from work. That’s what I’m doing today! Sorry for the delay. New download should be up soon. Might try using google drive or iCloud. Drop box has gotten kinda crap lately.

I’m also going to give a good solid bash at making all the missing icons myself. I’ll put it as a separate skin file, in case anyone wants to have a 100% stock feel; including missing icons.

Hello, @javelinface
your os image is to big to download from China, could you please share your retroarch.cfg for v1.8.0, I have tried many cfgs, but none of them works(cannot open at all or asking for login),I’m running OS v0.4
Thanks!

sounds great, i’ll be on the lookout

any word on the update? :>