clockworkpi

Custom D.E.O.T. V2.0+/Clockwork OS v0.5 image - With customised DEOT interface, Kernel 5.7, Optional 1400MHz OC, Debian 10 Buster, Retroarch 1.9.0, Mupen64+ plus more! (Current build: 200903)

No worries!!! Thanks for the comment! It keeps me smiling and motivated. :slight_smile:
And ha we all gotta start somewhere!
I’m eventually going to make individual modules people can install with each change I’ve made, so you can install individual components without having to reflash your entire card. For now, here’s a link to a mupen script to get things running on your main card:

As for the dpad reconfiguration, the mupen config file is located in ~/.config/mupen64plus/mupen64plus.cfg
There will be a place you can scroll down to change the keybindings under “input player 1”
As for what to put in, you’ll possibly need to know the keycodes. I uploaded them all somewhere but can’t seem to find it! Never fear! You can get them yourself. Here’s how.

  1. SSH into your gameshell.
  2. Type export DISPLAY=:0
  3. Type xev
  4. Push the buttons that you want to get the key codes of, and make a note of it.
  5. Exit by pushing “ctrl + c”
  6. Edit the config file accordingly.

Oh haha I just realised. I would have already had the Gameshell dpad keycodes mapped! You could have just cut and paste them to wherever you want! Haha. Ah well, it’s also a good thing to know, so you can edit the rest of your keys.

There should be a way to make an individual script/action to load a specific config file for a specific game. Useful for times such as this. Either that, or a script to toggle different mupen configurations; similar time what I did with the kernel/clockspeed switch.

While I’m here! I want to also point out another thing I noticed re: some standalone emulators. Some of them now run ATROCIOUSLY! In particular, FCEUX and gpsp. Both of them have really janky v-sync and frame rates. FCEUX has audio sync problems. This is using 5.5.9 and 1400MHz. Possibly a clock sync issue. The audio issue was fixed just changing the audio quality down to 0 in FCEUX.

I didn’t notice these at first, since I usually use Retroarch. Likewise with PCSX, the Retroarch core handles scaling of text better than the PCSX standalone. But that’s just personal opinion. I actually prefer using Retroarch, where everything runs buttery smooth, but I know that many users insist on using standalones. They’re there for you to try out and fiddle with settings to make work better.

And please do! There are far too many games to test and too little time to do it in. It would be great if people could post and changes they have made to make things run smoother etc. I’m always testing and trying new things, and often overlook simple things.

1 Like

Just caught wind of another potential thing to fix. It was via Discord. (I’m lettuceleaf)

For now, unless you really want the custom volume/brightness, deactivate the DEOT settings via the script in utils.

I haven’t tested it yet myself, as I am at work, but will report back as soon as I do!

1 Like

Indeed it freezes it…but I like the looks of the deot menu, so I will not deactivate the DEOT settings until I have to access the warehouse :slight_smile:

1 Like

At least I’ve isolated it down to the skin_manager.py being the culprit behind the warehouse breaking.

The only thing added to it were references to additional fonts that theoretically shouldn’t have altered anything unless called upon. The stock font references were untouched.

Unless… surely it’s not the changes the the settings pages? They shouldn’t be referenced in the warehouse. Surely?

Yay another thing to add to the mystery bag to sort out. :slight_smile:

After work, I’ll just try commenting off each line one by one.

#!/bin/bash

sudo cp -r /home/cpi/apps/Menu/60_Utils/11_DEOT\ Settings/.deot/Settings/Brightness/ /home/cpi/launcher/Menu/GameShell/10_Settings/
sudo cp -r /home/cpi/apps/Menu/60_Utils/11_DEOT\ Settings/.deot/Settings/Sound/ /home/cpi/launcher/Menu/GameShell/10_Settings/
sudo cp /home/cpi/apps/Menu/60_Utils/11_DEOT\ Settings/.deot/Settings/list_page.py /home/cpi/launcher/Menu/GameShell/10_Settings/
sudo cp /home/cpi/apps/Menu/60_Utils/11_DEOT\ Settings/.deot/UI/scroller.py /home/cpi/launcher/sys.py/UI/
sudo cp /home/cpi/apps/Menu/60_Utils/11_DEOT\ Settings/.deot/UI/skin_manager.py /home/cpi/launcher/sys.py/UI/
sudo cp /home/cpi/apps/Menu/60_Utils/11_DEOT\ Settings/.deot/UI/slider.py /home/cpi/launcher/sys.py/UI/
sudo cp /home/cpi/apps/Menu/60_Utils/11_DEOT\ Settings/.deot/.gameshell_skin /home/cpi/
sudo reboot

On another note!
I’m looking into getting Mesen running. A NES emulator that supposedly supports advanced audio features from some famicom games. Eg Akumajou Densetsu/Castlevania 3. The Retroarch core doesn’t perform well on the gameshell, so was going to try and compile the standalone. It would be something to replace FCEUX, that is currently suffering from terrible V-Sync issues.

1 Like

thank you for the update. it is very helpful

1 Like

Welcome to the forums @kate_smith !
Glad that it’s helpful!

1 Like

I’ll be including the LowResNX fantasy console in the next release.


Here’s an icon that has been “DEOT-ified” if you decide to install it now yourself.
LowResNX

or

LowResNX

In other news, I’ve gotten the warehouse working in DEOT mode. Yay!
I’ve also put on standby the DEOT style settings pages for storage and airplane, in case anyone else wants to try their hand at making it work. They’re currently commended out in the activation script.

I also fiddled with a few other icons too. Nothing major, just the DEOT mode (de)activation, and the retroarch update script. I’ve touched up the wonderswan icon. The colour just isn’t quite right!

I added another script to retroarch, serving as a config file recovery; just so you don’t need to SSH in if you change something that makes it not start up properly, or just want to start over.

Experimentally have included an action.config for the BeetleVB Virtual Boy Retroarch core.

I’ve also included an installation of mednafen that seems to work much better for virtual boy.
It also supports NES and Wonderswan.

I haven’t included it, but if you want to install Brutal doom, you can do so with this script.
The post has been updated with some new information to have better mod management.

I’ll get it uploaded tomorrow. It’s 2am, and I probably should sleep. :slight_smile:

1 Like

Hello again! I wonder, is it possible to perform an overclock at stock 0.5 OS? Let’s say, I want 1200MHz, what I need to do?
Thanks in advance.
I tried to search in this thread but, couldn’t find it…

Hello! You can apply the overclock to whatever kernel you want. :slight_smile: It’s more, you may want to have an updated governor in an updated kernel to get the most out of it, re throttling etc.

The stock 0.5 image has the stock kernel, so could potentially lead to battery life being less.

Although are you specifically wanting to have 1200mHz and not 1400mHz?
You will need to replace the .dtb file in the boot partition.

Have a look here for more info.

1 Like

I want to take a try and compare with original frequency, 1200 looks logic to me, but I can try 1400 also.
Thank you for showing me what I was looking for!

1 Like

1200 is what the gameshell is advertised as having funnily enough! They’re not wrong; it’s just that all the official OS releases have it set to 1008.

Most things don’t have that much difference. That’s why I made it a toggled option. It’s certain games in Mame/FBA that really benefit from it. Usually when the audio gets out of sync, and has major buffer problems. Mupen64 just has slightly better performance, and less micro stuttering.
Compiling is faster, but it gets stupidly hot, so I probably would wait that 50% extra time.

Overall though, It’s not worth having overclocked all the time. Just turn it on when you need it.

That said, another user recently posted that while using the DEOT image, they can’t get their SNES emulator running well, unless overclocked. This is very strange. I have no problems with SNES on stock clock speeds. Did I just get lucky and get two really good CPI boards? Not likely.

Anyway, let me know how you go. I’m curious to see how others feel the overclock works.

I had bad experience with snes emulation, but because or stock core. I tested many of them and choose snes9x2005, and as I remember in stock os it is snes9x2005plus or how it called… Maybe that is why he had a bad experience…
And I want to try overclock only for MAME/FBA and VIrtual boy, everything else is working good in my setup.

Virtual boy! I forgot about trying that, since I remember it running so poorly! That was using the beetle vb core. Are you using a different one, or potentially a ported standalone?

Also very strange! I am using Snes9x 2005 plus, ie the stock core, and it’s working fine. That said I am also using the 5.5.9 kernel, without overclocking. Perhaps it’s the kernel choice that’s making a difference.

Was snes9x 2005 plus running poorly on your stock 0.5 setup too?

It seems to me that there is definitely an indiscrepency on boards. There shouldn’t be but there is.

I’m using core for Playstation Classics, I tested many and compiled one myself and all of them not near as good as this one. Here is my action.config file:
“ROM=/home/cpi/games/VirtualBoy
ROM_SO=/home/cpi/apps/emulators/mednafen_vb_libretro.so
EXT=vb
LAUNCHER=retroarch -L
TITLE=Virtual Boy Roms
SO_URL=https://classicmodscloud.com/classic_libretro/stable/classic_armv7_a7/so/mednafen_vb_libretro.so”
and I was testing only one game Wario Land. I’m getting around 34 fps this is the best I found…

I tested them all but only on one game Super Metroid and 2005 was best in performance so I choose it. I can’t say 2005plus is bad but it is not the best…

Possibly looks like the same one. Here’s my action.config.

ROM=/home/cpi/games/Virtualboy
ROM_SO=/home/cpi/.config/retroarch/cores/mednafen_vb_libretro.so
EXT=vb,zip,7z
LAUNCHER=retroarch -L
TITLE=BeetleVB Roms
SO_URL=https://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/mednafen_vb_libretro.so.zip

I actually haven’t delved into the PS Classic! Does it also use the all winner R16 like the snes and nes classic minis? That could be a treasure trove of cross compatible emulators! Either way, the fact it’s using the retroarch would imply it’s the same core.

I’ve just made an icon too, if anyone wants to try it for themselves. If it works, I’ll throw it in the next update for kicks.

BeetleVB

Gives me around 24-27 fps, so my config is better for me. You can try both and compare, actually it gonna be interesting to find out that some boards are different…

I don’t know, I even don’t remember why I tried to test its core :crazy_face:

Hurm, that’s about the same as what I got before overclocking. Doesn’t sound like the overclock makes that much of a difference. I’m running it in “fast” mode, as opposed to accurate, using the buildbot version.
I’ll see what FPS I manage using the one you’re using. I’m guessing about the same.

Verdict: They’re the same core. Playable, but not enjoyable. The audio is far too stunted. Which is unfortunate. :frowning:

I’ll keep trying to fiddle with settings, and or find a better emulator.

On that note, that’s something I might put in. A quick “rescue” script, in case you muck up your retroarch config, ie changing drivers, and want a quick recovery without having to SSH in.

using official libretro core i also get ~34 fps, recompile it with proper cpu let gain ~1fps more

core got options, setting cpu option to “fast” goes at ~40fps

with latest standalone mednafen it run full speed, constant 50fps
(mednafen conf file with sound & minimal keypad configured, ~/.mednafen/mednafen.cfg)

(take note retroarch core got nine months old mednafen source, and last mednafen standalone release was from 17th march

2 Likes

Thanks @r043v! You saved me hours of time trying to find that standalone!

I’m surprised that it’s only 1fps more compiling it for the right CPU. Playing Warioland, seeing the timer going down is now much closer to what 1 second should actually be.

The audio is still a bit garbled sounding, or at least I think it is. I don’t know what the audio of the virtual boy sounded like. (using the retroarch core)

Which then begs the question. I wonder if it’s worth manually recompiling every Retroarch core specifically for the Gameshell.

Wow, where you get it. How I missed that?