clockworkpi

Custom D.E.O.T. V2.0+/Clockwork OS v0.5 image - With customised DEOT interface, pre installed Retroarch 1.8.4, Mupen64+ and everything in 0.5 plus more! (Current version: 200224)

Similar to my previous DEOT custom skin based on 0.4, I have put together a new image, based on the recently released ClockWork OS 0.5.

This is the same as the official 0.5 image, just with a lot of updates, and quality of experience optimisations. You don’t need the DEOT edition Gameshell to use this. The official DEOT image is much older, and behind the official 0.5 image. This custom image is the bridge to get the best of both worlds.

b7d679edaee7a55ad42147c9085b5e919824296a_2_462x500

Here is a google drive link to the custom image. This is where the most current build will be uploaded. To ensure you have the latest version, make sure the build number matches up. (200224)
In future, I may need to take it down to save space, so send me a DM if it does go down, and I will re-upload it.
https://drive.google.com/drive/folders/1xjuLFPvbtcq3FDDYCX-GI1wTCXX4XB7n

This is an alternative mirror of the current file. It is a temporary one that will be placed with an edited one by guu, with smaller image footprint, and an auto expand script. This image will not have these implemented yet, but is still 100% useable. (Current 200224 build)
https://mega.nz/#!luIw1CwB!8ZQtQjcwCcFTuESVD_OnIQWSxFqyiuNPZTgr2jpCTug

This is a Mega link provided by @guu that should be good for people finding the google link too slow; especially in China: (Previous 200110 build)
https://mega.nz/#!UcFlSSAK!FrKpbT7e13a1vKiQWH2VaxLKqR7VzOitW7XoXyX3tT

This is an alternative link, provided by @wizz. This is great if you are in Europe, and want fast speeds.
(Current 200128 build and Previous 200110 build)
https://pcroz.stackstorage.com/s/a26iBYxvkQ5VSgS

The majority of the features that were incorporated in the DEOT v1+ 0.4 image are now standardised in the official Clockwork OS 0.5, so a lot less work has needed to be done.

Instead of being built from DEOT V1.0 up, it is built from the official Clockwork OS 0.5 image, making it far more future proof and upgradeable. (Hopefully!)

With this unfortunately comes the demise of the alternate minimal home screen layout.

The positive side is, this is now an official 0.5 image, simply with a few extra things added to it.

The custom launcher changer has also been removed, since being based on 0.5, there is no real need to change to a separate launcher.

Current features: Build 200128 (as of Jan 28 2020)

  1. DEOT skin restored, and matched up to the current 0.5 image file structure. Loading screens and menu items also updated to reflect DEOT. /etc/motd welcome screen also edited to reflect the DEOT release. All icons have now been edited to match the unified theme. You can simply choose the default theme in the skin chooser, if you wish to return to a more vanilla 0.5 experience.

  2. Retroarch updated 1.8.4 - all parameters enabled and options installed, including a very fancy XMB menu. All cores used by the default gameshell emulators that require retroarch have been pre-downloaded. Mame directional controls and input addressed, adding the user cpi to UDEV group, and controls predefined. All assets, shaders etc downloaded.

  3. On each release, I perform a) a launcher update, and b) a general asset/core update on retroarch. I have deliberately omitted an apt update && upgrade as unless there is a need, this risks breaking things.

  4. The latest debian updates include unused features in the music player daemon (mpd). I have modified mpd.conf to disable unused plugins, eg Qobuz, Tidal, id3v1 encoding, avoiding having a verbose printout at every boot up. Keep this here if you ever decide to do an apt upgrade yourself.

  5. A remove mail and filesystem expansion script included in the Utils folder.

  6. Global volume control installed.

  7. ChocoDM and additional ID software WAD wrappers set up. This allows you to play Heretic, Hexen and Strife. You can find it in the Retro Games folder, under “id” You can edit the control on the fly, using dinguxcommander in the utils folder, and navigating to /usr/games/ and choosing the apropriare setup. By default, the accept button (or Y for yes on a keyboard) is the B button on the gameshell (Or the bottom input key). This is useful to know, so you can exit out of the game.

  8. PicoDrive standalone emulator installed

  9. Mupen64plus installed and configured, including the inclusion of state save/load via shift select/start. Menu now does turbo, and quit is invoked by shift+menu.

  10. Action files modified to point to a more logical rom folder hierarchy, have more file extension support and have retroarch dependent cores installed within the retroarch system directory.

  11. Edgelord icons/apps are back. Love them or hate them, they’re what make DEOT Unique. They are all in Chinese unfortunately, and are hard coded as such. I won’t be able to translate them. You’re not missing out on anything. The manual app is for the DEOT apps specifically.

  12. OP-1 theme has been removed to avoid future compatibility problems.

  13. Action files and retroarch config has been updated to use https://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/

  14. Just so you know, the input mode is set to SNES, which I find is superior given the nature of the console. Retroarch exiting is now invoked by pushing shift+menu twice. This avoids accidental exiting pushing menu alone. Menu now invokes, you guessed it; the menu. This makes more sense in my opinion.

  15. Everything should be fairly updatable as if this were a stock 0.5 image.

  16. Battery monitor app installed to the Utils directory.

  17. The .xinitrc file has had legacy file location entries removed, as they were unused. Just a cleanup.

  18. The bug in the stock 0.4/0.5 image with duplicate entries in both /apps/Menu and /launcher/Menu that caused certain menu items to vanish has been fixed.

  19. @guu’s rootfs expand script, and an optimised zeroing of empty space has been applied to the current version.

Recent Changes (as of 24/02/2020)

  1. xbindkeys installed to allow key shortcuts to exit/kill apps that don’t have easy termination processes. eg, sampler box and scummvm.

  2. Samplerbox shortcut in utilities. (Exit it using menu key) thanks @edward

  3. Scummvm shortcut made in Retro Games. (Exit using shift+A+B+X+Y) You will still need to sudo apt-get install scummvm. I have omitted from doing this on this release, as you will not be able to use this unless you’ve installed the mouse mod to the arduino. Unfortunately, I can’t do this from the image end.

  4. Slightly modified .xinitrc that uses twmrc in HDMI mode, but sticks with dwm-mod in handheld mode. There were no benefits in hand held mode, and it only made the interface slower. We’ll see how the mainline image tackles it in the future, and go with whatever is chosen then. I personally don’t have this on my day to day image, but I know that people will complain about the slower menu speeds.

  5. Cleaned up and optimised mupen configuration, and action.config to reflect using a /usr/local/bin file location.

  6. Quake 2 shortcut removed.

  7. Returned freedoom part 1 and 2 - I previously deleted, while culling all games.

  8. DEOT Skin settings items modified to have the appearance of stock, with the colour of the DEOT interface. I still can’t get the modified items to work. I believe it’s a font issue or something else referenced in the skinmanager.py file.

  9. The OP-1 theme has been returned, and adequately doctored to reflect the new file structure of 0.5. Likewise, Canisminor has been included with similar fixes.

  10. Fixed the vertical justification of the /etc/motd file so that the welcome splash message better reflects the stock DEOT OS.

Previously mentioned updates reiterated, with links to initial post:

  1. Tweaked retroarch config to try and have more of a focus on vsync and screen tearing issues, than audio timing/skewing. It seems that most people care about visuals more, than actual frames and audio quality. On my day to day image, I personally prefer to have Vsync off, and just have audio sync, since it gives more reliable frame rates, and better audio. But screen tearing is what people see, so lets see how this goes. see here
  2. Font overlap fixed
  3. DEOT Apps cleaned up
  4. Cleaned up some of the retroarch directory structure
  5. The initial tweak to the .xinitrc reference to the window manager

Future changes:

  1. I was initially going to change the debian repository to a more centralised location, but this would fragment releases. For me, the chinese mirror didn’t pose a hinderance to download speeds.

  2. I didn’t bother recompiling the kernel to have all of the custom splash screens, because a) I was just too lazy and b) chances are it’s going to change very soon; what with the 5.4.6 kernel just precariously sitting there, waiting in the boot partition. :wink:

  3. Custom brightness, Volume, Airplane and other settings menus from the DEOT image will eventually be added once I get around how to get them to work. Then again, they might not, depending on how badly updating just keeps getting rid of the hard work, without having to add them to an exception list. In DEOT theme, Airplane mode toggle font /image is too large, and clips. For now I have just applied a colour filter over the items to make them appear more unified.

  4. The skin chooser python file needs to be hard modified to change to the DEOT font, which is a bit naughty. What this unfortunately does is, unless your theme has explicitly included a config file stating what colours it wants to use, it will use a darker theme. It may even break completely. That said, the stock 0.5 theme kinda looks neat in dark mode. Plus its nicer on your eyes! I am debating still whether or not to include this, as this will also break updating.

  5. Including extra standalone emulators, namely ohboy, fceux, picodrive stand-alone, heretic, hexen, strife, quake 2, and have also installed PokeMMO.

  6. Install Emulation Station

Known issues:

  1. Still need to work out how to include the proper stock DEOT settings pages. Ie, Sound, Brightness, Wifi, Storage. Most likely a problem with the skinmanager.py references not lining up.

Installation:

  1. After downloading the file, you will need to decompress it. It is in a bzip2 format. Most modern computer should be able to handle decompressing this natively, simply by double clicking on it. If not, try to find an app that does it for you. (not needed if using a mac)

  2. Acquire an SD card that is preferably 16GB or larger. Assuming you just want to use a single partition, you don’t need to do anything to prepare it.

  3. The image that was decompressed should be an img file. This needs to be written to your SD card. A popular app to use is Etcher. https://www.balena.io/etcher/ As the program’s site would imply, a) select image, b) select drive, c) Flash! Flashing an image will delete everything from the SD card, and change its file structure to match up what is required. Sometimes, errors can be resolved by making sure you have the latest version of your flashing program, and updates to your system’s drivers. On the off occasion that either a drive or a sd card is faulty, you may need to do a file system iconsistency check, or a fsck. This shouldn’t happen too often, but if it does, there are plenty of resources available online to show you how. Just look up “FSCK” (not to be mistaken for a cuss word). If on windows, I recommend using the program Putty to do this. Mac, just use Terminal. If you’re on Linux, then you probably know exactly what you need to use ;).

Post installation:

  1. Since I haven’t included an auto expansion script, I have included one to manually execute after installing the image. It is located in the Utils folder, accessible from the Gameshell’s home screen. Do this to allow the operating system to fill up any unused space on your SD card. IMPORTANT: You need to be connected to the internet, either by wifi or Ethernet over USB for this to work. It takes about 30 seconds. The screen will be blank, so don’t panic, and let it do its thing. For stable releases, I will graciously ask for @guu’s help to apply an automatic rootfs expansion script, making the aforementioned step unnecessary. Instead, just allow your gameshell to reboot a couple of times; the same as the official 0.5 release.

  2. Bios files are now much more centralised, in particularly pertaining to the PCSX bios. These files are sometimes needed for games to run.

  3. Place the SCPH1001.BIN (or whatever PSX bios you use) in the ~/apps/emulators/bios directory. Note that this is now different to what it used to be, ie ~/launcher/sys.py/bios.

  4. You will also find the .pcsx hidden folder in the ~/apps/emulators directory, if you wish to restore your old save files, state saves and config files from a previous version.

  5. Mupen64plus settings are held in ~/.local/share/mupen64plus/save. Save rams are the *.sra files AND/OR *.eep files. Some games use one or the other strangely. Memory pak data are the *.mpk files. State save slots are the *.st0 files.

  6. Place the gba_bios.bin file in the same directory as the gpsp application; ~/apps/emulators/. I never realised it till today, but the gpsp.zip file that automatically gets downloaded includes a file named gba_bios.bin. I haven’t confirmed if it is actually a bios or not. Gpsp save states and save files are located in the same directory as the gpsp app. You will also need to put a bios in the ~/apps/emulators/bios directory for the GBA cores that are used in Retroarch.

  7. Pico-8 is installed the same way. Place your purchased copy of pico-8_0.1.12c2_raspi.zip into the ~/games/PICO-8 directory, then run it via the games menu in the game shell.

  8. Roms are to be placed into their respective directories; either compressed or decompressed. If they are compressed, and there are more than one rom images per compressed archive, the emulator will more often than not choose the top one in the list. You will notice that there are far less directories now, with double ups removed, and console names being chosen over emulator names.

For information and sources used for this image, please refer to the previous thread. There was so much information that led to amazing development in the previous page. I thought it would be best if I started afresh with this image. I would say to keep discussions relevant to the thread, but hey! If we did that, we wouldn’t have a working Lima driver! Just use discretion. :slight_smile:
Hopefully we will once again be brought together to progress the Gameshell even further!! :slight_smile:

Note: After 1 month, I will be unable to edit this post, due to forum policy. I will try and keep updated links to future updates within this thread, and change the title (which can be changed funnily enough) to reflect what the current version is.

7 Likes

Great! I was waiting for you to customise v0.5. Didn’t expect you to get it done so quickly! I am going to try it later today. Exciting!

1 Like

Haha it was a day of intense hyper focus! I was worried I got it out too late! That’s madness, downloading and testing an OS while on holiday! That said, so am I. Strange how we find joy in such little things.
Hope you enjoy the image! Let me know if any problems, or features you’d like in future releases! :slight_smile:

1 Like

I couldnt get those google drive images to download last night. They dont show the total filesize while dling and they just keep going. it never even finished,.ill try this one but the other google drive images wouldnt download very well, id use a different host if you can …

@Wizz
Greetings to you again, as per this user’s request, would you once again be able to host a copy of this custom OS?
I’ve only just had enough bandwidth to upload it to google, which is strangely the fastest method in Australia.
I don’t know where the aforementioned user is downloading from, so fingers crossed things end up faster; at least for Europe!
I’ve been working on this nonstop all day. Apologies for not considering uploading to a different place. I will do it right before I sleep. Probably mega or something. Too tired. Can’t think. DM me if you have more problems downloading or installing, or for things not working or whatever @wayfarer. Realistically though, I don’t think this image is for you. It’s the first release, which will see a lot of revisions as other users help out. You will be wiping your card a lot, and getting frustrated. It’s 3.68GB.

This will upload in like, 12 hours.
https://mega.nz/#!0rBxgSjC!Shwg888_vv_pRRExN_UmlRMQc3atT_D_7r5jrqLP0to

Hi,

When upload finishes DM me and I will download and host it ! I will remove the old image so we don’t get versioning issues :wink:

1 Like

I already wiped my card out , i dont care I just wanna get N64 emulation working.

My dude. I am trying to help. If you could continue this in the OTHER thread I am helping you on, that would be fantastic.

All i saw was black screen and no light even for power. So i just flashed it again with the 0.5 official image. now getting black screen completely, no LED light or anyhting sigh

now trying to flash it again…

black screen could mean uboot is bad, be sure to unmount properly the sd card before flashing it and make sure write is really over and sd properly unmount after flash and before eject it

it could also be your sd card adapter who’s bad, real sd to micro sd work better than usb, one usb adapter i own cannot write more than 4gb (wtf), try another one to be sure

1 Like

igot it booting up, using the reset button on the mobo . now its working on the latest 0.5 image but still no mupen64 working… my wifi was too slow to dl the dependencies…

(try disable wifi power save, How to disable wifi power save to prevent disconnects

1 Like

Since I wrote that post, that functionality was integrated in the power modes in the Launcher. Check the settings, the performance mode should disable wifi power save.

1 Like

Still , the DEOT images dont work at least none of them did for me. only getting black screen. And i tried every mirror, and downloaded the 0.4 and 0.5 versions, tried them all flashed about 10 times my sd. I can get the 0.5 clockwork image to work , the official one, but this one just black screen. twice now. i just had it working in 0.5 too.

now to go back to that image again and flash it again TRY this wifi power safe bs and see if that works. (btw not using this topics image im using the offficial 0.5 one cause none of the ones here work.

i beleive i had performance mode on anyway

and i dont even know if it was the wifi or if it was just running into errors installing in which case fixing wifi wont matter

it’s strange, as you reset push fixed an issue you could also try disconnect the batterie completely and powering on with usb wire

if you have wifi issue you will see it fast while just type command or transfers files

1 Like

Hi @wayfarer. Could I propose that you please start a new topic, especially seeing as what you’re posting about is not relevant to the image that this thread is about?
a) You’re discussing mupen dependency installation. This is already done in this image. I am literally trying to help you with that in another thread.
b) You’re talking about issues with flashing images, power profiles, and hard resetting. This is something that can have its own topic.
c) Problems don’t seem to be pertinent to just this image, but issues that the user is having with hardware; both with writing the image, and wifi stability.

I’m happy to answer your questions externally, just not in this thread if that’s okay.

And please don’t reply to any of the above points in this thread. They are suggestions for starting a new one.

I want to try and keep this thread tidy. So far, it’s not getting off to a good start.

In other news, here is a mega upload of the same file:

https://mega.nz/#!0rBxgSjC!Shwg888_vv_pRRExN_UmlRMQc3atT_D_7r5jrqLP0to

1 Like

seems need a decryption key for downloading

1 Like

I already have like 5 copies of the DEOT image i dled from basically all the mirrors, and they dont work , i was trying to dl the DEOT images all day from every mirror… i think its cause the file size is too big , google doesnt scan them for viruses or something , dont download right in any browser, i think if it was in a torrent it would work

Thanks for sharing. I brush the machine in the afternoon. The following problems occurred:

  1. SFC simulator cannot find ROM folder, MD simulator cannot find ROM folder, and arcade simulator does not have ROM folder.

  2. When changing the theme, loading will be displayed all the time, and loading will still be displayed after restarting.

  3. If the menu in the simulator can have Chinese, it’s good.

I like playing games, besides being a Chinese. Thank you, brother.

报错

1 Like

Perfect!!! Thank you so much. This was the kind of feedback I was looking for re how to improve the image.

  1. I know exactly what to do to fix the rom directory problems; and what I did to break it! Can you confirm which emulators didn’t work re SFC and MD? I mainly was testing the standalones, so I am guessing it was the Retroarch cores. I will post up updated action.config files, and upload an updated image.

  2. Strange that changing themes does that! I admittedly only changed and toggled the DEOT and Default themes, since I don’t use OP-1.
    Was it OP-1 you had problems with?
    This is possibly related to the custom fonts required of the DEOT theme and the modified skin_chooser.py. I’ll simply restore it to the stock one, and forego the fonts. (And find a better way to use custom fonts!!! Grrrr!!)
    I’ll provide instructions for those who want them, but also update this in the next release.

In a nutshell, just change your skin to the default, then go into ~/launcher/sys.py/UI, then find the file called skin_chooser.py, rename it to skin_chooser.py.bk or something, then rename the file called skin_chooser.py.bak to skin_chooser.py. (Or was if skin config? I’m just writing this from memory in bed haha)
Afterwards, reboot the system.

  1. A lot of the Chinese would have to be hard coded into the emulators, which unfortunately I didn’t write. Also my Chinese is SHOCKING, despite being Chinese myself. If they ever release translates versions of the standalone emulators, I will be happy to include them! :slight_smile:

Again, thank you so much for your HELPFUL feedback!

In other news, @wizz has provided a helpful mirror for the download: https://pcroz.stackstorage.com/s/a26iBYxvkQ5VSgS

@guu - hopefully this mega link will work. https://mega.nz/#!0rBxgSjC!Shwg888_vv_pRRExN_UmlRMQc3atT_D_7r5jrqLP0to
The previous one was one I provided while it was still uploading. I couldn’t get the permissions properly sorted, and was way too tired haha!!

@wayfarer

For those curious of @wayfarer’s problems, the solution was cross posted across a few threads, including this one. Summary: user downloading problems.

Their mupen64 problems were resolved as well.