Emulationstation on Gameshell


lasvegas, do you know which OS version you started with? I had luck with v0.3 … Initially had some trouble with cmake with some missing packages but Dowdheur updated the tutorial, and it worked after that. I have not tried any previous versions to 0.3


Okay… I didn’t except that :hushed:

Did you try to change the GPU driver ?


Yes, Fbturbo gives the same result as Lima. Strange. I have actually built ES twice now with the same result.


I was running v0.3. Unfortunately my attempts at installing freeimage, ended up breaking the screen drivers. Nothing after the initial boot screen. I need to start over…


I received a new GameShell today. I made a backup of the stock image on the SD card, then proceeded to follow your tutorial and got a working, legible ES install, screen looks normal. I believe the stock SD has OS 0.21 installed, but I do not know how to check that. I am going to spend some more time configuring ES and this GS in general, but I may try upgrading the OS to 0.3 and see if I get the corrupted screen issue again. But for now, it looks normal. Thanks for all your help!


Okay! I got EmulationStation to install into a new install of clockworkos_v2.1.

It launches, but I get a configuration screen to assign keys. Unfortunately, the GameShell doesn’t have enough buttons to assign every function. Is there a technique to skip entries? Or better yet, does someone have a config file will the keys already assigned?



I believe that holding any button for several seconds will skip a keymapping entry. In this way you can skip functions you do not want to map to buttons by holding any key.


Cool! I got it up and running. Unfortunately, I can’t get it to run any ROMs from NES or SNES…

Edit: Got it. Typos in emulator paths.


Cool ! Good news :slight_smile:

Please check my launch script, it could be useful for ya ! :wink:


Confirmed. ES runs fine for me with 0.21 but the display is corrupted with 0.3 installed.


Hi. Great tutorial.

I have compiled emulationstaton on 0.21 and set up es_systems.cfg and gamelists.xml following your example. Also got ES icon on clockworkpi screen.

When I run emulationstation, I get an error initializing SDL. No available video device. Window failed to initialize followed by a segmentation fault:

Any ideas?



Did you get the resources folder in .emulationstation ?

Verify the owner and the permissions of the folders


You need to add DISPLAY=:0; to send the output to the LCD before the command if launching via SSH. IE:

cpi@clockworkpi:~/.emulationstation/gamelists$ DISPLAY=:0;emulationstation

Yes. I copied the contents of ~/EmulationStation/resources into ~/.emulationstation like this:

Is this correct?

Thanks again for the help.


Thanks for the suggestion. When I tried it I got this output:


This is the same output I get when I try to run emulationstation with the command:

cpi@clockworkpi:~/.emulationstation$ emulationstation

Am I missing SDL driver?


Looks like you took the contents of the resources folder, instead of the folder itself.

Try this command, which will recursively copy the resources folder into the .emulationstation folder:

cp -R ~/EmulationStation/resources/ ~/.emulationstation/

As for your sdl error… I do remember having this problem once, but the only solution that worked for me was to start from scratch and try again.


Thanks for the help. I used the cp -R ~/EmulationStation/resources/ ~/.emulationstation/ command previously but just tried again on fresh install of 0.3 with same results :woozy_face:

I did remember this time that the /etc/emulationstation files are note created automatically. I have been making the /etc/emulationstation/themes folder to install the light theme as per the directions. Browsing the Emulationstation github page it looks like there should be some files installed to /etc during installation. Is this correct?

Thanks very much to all who have helped out. Much appreciated. Really wanna get this to work.


For etc, I had to add the folders and files for themes manually. You will need to use sudo for all commands, including git.


FYI, I started again with a fresh image with OS 0.21 and got some similar sdl errors when attempting to run emulationstation over SSH, but it ran fine when I launched it from the GameShell. I would not recommend using 0.3. I got those corrupt screens using 0.3 on 2 different GameShells.


apt-get install libcurl4-openssl-dev

worked for me but from os 0.2