Emulationstation on Gameshell


I had to create one from scratch because it was not present. Looking at the log file, it doesn’t look like ES is touching the es_settings.cfg file, but there are no errors. I was able to switch themes by studying screenshots of the ES settings menus with a Google image search. I can tell the theme changes, but I guess this was not the problem because the screen still looks blocky and weird.

Before all of this, I had been experimenting with the build and ended up starting over, but at one time, I had an es_settings.cfg file that was auto-generated. Not sure how. I was even successful in getting ES to load a ROM, but of course the screen is un-readable so there’s no knowing which ROM will load.


Am I missing something? I was following the process on GitHub, but when I get to the line cmake ., it’s not a recognized command…

-bash: cmake: command not found


Did you installed cmake package ?

Are you sure you’re in the right directory ?


This is weird.

When you say that your screen looks blocky, can you post a screenshot ? I wouldlike to know how it feels.

es_seeting.cfg should autogenerate if it’s missing. But it first looks in /etc/emulationstation if it finds one.

Normally, certainly the screen is small and the resolution is not huge, but we can still see something. (And that’s a guy with glasses who tells you that!)


I have now… Unfortunately, I still can’t get anywhere…

cpi@clockworkpi : ~/EmulationStation (master) $ cmake .
-- Looking for FreeImage...
-- Checking for module 'freeimage'
--   No package 'freeimage' found
-- Found FreeImage: optimized;/usr/lib/arm-linux-gnueabihf/libfreeimage.so;debug;/usr/lib/arm-linux-gnueabihf/libfreeimage.so
-- Could NOT find Threads (missing: Threads_FOUND) 
CMake Error at /usr/local/share/cmake-3.14/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Call Stack (most recent call first):
  /usr/local/share/cmake-3.14/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /usr/local/share/cmake-3.14/Modules/FindCURL.cmake:143 (find_package_handle_standard_args)
  CMakeLists.txt:58 (find_package)
-- Configuring incomplete, errors occurred!

See also "/home/cpi/EmulationStation/CMakeFiles/CMakeOutput.log".

CMake Error: Unable to open check cache file for write. /home/cpi/EmulationStation/CMakeFiles/cmake.check_cache

cpi@clockworkpi : ~/EmulationStation (master) $


Seems you need to install curl package


According to apt-get, curl is already installed.


Here is what it looks like with pixel-tft chosen. It doesn’t really matter which theme I choose, they all sorta look like this:

Settings menu:

I opened es_settings.cfg again and noticed that ES has fully populated it, so that looks good now.

Is there some step you took to make the fonts readable and the graphics recognizable?


lasvegas, do you know which OS version you started with? I had luck with v0.3 … Initially had some trouble with cmake with some missing packages but Dowdheur updated the tutorial, and it worked after that. I have not tried any previous versions to 0.3


Okay… I didn’t except that :hushed:

Did you try to change the GPU driver ?


Yes, Fbturbo gives the same result as Lima. Strange. I have actually built ES twice now with the same result.


I was running v0.3. Unfortunately my attempts at installing freeimage, ended up breaking the screen drivers. Nothing after the initial boot screen. I need to start over…


I received a new GameShell today. I made a backup of the stock image on the SD card, then proceeded to follow your tutorial and got a working, legible ES install, screen looks normal. I believe the stock SD has OS 0.21 installed, but I do not know how to check that. I am going to spend some more time configuring ES and this GS in general, but I may try upgrading the OS to 0.3 and see if I get the corrupted screen issue again. But for now, it looks normal. Thanks for all your help!


Okay! I got EmulationStation to install into a new install of clockworkos_v2.1.

It launches, but I get a configuration screen to assign keys. Unfortunately, the GameShell doesn’t have enough buttons to assign every function. Is there a technique to skip entries? Or better yet, does someone have a config file will the keys already assigned?



I believe that holding any button for several seconds will skip a keymapping entry. In this way you can skip functions you do not want to map to buttons by holding any key.


Cool! I got it up and running. Unfortunately, I can’t get it to run any ROMs from NES or SNES…

Edit: Got it. Typos in emulator paths.


Cool ! Good news :slight_smile:

Please check my launch script, it could be useful for ya ! :wink:


Confirmed. ES runs fine for me with 0.21 but the display is corrupted with 0.3 installed.


Hi. Great tutorial.

I have compiled emulationstaton on 0.21 and set up es_systems.cfg and gamelists.xml following your example. Also got ES icon on clockworkpi screen.

When I run emulationstation, I get an error initializing SDL. No available video device. Window failed to initialize followed by a segmentation fault:

Any ideas?



Did you get the resources folder in .emulationstation ?

Verify the owner and the permissions of the folders