GameShell OS image files (v0.4 latest)

Try loading more than 8 gigs of data to it and let me know if it starts to slow down. I suspect the partition is extended but I don’t think the file system is expanding. Either that or the launcher cant function when you have 10k+ roms.

I tried gParted from Ubuntu, being careful to set the size a direct multiple of 2048. It booted the first time! I had 60G+ and it looked good… Then I rebooted… Again to the Login/Password screen. For some reason, it lost auto-login.


Did you load roms onto it during that time? I don’t have trouble booting unless I load too much content onto the device. The system seems to need some headroom.

@LasVegas Autologin still works for me - I didn’t set the multiple of 2048 though… Just maxed out the partition.

@DisruptItYourself I’ve also had short freezes when trying to scroll through my ~300 GBA roms on the preinstalled 8GB card. I’m not an expert but my guess is the launcher is the culprit here. It felt like it needed to read the next page of roms when I scrolled so it stopped for a second or so before it became responsive again.

1 Like

When I was using my 64 gig card with an extended partition it would show that I had 50 some odd gigs available and about 7 gigs used. As soon as I had more than that, 8-9 gigs for example, it would prompt for a log in. Then I deleted those files over SFTP (fortunately it was still connecting to wifi on boot) and rebooted and it wouldn’t prompt anymore.

Now I have a 16 gig card that I did the following:

  1. burned the original 8gig image to
  2. Extended the partition with gparted on ubuntu VM
  3. Transferred my files over
  4. booted up for the first time (I think that might be the critical part)
  5. Now I have 8.1gigs used of 14.4 and no problems

So as I mentioned I suspect the key was not booting it up the first time until I had already extended the partition. I think the file system expands on first boot and will allocate things based on the size of the volume at that moment and then not quite figure it out when you extend the partition later. You wont notice this issue in my experience until you have more than 8 gigs or so on your card.

Id love to have someone else test this. I am curious if it has anything to do with the size of the card as well. Maybe 64 gigs is too much without optimizations.

I’m having an issue writing the OS file to a formatted MicroSD. It’s the 8GB one that came with it. I formatted the SD using the standard windows options on FAT32, and when i’m trying to write it to the SD I get a “Write Error” at around 0.9% every time.


I fear your SD card is dead, but try it on another device / card reader just to make sure, but SD card have a bad habbit to switch to a read-only mode if something happen, and you will never be able to write to them anymore…

Try formatting it with this:

If a tool like Rufus which is doing low level access can’t write, I’m not sure it will do something, but well still worth a try.

SD card that fall into a permanent Read Only mode is quite common in the rPi world, and generally a sign that the SD card has been abused, like repeated switch on/off without proper shutdown sequences and other things.

SD card are quite fragile in fact and don’t need a lot to become useless :frowning:

complying with the SD File System Specification created by the SD Association (SDA).

It is strongly recommended to use the SD Memory Card Formatter to format SD/SDHC/SDXC Cards rather than using formatting tools provided with individual operating systems. In general, formatting tools provided with operating systems can format various storage media including SD/SDHC/SDXC Cards, but it may not be optimized for SD/SDHC/SDXC Cards and it may result in lower performance.

That is to format your SD card in FAT format (or ExFat), useless when you do low level write like using rawwrite, dd or rufus.

The only thing the SD card app can do, that most formater can’t is if your SD card support it and you have compatible reader, it can try to issue some SD card command for low level format the SD card (asking a proper flash erase in the SD card) but I never found a couple of card and reader that support that functionality, and basically all USB reader does not support that.

What I was speaking about:

So I used Etcher and it worked flawlessly. Still had it formatted with Windows too. For some reason Rufus just didn’t want to do it. :thinking:

1 Like

To write the image in Mac OS, using Terminal:

macos$ diskutil list (to determine which disk is your microSD)
macos$ diskutil umountDisk diskX (where X is the disk number)
macos$ dd if=<path to dmg> of=/dev/rdiskX bs=8m (again, X is disk number)

That’s it! You’re ready to go.


1 Like

Can anyone else try loading more than 8 gigs worth of content and seeing if they have issues? And if so then try following my instructions from my previous post:

Now I have a 16 gig card that I did the following:

burn the original 8gig image
Extended the partition with gparted on ubuntu VM
Transfer files over
boot up for the first time (I think that might be the critical part)

Yes. I copied the original 8GB image to a 64GB microSD. The booted Ubuntu and ran gParted to expand the CLOCKWORKPI partition to fill the card. This time it worked. It took all updates and changes. A bit of a pain to start over, but worth it…



You aren’t understanding what I’m asking.

So far, I’ve only used 6GB of 58.4GB (89% Free). I’ll be adding to it to see if there are any problems. I’ll keep you informed…


Thanks. I have a few large MAME games and a couple hundred GBA and SNES roms. I also have a few dozen NES, NGPC games and all of those are in the launcher. At least have one folder with 100+ roms and another with some large files like MAME if you can.

Remember that your RAM is very limited. Very large games may not load at all.

I haven’t had any problems with that yet but I’ll keep that in mind.