clockworkpi

How to install PICO-8 on GameShell

The directory exists. It’s just not normally visible since its name starts with a period. SSH into the GameShell and enter the following:

cd ~/.lexaloffle/pico-8/carts
ls

20190512_122003_HDR

You are trying to install the newest version of PICO8.
Try to update launcher and check If you have your versions of PICO8 inside this file https://github.com/clockworkpi/launcher/blob/fb156214f96811d8afb9be01cd6944ef5ef1612d/Menu/GameShell/50_PICO-8/compkginfo.json or just replace that file with versions from GitHub

Open compkginfo.json in any text editor and replace content with that:

{
"GameDir":"/home/cpi/games/PICO-8/",
"InstallDir":"pico-8",
"NotFoundMsg":["Please purchase the PICO-8 \n|None|varela16",
"and copy it to the \"~/games/PICO-8\"|None|varela16"],
"MD5":{"pico-8_0.1.11g_raspi.zip":"a3f2995cf117499f880bd964d6a0e1f2","pico-8_0.1.11g_amd64.zip":"6726141c784afd4a41be6b7414c1b932","pico-8_0.1.12_raspi.zip":"08eda95570e63089a2b9f5531503431e","pico-8_0.1.12c_raspi.zip":"1a62b0d7d4e4be65f89f23ec9757cb66","pico-8.zip":"whatever it takes"},
"Post-Up":"bash Post-Up.sh" 
}

The problem could be that your file doesn’t contain line with pico-8_0.1.12c_raspi.zip.

Yes. I kinda figured it out by myself but thank you so much for replying.

Thank you for the walk through! I got PICO8 up and running, start and select are working, but ABXY are not. Rebooting the Gameshell doesn’t seem to fix anything. Any thoughts?

Hi,

Since I am totally new to this could you please explain this further in a detailed manner.
Maybe a video showing each step? I am unable to understand how to go about installing this.
I know how to SSH into the gameshell.
From there I copied and pasted

sudo pip install pyxhook

I received this message:

Requirement already satisfied: pyxhook in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied: python-xlib in /usr/lib/python2.7/dist-packages (from pyxhook)

How do I proceed from here?

Please help me as I find this code really useful when playing Pico8 games.

Thank you.

pico ~/.lexaloffle/pico-8/config.txt

“Pico” is a simple text file editor available on most Linux systems, including GameShell. It has nothing to do with PICO-8, it’s just called “Pico” by coincidence.

Use the cursor keys to scroll down to the line that says fullscreen_method. Edit this value to 0:

fullscreen_method 0
Scroll down further to the line that says button_keys. Edit this value as follows:

button_keys 0 0 0 0 13 14 0 0 0 0 0 0 0
Press Control-O to save the file. Press Control-X to exit Pico.

Made an overview on how the installation procdure currently works. Along with an obvious pitfall associated with the recent PICO-8 update:

1 Like

I have updated the original tutorial at the top of this thread to use the new built-in installer, including the file renaming workaround for Launcher v1.24. It’s much fewer steps now!

I also added links to krystman’s videos to the Resources section. Thanks Krystian!

I’m so excited that Launcher has this built in. Thank you ClockworkPi!

P.S. I believe the Launcher v1.24 “MD5 error” screen has the Continue and Cancel buttons swapped. I only tried it once but I believe I had to press B (right button) to Continue even though it says “A”.

2 Likes

Thanks for the issue

Has been fixed #214

I tried to update to the latest PICO-8, but now it won’t even open at all. Which files should I delete or restore in order to perform a clean install?
Can I clear out /launcher/Menu/GameShell/50_PICO-8?

~/launcher/Menu/GameShell/50_PICO-8/.done

2 Likes

perfect! Thanks, Now I can play a lot of the newer games.

I’ve been trying to get Pico-8 running all evening, but it always goes back to the launcher when I start it.
I’m on v0.3 with launcher version 1.24. I’ve installed Pico-8 with no problems (version pico-8_0.1.12c2_raspi), but still it won’t boot. I also made sure all the files had the correct permissions.

Do I maybe need an older version of Pico-8?

No actually you just gotta Change the name of the zip file, https://youtu.be/ltBVKFw88zw

This is what I used @Rebusmind

I did that, as I said, Pico-8 installed just fine, but when I execute it after installing, it just goes right back to the launcher. I also checked the path in the sh file and it seems correct.

try ssh into gs

you can directly run the pico8 in ssh to see if there is something wrong

cd /home/cpi/launcher/Menu/GameShell/50_PICO-8
./PICO-8.sh
1 Like

Ah, I forgot to set the file permissions for the sh file as well… thanks for your help. :slight_smile:

Damn, after fixing the permissions it runs through ssh but still not through the icon. :frowning:

Also, when I start Pico-8 through ssh it still dims the screen after a few seconds (I’m using “Power saving” mode) and the ABXY buttons don’t respond. When I pressed Select, the image turned black and nothing responded anymore.