clockworkpi

Let's play Brutal Doom!

Damn, hahaha you read my mind! Actually I just found my easy way to modify my zdoom.ini, just tried Brutal doom and 4 Vanilla and it worked flawlessly.

And as I said before I do use the light bar (I’m trying to get used to it, I really don’t like the cables hanging out freely) I’m looking to make a proper fps feeling, that mouse mod really looks promising, I’ll try it and see how it improves the gameplay !

1 Like

@Officerpug
I already did all the steps before, just FYI
How’d did you make this work?
And where did you find the zdoom.ini?

Thank you

@HalfBlood zdoom.ini can be found in the directory /home/cpi/.config/zdoom,
You could just edit it’s global.autoload feature for Brutal Doom or D4V in it, or actually any mod combination you’d want to try out.
Under Global.autoload the correct path to look after the mod itself would go on like this:
Path=/home/cpi/games/ChocoDM/brutalv20b.pk3

No problem man, hope it helps!

1 Like

Appreciate your response @Officerpug , but after installing @javelinface cleaner way for zdoom the .config folder is nowhere to be found. But the zdoom and brutal doom apps work fine though

Hmm, there’s nothing in the script that removes the .config folder. That contains pretty much everything that is configurable for /usr executable files.
The dot before the config folder implies that it is a hidden folder. Have you got hidden files enabled?
Do you mean the action.config file? I made a change to the script to have it install to the 20_Retro Games folder, since it clashed with the pre existing bug in the clockwork OS launcher, re: making the Retro Games folder go missing.

On another note, another amazing mod called “Zion HD” works well. It’s a fairly chunky mod, weighing in at 709.6MB.

I did notice however, I had a small syntax error. I had under the extensions: wad, WAD, pk3, PK3. It should have been: wad,WAD,pk3,PK3. Ie, no spaces. It’s been updated. It doesn’t affect things that much honestly, but worth noting.

3 Likes

Hello again @javelinface , I modified my action.config as mentioned before. Now I’m able to see my pk3 and wads on my zDoom app.
And I thought that would improve the way I was actually looking for my mods rn.
But I really don’t know why but when I click on my pk3 or wad mods, a List with the legend: “ZDoom found more than one IWAD select from the list below” appears and
I can’t select none, since pressing ABXY or any of the buttons on my Light Bar, for some reason act as a keyboard. And if I press START it launches the normal DOOM wad I’m highlighting. How can I apply the mod this way or am I missing some steps?

Mm that’s where I’ve taken the mouse mod route, and activated it to click on the box. It’s basically a dialogue box. I think you may also be able to select it with up and down, and push START which simulates pushing enter. It’s no longer using the launcher bindings for the ABXY keys, but the literal keyboard keys that each ABXY button represents, ie letters.

I did install the mod you suggested for the keypad, but I don’t know if it’s supposed to work like this, when I press double shift, It indeed feels like I’m using the mouse, since when I press the A button It selects what I’m supposed to be above on that moment. But I can’t see the mouse pointer. So still no luck for me on that part haha :frowning:

Edit: I think I found how to select the mod and press OK, but still won’t launch the mod. It opens the normal Doom Wad. Damn.
Edit2: MouseLook inside Doom works fine, I guess I did install the mod correctly.
Only problem is that still can’t load the mod this way.

What I’ve got is a separate action.config that allows you to select the mod. For the doom 4 mod, you might need to add *.deh or whatever the format was to the list. However that only lets you easily select one. You can’t choose all the weapons individually. Probably best to just have a separate script per selection on the gameshell.

mkdir -pv /home/cpi/apps/Menu/20_Retro\ Games/07_zdmods
printf %s "ROM=/home/cpi/games/ChocoDM
ROM_SO=
EXT=pk3,PK3,deh,DEH
LAUNCHER=zdoom -width 320 -height 240 -file
TITLE=ZDoom Mods
EXCLUDE=
SO_URL=" > /home/cpi/apps/Menu/20_Retro\ Games/07_zdmods/action.config

I think the extension was deh right? It’s been a while since I’ve tried that mod haha! Also, I’ve gotten rid of the extra space bar after each comma in the ext list. I gotta stop doing that!

2 Likes

I think I’m lost now. I don’t want to use more than one mod at the same time.
My action.config on my 05_ZDoom folder is this way rn.

ROM=/home/cpi/games/ChocoDM
ROM_SO=
EXT=wad,WAD,pk3,PK3
LAUNCHER=zdoom -width 320 -height 240 -iwad
TITLE=Zdoom
EXCLUDE=
SO_URL=

Don’t need to add the “.deh” ext since I’m actually using the “.wad” version of that same mod. Using the zdoom.ini “path=” method loads it correctly. But when I want to select in from the drop list on my Zdoom it wont load. Don’t know what to do now haha

You have to add the link to the .SO file in the last line I think. It should be (assumption here) in the same location as Javel’s one if you followed his instructions;
SO_URL=" > /home/cpi/apps/Menu/20_Retro\ Games/07_zdmods/action.config

Instead of the action config, if you don’t want to use it, put the .so there and put the name in the file.

Otherwise it will not be able to find the emulator needed.

1 Like

The last line is only needed if you’re using a fresh system, where you don’t have the .SO downloaded. It’s mainly for retroarch based cores, where you download them on demand. We’ve already gotten this defined, and installed to the /usr directory.
And all good! It should work, if you use get rid of all the references to the deh files. In fact, if you don’t have any deh files in your directory, it won’t even list them.

The line you need to modify is LAUNCHER=zdoom -width 320 -height 240 -iwad
Where the final argument is what determines what you load.
If you have -iwad as the last argument, then it will load a WAD file.
If you have -file as the last argument, then it will load a mod. You can then specify what you want. Eg.

Having doom2 as the base WAD, and having your choice of mod:

ROM=/home/cpi/games/ChocoDM
EXT=pk3,PK3
LAUNCHER=zdoom -width 320 -height 240 -wad /home/cpi/games/ChocoDM/doom2.wad -file
TITLE=Brutal Doom
EXCLUDE=
SO_URL=

Having a mod specified, but the ability to change which wad to use:

ROM=/home/cpi/games/ChocoDM
EXT=wad,WAD
LAUNCHER=zdoom -width 320 -height 240 -file /home/cpi/games/ChocoDM/brutalv20p.pk3 -iwad
TITLE=Brutal Doom
EXCLUDE=
SO_URL=

I’ve removed extension of things that won’t load with the last argument to make things make more sense.
You can keep the SO_URL= field empty. That’s usually a URL to a zip file.

I’ve included the resolution in the launcher field, in case you ever need to delete your zdoom.ini file, and run into trouble not having the correct resolution.

2 Likes

Thank you man, but in the end I only changed this on my action config.

ROM=/home/cpi/games/ChocoDM
ROM_SO=
EXT=wad,WAD,pk3,PK3
LAUNCHER=zdoom -width 320 -height 240 -file
TITLE=Zdoom
EXCLUDE=
SO_URL=

Just tried changing that final argument as Javelinface suggested.
And everything works wonderful now! I can select which mod I want to use everytime I open the app. Already tried a handful. Sad that Bloom, Goldensouls 2 and other more advanced gameplay mods didn’t work but surprisingly my fav 2016’s Doom rip worked SMOOTH as butter. Also ! @javelinface you should try it!
Titan 2016 Doom rip Mod
I couldn’t believe how SMOOTH it works! Brutal Doom lags A LOT. So I didn’t want to try Zion since it uses a lot more of resources. And also I don’t really like much how it looks, compared to Titan which even if it’s still in Alpha. It’s models are a lot more cleanly ripped. Would recommend it to anyone wanting to try some mods! Since everything works beautiful now. I’m moving to try me some Quake. Already installed quakespam, but when I open the app my screen flashes the gameconsole. Guess I’ll go and ask in another thread. Thank you everyone for your help!

1 Like

Thanks for the recommendations! It’s been a while since I’ve messed with lots of doom mods!

Just be careful. Loading wad files with the -file parameter may end up problematic. Also, for my predefined action.configs above, change the doom2.wad file name as needed. Eg, DOOM2BFG.WAD is what I use, including caps.

For the record, Zion works lag free, despite how chunky it is. Basically just a huge initial load, taking about 15 seconds.

Not side tracking too much, but quake 2 runs practically 100% problem free. Quake 1 is buggy, with slow downs and graphical glitches. Just pointing you in the right direction before you start on the wrong foot. I’ll see you in the relevant thread! :wink:

Woah… ChocoDM support Doom Mods and PK3’s, this is new ?

Does it? If you’re referring to my action.config, it’s still using zdoom, ie in the launcher section. The reference to the chocoDm wad directory is just using the assumed default directory a vanilla gameshell has, just to avoid creating extra directories.

Ah ok I missed that part. lol

Hm… Just to be sure, what could go wrong for me to be using the -file parameter?
Just wanna know if something ends up broken, where to start digging when I try to fix it.
You say it may end up being problematic. So maybe it won’t too? Haha

Just that if the last thing on that line is -file, it will assume that whatever you load is a mod. If you load a wad instead, it may clash with whatever wad is already in place. I’ve just modified the action.config to not display wad files, to avoid that happening.

Ah! That last part ie,

SO_URL=" > /home/cpi/apps/Menu/20_Retro\ Games/07_zdmods/action.config

is just the tail end of the code required to write the printf file, telling the file name and location to be written out. It doesn’t appear in the written action.config.

On another note @Officerpug, here is a config that will load a specified wad, and then let you choose whichever mod you want to use. Just change the “doom2.wad” to whatever file you want to use as a base.

1 Like