Running Clockwork OS in a Virtual Machine - How to?

Would like to try to use OS v.021 in a virtual machine to understand it more. Saw this thread

where SVIN_24 seems to have gotten it to work. Is there a more recent or more explanatory post on this right now or is this the recommended path currently?

All advice welcome.

1 Like

if you dont mind the kernel
you can start the clockworkpi os v0.21 with qemu and debian net boot kernel

qemu-system-arm -M vexpress-a9 -m 512 -kernel vmlinuz -initrd initrd.gz -dtb vexpress-v2p-ca9.dtb -drive file=./armdisk.raw,if=sd -append "console=ttyAMA0,115200 root=/dev/ram" -serial stdio -net nic,model=lan9118 -net user

just a tip,not fullly tested

This does NOT work. I have tried using the debian net boot kernel and replicated exactly as you have it here, I have also tried converting the image to a qcow2, I will have to try the method posted elsewhere where its more or less merged with a debian image, but I don’t feel it should be that much work to get this working. the fact that I can’t even get the kernel to boot seems to be the issue. I will come back to this once i have it at least semi working and will likely put together a tutorial for v0.3


Thanks Ducky. Please message me with your progress on this.

so update, there seems to be issues getting the a7 working in qemu. I have tried the kernel in the 0.3 image, I have tried the arm and the arm64 debian kernels and it does not boot. I am now looking into the kernel itself (the uboot image) to see what I’m missing. the machine type of vexpress-a9. so far it’s looking the the method of creating a debian arm64 virtual machine with the same userID and then copying the home folder over might be the only way thus far. I will do that and if its working upload the image as well as instructions on use/etc for everyone, but I will continue to pluck away at getting the actual proper image to boot. as a semi side note, looking into how a uImage is created i think it itself might be an image that contains the kernel and initrd. more research required.

1 Like

another update. the entire build seems to not want to work. I have determined that its not just a kernel issue but it seems there’s some stuff done to pack up the kernel with the sunxi image tool. I’m going to attempt to “rewind” that and see if i can get a usable kernel from that. it also seems like there is no init.rd as it’s a live mounted system from the start and that does simplify things if I’m right. hope to have more information soon.

1 Like

and of course another update. extracting the uImage reveals just a kernel which is not very helpful. I am going to go about creating a complete setup using the debian VM i created. it wont be the same, but it’s something developers can use.

1 Like