[SOLVED] I can't do an apt update. How to fix?


#1

I can’t seem to install anything through apt-get in clockworkos_v0.21. When I attempt to do an apt update, this is the result:

cpi@clockworkpi:~$ sudo apt update
Ign:1 http://cdn-fastly.deb.debian.org/debian stable InRelease                                                           
Ign:2 http://cdn-fastly.deb.debian.org/debian stable-updates InRelease                                                   
Err:3 http://cdn-fastly.deb.debian.org/debian stable Release
  Unable to connect to cdn-fastly.deb.debian.org:http:
Err:4 http://cdn-fastly.deb.debian.org/debian stable-updates Release
  Unable to connect to cdn-fastly.deb.debian.org:http:
Ign:5 http://security.debian.org/debian-security stable/updates InRelease
Err:6 http://security.debian.org/debian-security stable/updates Release
  Unable to connect to security.debian.org:http: [IP: 149.20.4.14 80]
Reading package lists... Done
E: The repository 'http://cdn-fastly.deb.debian.org/debian stable Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://cdn-fastly.deb.debian.org/debian stable-updates Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://security.debian.org/debian-security stable/updates Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
cpi@clockworkpi:~$ 

EDIT: It turns out that I need to have the GameShell connected to the computer to access the USB-ETH connection. It won’t work via WiFi for some reason. Once connected, it updated okay.


#2

I guess that its not working over wifi because of the default gateway, check the gateway.


#3

Yes. I figured out that it was the fact that I’d set the dns-nameservers in the usb configuration. I commented out that line in /etc/network/interfaces and it resolved the issue.