I've rewritten DevTerm keyboard & trackball firmware

sudo apt install dfu-util -y

wget https://github.com/clockworkpi/DevTerm/raw/main/Code/devterm_keyboard/bin/DevTerm_keyboard_firmware_v0.3_utils.sh

chmod +x  DevTerm_keyboard_firmware_v0.3_utils.sh

sudo ./DevTerm_keyboard_firmware_v0.3_utils.sh

an update, to fix the mouse mid button conflicts within scrolling mode
disable mouse mid button click while scrolling

18 Likes

Soooo nice to have a useable mouse! TY!

2 Likes

Wow! This is much better than the original firmware! Nice work! Finally the mouse pointer is not jumping!

2 Likes

I installed this right into the machine rather than through SSH. It installed correctly, and I rebooted. The trackpoint is much more navagatable now. I don’t observe any change to the keyboard. All three selector buttons for the trackpoint function as expected.

2 Likes

Is it possible to make it scroll any faster? I’ve got the speed/acceleration turned up to max and still having to scroll half a dozen times to get the pointer an inch across the screen.

Massive improvement! Thanks! :slight_smile:

Have you installed the firmware update as per these instructions? I can travel the entire width of the screen in one swipe with the latest version - though vertical’s a little dodgier.

Yes. After rebooting it behaved a little better, but now both keyboard and trackball are completely inert. I’m having to get around with a USB mouse I have lying around, but I can’t enter passwords or anything.

Did you try reseating the keyboard on the pogo pins?

Also a thing I like to do to see if its something with the firmware or bad positioning is take it out and connect it to the devterm usb throught the keyboard microusb. If it works fine like that, its 100% connection issue with the pins

Just now reseated it in case it was that, yes, and it works. Not sure how that happened. But the trackball is still misbehaving. Maybe I’ll try reflashing it again in case it didn’t take.

This is better, but for me the trackball is a little finicky sometimes. I have a hard time making it go left. Often it will reach some kind of limit and stop there. Going right works fine most of the time. I don’t know if it’s a hardware or firmware problem, so looking for how to revert to the stock firmware to test. Sometimes if I press a bit harder it works better, so maybe it’s a hardware problem?

1 Like

Woah! This is soo great!

Since I received my a04 on Thursday, I’m quite the noob and would really appreciate things like these being listed in some kind of “getting started” guide since this was a bit hard to find.

2 Likes

Lately it’s doing better. I wonder if use has worked free something that was impeding it.

1 Like

I consider it a fallback for when I don‘t have my mobile mouse handy.
I have yet to see a trackball that small working really well…
Considering the size I am astonished it is usable at all :laughing:

1 Like

Just another note to say thank you for this!

I was really disappointed with the trackball the day I build my DevTerm but now it’s usable :slight_smile:

2 Likes

Running this updated FW and I have noticed that the CAPSLOCK key does not function correctly, does anyone else have this issue? I have also noticed that the gamepad buttons do not register as keypresses that will prevent the screen from sleeping. Is this due to how the gamepad buttons are handled in the FW?

Has anyone noticed that some key combos are locked out? Specifically, I’ve noticed it’s impossible to press both up arrow (or down arrow) and left arrow (or right arrow) at the same time to get diagonals. If one is pressed then the other is ignored until the first key is released.

Is this something that could be fixed in the firmware?

The arrow keys are not that comfortable to use this way anyway, but I’ve found myself trying to and then being disappointed when they don’t work in a game, etc. The gamepad at the top does work for diagonals (I didn’t switch mine with the dip switch so it’s still seen as a joystick), but the gamepad is so difficult to use and uncomfortable it’s not even worth trying. The ESC key is also dangerously close to the gamepad, so when I have tried to use it I often found myself either quitting out of whatever it was I was doing, or at least bringing up a menu to disrupt things. It’s definitely something worth remapping in software if you plan on using the gamepad.

Awesome work! The glitchy trackball was the only and first issue i noticed after assembling my DevTerm.Can any of you guys give a feedback if the overall resolution of the trackball improves with this patch? I noticed that small movements of the trackball when selecting fine details often results in a more or less “jumpy” behaviour. Sometimes it is impossible to select small checkboxes because the curses jumps ~ 20-30 pixels at the same time.

Can anyone share his/her observations?

Thanks ans greetings

Nico

1 Like

On the stock firmware, if you hold down the Fn key while using the trackball it engages “fine precision” mode - removing those jumps, but making it move really slowly.

On the community firmware, there’s no need: default behaviour works for both small movements and big ones.

2 Likes

Has anyone noticed that some key combos are locked out? Specifically, I’ve noticed it’s impossible to press both up arrow (or down arrow) and left arrow (or right arrow) at the same time to get diagonals. If one is pressed then the other is ignored until the first key is released.

I just noticed this, myself. It’s pretty frustrating and makes a lot of things not work. I’m looking into it myself but if somebody with more of a grasp on the code wanted to take a look I would really appreciate it!