DevTerm CM4 keyboard not functional after attempting to fix trackball

The trackball on my newly arrived DevTerm CM4 was barely working. It would work fine left and right, but up and down basically didn’t function at all. so I pulled it out and reseated a bunch of stuff inside. that didn’t work, so I tried to flash a different firmware to fix the trackball. Now the keyboard is not being detected at all. It’s not stuck in bootloader mode (no flashing light) and I would really rather not wait for an ST Link thingamajig to arrive to try that, if that would even work at all since this problem doesn’t seem to be encountered by anyone else. Is there anything I can do or am I stuck with a very cool looking case for an rpi cm4?

Hi. I have the exact same issue. I just got my devterm as well. Trackball worked (some dodgily) initially … But then the x-axis gave up the ghost after less than an hour of use. I determined it’s a mechanical issue. But, after reading your post, will not attempt to fix. Have asked Clockwork pi if possible to get a replacement.