Picodrive (standalone and libretro core) Mega Drive emulator

Thanks @lasvegas, I was too lazy last night to write instructions about it. Just some corrections

there is a space missing in the mv command (between the .so and the /home/cpi:

mv .config/retroarch/cores/picodrive_libretro_gameshell_v1.92.so/home/cpi/apps/emulators/

should be:

mv .config/retroarch/cores/picodrive_libretro_gameshell_v1.92.so /home/cpi/apps/emulators/

Add some more extensions not just bin, zip in the action.config. The SO_URL is obviously wrong but I guess we don’t mind.

ROM=/home/cpi/games/SEGA 
ROM_SO=/home/cpi/apps/emulators/picodrive_libretro_gameshell_v1.92.so 
EXT=bin,zip,gen,32x,smd,iso 
LAUNCHER=retroarch -L 
TITLE=SEGA 
SO_URL=http://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/picodrive_libr$
3 Likes

Thanks @elefas… Corrected in my post. Cool that more formats are supported!

1 Like

Great work!
I have create a menu!
Thanks @lasvegas @elefas

1 Like

Updated original post with standalone version coming in two flavors in rendering: software and opengl!

How could I install this emulator to appear in the “Retro Games” folder? So I would have it with other emulators such as PCSX.
PS: Can you tell me how to change the icons for ones in which the system appears? Any post with those icons, if it’s not too much trouble?
Thank you!

Hi! The Retro Games folder contains RetroArch emulators (cores). There exist a PicoDrive RetroArch core so you can either create a similar menu for this core following the instructions a few posts above: Picodrive (standalone and libretro core) Mega Drive emulator

If you still want the PicoDrive standalone emulator to appear in the Retro Games menu ssh to GameShell and do:

 curl -sL https://github.com/pleft/picodrive/releases/download/v1.92-gameshell/PicoDrive.tar.gz | tar -xvz --directory ~/launcher/Menu/GameShell/20_Retro\ Games/

And here are icons for most consoles:

5 Likes

Hi. A question. Does the Core “picodrive_libretro_gameshell_v1.92” also work on OS 0.3 with Lima?

it should work, but don’t forget that the lima drivers are unstable currently so you may get varying results

You still can use standalone PicoDrive just like RetroArch. I tried with such action.config

ROM=/home/cpi/games/SEGA
ROM_SO=
EXT=7z,bin,gen,md,smd,zip
LAUNCHER=/home/cpi/launcher/Menu/GameShell/20_Retro\ Games/PicoDrive/PicoDrive
TITLE=SEGA
SO_URL=

quick question here… where should I put the bios files for 32X?

The BIOS location is identified in RetroArch’s configuration. You can find it at RetroArch->Settings->Directory->System/BIOS. Mine is set to /home/cpi/games/retroarch/system

1 Like

I did Las Vegas and your steps the way you guys said, but every time I boot up a rom it tells me that picodrive_libr$ Download failed. What do I do?

@elefas forgot to tag you

Doesnt work.

tried all the cores all the video drivers every plugin all i get is reboot

Did anybody get Picodrive to work in the latest v0.4 update? For me the standalone version gets stuck at the loading screen (the one you get after you agree to configure the game engine automatically). While the retroarch core crashes immediately.

Didn’t have time to check with 0.4 OS so I don’t have any suggestions. Only try to use the fbturbo driver rather than the Lima one.

Are you on v0.4? I think it is a v0.4 issue

I was able to get it working. I was browsing through the clockwork files using WinSCP (makes connecting to the gameshell so much easier for me) to see if I could find anything, and found the action.config file for PicoDrive. In there I found the URL that the gameshell wouldn’t download for some reason. Pasted the link in my browser, and it downloaded the file without issues. I then extracted the zip file, and placed the .so file into /home/cpi/apps/emulators folder. I also put the zip file itself, which probably wasn’t necessary, just because. Lastly I reloaded the UI. Everything now seems to be working flawlessly. Here’s the link for the core:

https://github.com/cuu/picodrive/releases/download/v1.92-gameshell/picodrive_libretro_gameshell_v1.92.zip.

Also be sure not to change any names as they need to be exact. Hope this helps anyone else on 0.4!

Thank you sir, you made my day :slight_smile:

1 Like

No problem man. Glad to help.