A few general emulator queries


#1

I can’t get Picodrive to run any games. I load the core, then load the content and it flashes up ‘Loading’ then it goes back to the Gameshell OS. the games are unzipped and are in .md .smd and .bin formats. tried them all, but none work. Does it possibly need a bios file?

Speaking of bios files, where do they go? I can’t get any NeoGeo roms to work, puting the neogeo bios in with the game roms doesn’t work. I’d also like to use TR-DOS with Fuse. I have the bios files, but I’m at a loss as to where they should go.

My only other query is about Scummvm, anyone got it working?

Thanks,
Ali


#2

Picodrive has been known to crash. Avoid for now, and use genesis_plus_gx instead. It’s a bit creaky but it does run.

Make a folder called bios in your games folder (the one that you can access from your computer) and bung all the bios files you need in there. Check the libretro site for info on any bios ROMs you need. Next, go into retro arch, and go into Settings, then Directory. Find System/Bios (top of the list hopefully) and find the directory you just put all your bios ROMs into. Basically you can put your bios ROMs anywhere you like do long as you tell retroarch where they are. I would recommend personally, putting it on the games folder because it’s a whole lot easier to add and remove bios ROMs.

As for Scumm, I’m sorry, I can’t help you there, I haven’t even tried it out myself.


#3

Cheers. Yeah Genesis Plus does the job fine, was hoping to see what performance differences there might have been between the two. I usually use Picodrive on my GCW Zero.

Also thanks for the bios info. I’m starting to get pretty good with working my way around Retroarch now, so all the info you gave me makes perfect sense.

Ali


#4

I got ScummVM to work only through installing it natively (opposed to using it through RetroArch). It does run, I tested 2 games (broken sword and beneath a steel sky) but they have a larger resolution and won’t fit on the screen.

I couldn’t find a way to downsize, I’m not even sure it exists because it’s a bad idea, obviously, even if I’d like to try it :slight_smile:

Also didn’t get around to emulate the mouse through the keys. It didn’t seem easy to do and as I couldn’t play because the game won’t fit in the screen, I just forgot about it :frowning:

I’m super happy with the GS though! Maybe we can get a higher resolution screen in the future.


#5

It’s a bit like that on my Pocket Chip. Resolution problems with some games and control problems if you had it set to full screen. My GCW Zero does quite a good job though, although the small screen size makes spotting some game items almost impossible.

Yeah, loving the GS. The GCW Zero performance is better, but it has just a single core, so I imagine with a bit of time, the GS should beat it and run some of the emulators more smoothly and with better sound.

As for my Pocket Chip, still love it, it had so much potential but NextThing made a bit of an arse of it. That said, it is the perfect platform for playing all the old z-machine text adventures :grin:


#6

I managed to make the ScummVM core work on RetroArch on the GameShell. Check it out if you’re interested: https://forum.clockworkpi.com/t/running-scummvm-games-on-retroarch/1776. Cheers!