3DO core doesn't load

I downloaded and installed the “4do” 3DO core through the “Download core” menu in RetroArch but it doesn’t load. I get no error or anything on the GS screen, simply doesn’t load. I get back to the core list menu as if it had loaded, but on the “status bar” on the bottom it either says “No core” or sticks to the previous loaded core.

Has anyone had success with emulating 3DO?

Some of the cores that are for download do not work on GS. You may try to compile it on your GS.

I will try it out this evening, looks like 3DO is having some interesting games.

Indeed. I didn’t even know about this console, don’t know why, I discovered it since searching for games for the GS, and indeed it has several games I want to try!

The original core for download does crash, I did compile from github 4do source, this one is working. However I have not yet managed to start a game. I have all that seems to be needed at the right places, but the game is not started.

Oh, that’s a shame. I never compiled this from source and can’t see any instructions. Is it just a case of running ‘make’ and copying the resulting file to the cores folder?

If I find time this evening I will post the instructions here.

1 Like

That would be great! Even if games don’t run I’d learn something in the process :slight_smile:

First have a look at How to transfer files with tinycloud through ssh. You will need to connect to your GS with ssh and do some work on it.

I assume you have a stock GS installation, maybe already updated to launcher version 1.21, however that should not be required.

The following steps include commands to be type to the ssh console as they are shown below. This means all on one line, upper and lower case are important, every tick, slash or backslash counts. A command is executed once return/enter key is pressed. Hence you may simply copy/paste them from here into your ssh terminal windows and hit the enter/return key after each single one.


  1. Connect to GS with ssh
  2. Type the following line into the terminal window, followed by return key to execute it:
    git clone https://github.com/libretro/4do-libretro.git
  3. This may take a short moment to download the source code
  4. Next type and execute the following command to change into the source directory:
    cd 4do-libretro
  5. Next command compile the core, with 4 threads to speed up things, takes about 1 minute to complete:
    make -j 4
  6. Next install the core
    cp 4do_libretro.so /home/cpi/apps/emulators
  7. Now create a directory where you have to put the BIOS files, bin files that is, and the games:
    mkdir /home/cpi/games/4DO
  8. Create the Retro Games directory for it:
    mkdir /home/cpi/apps/launcher/Menu/GameShell/20_Retro\ Games/4DO
  9. Create the launcher script for it with these 5 commands:
    echo "ROM=/home/cpi/games/4DO" > apps/launcher/Menu/GameShell/20_Retro\ Games/4DO/action.config
    echo "ROM_SO=/home/cpi/apps/emulators/4do_libretro.so" >> apps/launcher/Menu/GameShell/20_Retro\ Games/4DO/action.config
    echo "EXT=iso,bin,chd,cue" >> apps/launcher/Menu/GameShell/20_Retro\ Games/4DO/action.config
    echo "LAUNCHER=retroarch -L" >> apps/launcher/Menu/GameShell/20_Retro\ Games/4DO/action.config
    echo "TITLE=4DO Roms" >> apps/launcher/Menu/GameShell/20_Retro\ Games/4DO/action.config
  10. Now start RetroArch from main menu and quit it again
  11. In Retro Games you will now find the new entry 4DO

Once you have copied one of the BIOS files to games/4DO you can actually start the emulator. In Retro Games select 4DO then choose the bin file of your BIOS. It will start then ask you to enter a disk, that is where I am stuck for instance.

1 Like

Topic moved to #emulator

An icon for this! Place it into ~/apps/launcher/skin/default/Menu/GameShell/20_Retro\ Games


Thank you for the icon, does this mean you are able to play games with it ?

The core does load with the above script but so far, no game I’ve tried completely starts.

I got it to load! You must first place the BIOS file (panafz10.bin) into ~/games/retroarch/system (or whatever folder is defined as the “System” directory in Retroarch settings). Then place your game iso into the ~/games/4DO folder.

I have 4 bios files. All of them work equally well (pretty slow, choppy). The bios’ I’ve tested:


1 Like

Yep works for me too, but super slow, unplayable :frowning:

@lasvegas thank you for these details. I noticed that when only starting a BIOS, the animations look quite slow, guess the core is not optimised for ARM. I will check the few games I have as soon as I find time.

Hi everyone, I found this topic and I want to know which one is the best 3DO Emulators, I want to start playing again 3DO games. If someone is still reading this topic let me know your best solution for installing 3DO Emulator.

Moderation edit: removed suspicious link

Hi gema, I don’t think you can play 3DO properly on the clockworkpi, at least I couldn’t do it when I tried back in October, and not much has changed since then.