Amiga UAE Emulator

#41

Hi, I have tried your emulator and works fine with IK+. However, I can’t run multidisk games, it just flashes the loading screen. I followed your instructions for multidisk UAE. I am on 1.24 right now, any suggestions?

#42

Hello @Krantz,

what exactly do you mean by flashes the loading screen, and when does this happen ?

#43

Hello, in the meantime I have fixed it, I simply made a mistake in writing the UAE files. Now I got everything to work, thank you! I got to say that this emulator runs very well. I still have to try to customize controls and screen size, I will try in the next few days.

#44

Hello
thanks for this version of uae4arm-rpi for Gameshell.
Unfortunately I followed carefully the instructions but when I select alcocopter.uae the loading screen appears followed by a black screen.
Do you have an idea of ​​the problem ?

Thank you

#45

Hello @Didier_Touron,
Amiga OS rom is in place, correct version and a working one ?

#46

Hello
I tried unsuccessfully with the file amiga-os-130 that I found in the DVD of the edition of “amiga forever” and I also tried with another version found on the net (swos.eu )

I started doing this method:

Connect to your GameShell with the following type of commands:

git clone https://github.com/libretro/libretro-uae.git
cd libretro-uae

Now you need to edit the following file, or simply copy it back to the GameShell:

sources / src / fsdb.c

At it’s top insert the following line:

#include <sys / timeb.h>

Still connected with ssh and in the following libretro-uae NOTE that the compilation (first command) takes roughly 25 minutes:

make
cp puae_libretro.so / home / cpi / apps / emulators

Before doing this one:

First version of uae4arm-rpi for Gameshell ready for download. Instructions can be found here 12. All you need to place action.config 5 to / home / cpi / apps / launcher / Menu / GameShell / 20_Retro \ Games / Amiga. As usual with SSH, read ssh howto 1 if you need help. The action should then automatically download the emulator. If you want to do this, then upload the unzipped file to Gameshell to / home / cpi / apps / emulators directory.

is it this old installation which prevents to operate “uae4arm-rpi”?

Usually the emulators that I install are also in retroarch but not the case of this one
is this normal?

thanks you

#47

Did you copy rom.key to your GS ?

#48

Hello,
in fact no, I did research on the internet but I do not know how to do …

I thought that the presence of this file was not required I do not know where to find this file

#49

Thank you for pointing me in the right direction
I installed the rom.key file and now the game starts

thanks again

#50

Hi - I’m trying to install libretro-uae but when I run the make command, I get an error

Makefile:186: recipe for target ‘sources/src/fsdb.o’ failed make: *** [sources/src/fsdb.o] Error 1

I’ve checked and this file doesn’t exist. Is it an incorrect ref? Running v1.24