Can't Flash my SD card

Hello! I am very new to anything like gameshell and am also new to the terminology too so please bear with me.

I had picked up my gameshell after a long period not playing it. I updated over wi-fi. I got stuck on the loading screen and learnt that you have to ‘flash’ the sd using the OS image. I am trying to do this with V0.5 however i used etcher and it asks me to format the SD after flashing. I have tried doing it and not doing it, but both times the Flash seems to be successful (however it says 1 device failed?)

Now I have also downloaded Win32 and tried to do the same.

But all things I have tried just amount to this: when i boot up it is stuck on the "Clockwork!"screen and I have also been patient and waited for 15 minutes.

Please give me advice, Also it would be helpful to spell things out to me as I am very new to this. Thank you in advance.

I made a small write up in my custom image thread. You don’t necessarily need to use my image, although you can. The instructions should be pretty much the same!

Look at the first post in the thread, and scroll down to the Installation section.

Another thing. You may need to update your Etcher, if that’s what you’ve used.
I don’t use windows, so can’t really help you with Win32.

Try a spare SD card. it could be a corrupt card. They tend to do that occasionally.

Good luck!

Thanks for your help.

I managed to try another SD card and unfortunately i have the same issue. My Etcher is up to date and I’ve used the 0.5v OS image posted by yong. Since i’m rather new to this I don’t know where to go from here.

1 Like

We will get you up and running!
First of all, what size is your SD card? It shouldn’t make a difference since I am fairly sure that the image has had the free space zeroed, and should fit on anything bigger than 8GB.

It’s more if it’s a larger capacity card; say one of the fancy 400GB cards. I have heard people having issues with it properly auto expanding to take up the space. I have only ever tried up to 128GB personally.

When it finishes and asks you to format the card in your computer, don’t worry about doing that. It’s just because the format the card is in is readable by Linux, which is what the Gameshell runs on. Windows doesn’t like to read and write to Linux partitions, so immediately throws a warning flag to format the card to make it useable.

When it says that the flash was successful, but one device failed, were there any other details that you can provide? Perhaps an error log, or error code? Now this is a long shot, but possibly check that you were writing to the correct SD card. There could have been a USB drive plugged in. Or a digital camera. Or sometimes even a computer’s backup recovery partition. Make sure for certain that you know which drive you were writing to.

Etcher theoretically should support it using compressed archives, but just to get one process out of the way, try and decompress it first. The image should be in a *.gz format. This is like a zip file, just with a higher compression ratio, and a slightly longer decompression time. Use the file that comes out of that file, which should be a *.img file. You won’t need to worry about setting partitions, or formatting the card a special way. The image should take care of all of that.

Sometimes it can be your SD reader that is the problem. Since we are using microSD cards, some people need to use a larger postage stamp sized SD adaptor to use it with their computer. Sometimes the contacts can be dodgy on them, in which case try and source another one. Alternatively, try a USB reader that can read microSD cards. Some SD micro cards come with one.

Finally, and I hope this isn’t the case; some SD cards that are purchased cheaply online are counterfeits. They may be sold as 64GB, but are in fact only 2GB, with a modified headed to report if as a larger size. Long story short; they don’t work. There are programs online to verify the authenticity of your card. I’m not sure what is available for windows, but you should be able to find something!

Judging by the fact that it’s starting up fine, but getting stuck on the clockwork screen, it sounds like your Boot partition is intact, which contains the splash screens. It’s the main partition that doesn’t appear to be loading.

As a final thought, give my custom image a go. I have maintained it, and kept it current and working. I have provided a MD5 checksum hash that you can verify to make sure your file hasn’t been corrupted in transit. That said, you could also do the same with the official image too!

See how you go! :slight_smile:

I’ve updated my Ether, but same issue as yours, the checksum would fail.
What resolved for me, was using an old version - I installed: 1.5.70

It worked perfectly.

1 Like

Oh wow! Amazing tip! I’m glad they still have links up for the older version! Hopefully this works. I’m gonna bookmark this tip. :slight_smile:

1 Like

I tried the latest etcher 1.5.100 on a spare SD and worked.

I did a couple of test and here are my findings.

Latest etcher 1.5.100 works fine with the uncompressed *.img

But fails if you try to flash with the *.bz2


Thanks for going to the trouble to test that!
I remember reading that with regards to the compressed file direct writing support, there was a limit to the file size being less than 4GB in Etcher.

The compressed size should be about 2GB, leading me to believe that perhaps the decompressed size is >4GB, and that is where the limit lies. I haven’t used a stock 0.5 image in a while so can’t verify this!

But still; this is good information to go on and potentially use as a precedent. :slight_smile:

Now to find out with the OP can finally use their gameshell! :slight_smile:

Compressed is 1.7 Gb and uncompressed is 6.1 Gb.

1 Like