Catacomb Adventure Games Serie

Hi all,
Did anyone tried to install or compile the Catacombs serie, natively, through Reflection Keen, which include All the Keens and all of the Catacomb games (Catacomb 3D, Catacomb Abyss…etc) I already have all the Keens installed but realy would love to get the Catacomb games to work natively and not with DosBox.

Here is the source:

I tried compiling the source but it fail all the time.

Can anybody try to compile it and post back if its possible or not.

any luck? I would LOVE to be able to plat CA on my clockwork

For the moment, if you want to satisfy yourself, install zdoom (I posted a tutorial here on the forum ZDOOM on GS for Brutal Doom and other mods!) and use a Doom II mod.
Catacomb Abyss TC

But no, no luck, I hope someone with deeper knowledge of compiling on Linux will try…

i’m quite well versed in linux but already have several dozen projects on the go. so i cannot make any sort of promises, but I will download the source and see what if anything can be done.

Thanks man at least I will know if it work or not in a more definitive way. :slight_smile:


were/are required.

I installed them “sudo apt-get install -y libspeex-dev libspeexdsp-dev”
and then the compile went without issue

steps I took (all on my clockwork, NOTE IT MUST HAVE INTERNET TO PERFORM THIS)

download source – refkeen-release-20170401.tar.gz
extract – “tar -xvf refkeen-release-20170401.tar.gz”
move to source directory – “cd refkeen-source-20170401\src”
build the source – “make”
wait… awhile

and here’s the “hard” part… theres NO install scripting in the makefile. so you need to manually put the executables where you need them. I did this
“sudo mv reflection-* /usr/local/bin/”

all built. – I DID NOT test them yet.and you still need to make the “launcher scripts” which i did not cover at all.

1 Like

Cool! Yeah I can continue from here no issue. The compiling part was problematic for me but creating the launcher and sorting the files out is not a problem. Thanks again m8 I will try this tonight and report back! :slight_smile:

1 Like

I think the main issue will be Input Binding.
I managed to launch Catacomb Abyss but the launch menu require me to bind the controls but always state N/A.

I was curious so I installed the Windows version to try and its the same issue. When I try to bind a key in the settings it always say N/A. Furthermore, it seems like it does not even use the .ini file…

In game, at first you have to select Novice or Warrior, and for that, we need to bind a button to N or W…

So it works well but as long as we can’t bind, we are lost.

So I tried to recompile a newer version of Reflection Keen. Most of the Catacomb games work with the exception of Catacomb Abyss, but, there is a lot of screen flickering on my side so its almost unplayable…

I will stick with DosBox SVN for now.