clockworkpi

ZDOOM on GS for Brutal Doom and other mods!

Anyone tried to compile ZDOOM or Zandronum yet?
Would be nice to run some good DOOM2 wads and pk3 only available with these engines.

Ok so obviously, what I wanted to do is play Brutal Doom and other mods working only through GZDOOM or ZDOOM…

And I succeeded in compiling zdoom and launch Brutal Doom. Its very playable but I believe that some settings must be changed to make it completely fluid.

Here is what I did:
Compiling zdoom:
1 - Download zdoom from here: https://github.com/rheit/zdoom
2 - Send it to /home/cpi/
3 - Unzip it: unzip zdoom-master.zip
4 - cd zdoom-master
5 - sudo cmake . *(the dot is important!!!)
6 - sudo make all

Preparing Doom wads and mods:
1 - Get doom.wad and doom2.wad
2 - Create a folder in /home/cpi/games/ and put your wads in there. I named mine WADS
3 - Download Brutal Doom: https://www.moddb.com/mods/brutal-doom/downloads/brutal-doom-v20-legacy-edition
4 - Move brutalv20b.pk3 to your wads folder
5 - Create a folder in /home/cpi/launcher/Menu/GameShell/20_Retro Games/. I named mine DOS WADS
6 - Create a launch script in your DOS WADS folder, name it Brutal Doom.sh
7 - Put this in it: /home/cpi/zdoom-master/zdoom -iwad /home/cpi/games/WADS/doom2.wad -file /home/cpi/games/WADS/brutalv20b.pk3
8 - Reboot your GameShell
9 - Try to launch Brutal Doom and the exit from it.
10 - Open /home/cpi/.config/zdoom/zdoom.ini
11 - Change the resolution on lines 133 and 134 to vid_defheight=240 and vid_defwidth=320

Finally, set your controller settings in-game and do not forget to set your Lightkey to use Look Up and Look Down, you will need it!

Everything should work!
If anyone have a better way to do all this I welcome you to share your method! :slight_smile:
There might be a repo out there… sudo apt-get install zdoom would be easier…

3 Likes

thanks for the tuto

( instead of download zip from git repo you could directly clone it
also with not directly use gzdoom source ?
git clone https://github.com/coelckers/gzdoom.git --depth 1 && cd gzdoom
in general with cmake we mkdir a build folder before
mkdir build && cd build && cmake .. && make -j4
)

there is a repo, it need packages :- )

ok after some compile time & packaging seem latest release only support opengl >= 3.3

release note of 3.7.2 version seem the last containing “vintage” support for gl2

edit 37 > https://zdoom.org/Changelog/8ab68264c/files

08-Jun-2018 (Friday) at 12:12:06 CDT by Christoph Oelckers

  • removal of all code to handle OpenGL 2. From this commit on the main build of GZDoom will be OpenGL 3.3 or higher.

Hey thanks m8! I am always happy when I learn something, I am still new to compiling stuff.
Yeah I tried compiling from the gzdoom source at first but when I launched games the screen was in opengl mode and only displaying a gradient from red to green… Yes cloning the git is way easier, this is good. I will try your method right away. :slight_smile:

What is --depth 1 for? Is it to include changes and commit?

I am unable to compile the 3.7.2 version… Did you managed it?

–depth 1 only download current code without all the history

for checkout commit of 3.7.2 i was need to remove --depth 1

it compiled fine (need add swap file) but there is no texture drawed as your test :confused:

i check trigger a bit the conf file without succes for now …

to compile :

git clone https://github.com/coelckers/gzdoom.git && cd gzdoom
git checkout 1455111ddca7142f97694047a540ce8c1bf4fa8f
mkdir build && cd build && cmake .. -DCMAKE_BUILD_TYPE=Release && make -j4

Same for me. It seems to try to launch in open-gl mode.
There must be a way to launch in software mode…

software mode seem be enable by adding +vid_rendermode 0 to the command line or in .ini but does the exact same effect, no textures, it’s undocumented but can be found here https://github.com/coelckers/gzdoom/blob/master/src/v_video.h and into some forum answer, so it’s not work or it’s internal and gzdoom still use hardware for main screen blit ?

we may try change texture format like the doc say it here https://zdoom.org/wiki/Texture_options
but cannot found this flag in current conf file

i think we need fresher lima driver … i try switch the gs into fbturbo driver does not change anything, gl seem start in lima mode anyway like gzdoom output suggest :

GZDoom g3.5pre-44-g1455111dd - 2018-06-14 22:57:08 +0200 - SDL version
Compiled on Apr 14 2019

M_LoadDefaults: Load system defaults.
W_Init: Init WADfiles.
 adding /usr/local/share/games/doom/gzdoom.pk3, 626 lumps
 adding /usr/local/share/games/doom/zd_extra.pk3, 132 lumps
 adding /usr/share/games/doom/freedm.wad, 3342 lumps
I_Init: Setting up machine state.
I_InitSound: Initializing OpenAL
  Opened device ALSA Default
  EFX enabled
V_Init: allocate screen.
S_Init: Setting up sound.
ST_Init: Init startup screen.
Checking cmd-line parameters...
S_InitData: Load sound definitions.
G_ParseMapInfo: Load map definitions.
Texman.Init: Init texture manager.
ParseTeamInfo: Load team definitions.
LoadActors: Load actor definitions.
script parsing took 1009.15 ms
R_Init: Init Doom refresh subsystem.
DecalLibrary: Load decals.
Adding dehacked patch freedm.wad:DEHACKED
Patch installed
M_Init: Init menus.
P_Init: Init Playloop state.
ParseSBarInfo: Loading custom status bar definition.
===========================================================================
This is FreeDM, the free content deathmatch FPS.

FreeDM is freely redistributable under the terms of the modified BSD
license. Check out the Freedoom website for more information:

    https://freedoom.github.io/
============================================================================
D_CheckNetGame: Checking network game status.
player 1 of 1 (1 nodes)
Using video driver x11
GL_VENDOR: lima
GL_RENDERER: Mali400
GL_VERSION: 2.1 Mesa 18.3.0 (git-0a153b2aae) (Compatibility profile)
GL_SHADING_LANGUAGE_VERSION: 1.20

Max. texture size: 4096
Max. texture units: 16
Max. varying: 48
Resolution: 320 x 240
libWildMidi(_WM_InitReader:52): ERROR Unable to load  (No such file or directory)
gzdoom: Unable to load sound font
Unable to create FluidSynth MIDI device. Falling back to OPL

I will try to contact the gzdoom team this week and ask them for help.
Anyway, right now, Brutal Doom, and Brutal Wolfenstein work ok with the version of zdoom I used in my first tutorial. I’ll post back when I get answers.

Anyone else having issues with sound? I’m getting no audio whatsoever over multiple wads and pk3s. Any suggestions?

use openal for audio, you will need to install a soundfont to play midi with selection of timidity or fluidsynth in config

i got a working build & config (but only a pretty old brutal doom work) i need package it.

Hey thanks for the quick reply, I manually downloaded the audio dependancies that weren’t found when building, and just grabbed my soundfont from my gzdoom build on my mac. Runs great with the august release!