How Can I install dosbox-sdl2 version?

I’m Korean. so My English can be awful. please excuse me about my English.

here is my question.
I saw some topic about playing DOSBox on gameshell.
and I realized there was DOSBox-sdl2 version.
but I don’t know how to install it.
and I even couldn’t find sdl2 version. please some one can tell me how to find DOSBox-sdl2 ver.

SDL2 is not the best, I have tried it and it was disappointing. Use DosBox-SVN
Check this post: RetroArch Megathread

I followed each step and I got stuck at
make -j8 WITH_DYNAREC=arm
when I type make -j8 WITH_DYNAREC=arm
It keep saying make: *** No targets specified and no makefile found. Stop.
so I cant install DOSBox.
Do you have any idea about this error

and also when I type
sudo apt install libsdl-net1.2 libsdl-net1.2-dev libsdl1.2-dev libsdl1.2
it saying

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libsdl1.2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

I think this one is making error about make -j8 WITH_DYNAREC=arm this code

Ok try my method then:
(Please note that this way it will not go through Retroarch…)

1 - Download DosBox SVN from here:
2 - Place it in /home/cpi/ You can use Filezilla for this…
3 - Unzip it: unzip
4 - cd dosbox-svn-master
5 - sudo sh ./
6 - sudo ./configure
7 - sudo make

I think thats what I did…

Then when you want to create a script for your Dos games do this:

1 - Create a DOS folder in /home/cpi/games/
2 - Put some game folder in it. ex. /home/cpi/games/DOS/catac3d (For the game Catacomb 3D)
3 - Make sure your games folder names do not use more than 8 characters
4 - Create a launcher script in /home/cpi/launcher/Menu/GameShell/20_Retro Games/DOS/Catacomb
5 - Put this code in it (change it to reflect your game…)
/home/cpi/dosbox-svn-master/src/dosbox ~/games/DOS/catac3d/CAT3D.EXE -exit -exit

If you want to make it prettier, follow the steps I went through here: Adding Shortcuts to "Retro Games" on Clockork Menu

Here is my config files if you need them. Place them in /home/cpi/.dosbox/

try an sudo apt-get update before try installing anything with apt-get

Thank you for reply
I’ll do it now and I’ll notice the result

well thank you.
It works.
but is it possible to play fullscreen with output=surface option ?
because if I use output=overlay, then It’s too slow.
but surcafe option is fast enough.

Too slow?.. Which game?
Also, did you download the config files I provided?
Try with the Lima driver in your Gameshell settings

yes I tried with your config file.
and I tried also Lima driver
but it’s still slow.
however if I play with surface option its pretty fast.
but it show like this.
below screenshot that I captured


What game is this? I will try it here.
Also, are you on OS V0.3?

This is famous Korean game.
so you might not know that game.
but If you wannna help me then I’ll send you this game.
plz tell me your email.
I’ll send you game through email.
and Im on OS v0.3

sent to your PM. Ill try it and report back right away.

I will try it but you have to keep in mind that the GameShell is NOT a dosbox powerhouse. There will be games that works perfectly fine while others, not necessarly bigger or more demanding, that will fail.

Your gamefile is 1gb. lol
I have bad result with these filesize but let me try.

It failed for me on dosbox

But is the game translated to Under Night In-Birth ?
There should be a MAME or FBA version of this, it was also an arcade game.
On FBA, if you can find the rom, it will work for sure…

thanks for the help me the work.

와 한국분! 반갑습니다. 혹시 네이버 구닥동카페 가보셨나요? 거기 도스박스 관련 글이 하나 있#•습니다.

앗 안녕하세요~
저도 구닥동 회원이에요.
닉네임은 아카시성진로 입니다
그 글 아마 제가 올린걸거에요 ㅎㅎㅎ

아 그렇군요 본인이셨네요;;; 부끄러워라 ㅎ
아무튼 방법을 찾으시기 바랍니다!

앗 넵 ㅎㅎ 반가웠습니다~다음에 또뵈요~