How to add new emulators (Gameboy, SNES, etc.)

I think this will fix the fast NES issue, it did for me.

Run a nes game, and then open the retroarch menu. Select Quick Menu, then Options. Find Favored System and change that to PAL. Go to the front menu and restart. The game should run at a more pleasing, slower speed.

1 Like

Fixed it! You rock man thanks!!

1 Like

Is there any chance you could make a video of this? I’m struggling in a big way with this Gameshell and am starting to regret buying it :frowning: I’m wading through all these threads and becoming more and more confused.

1 Like

Hey what emulator works for Turbo Grafx… I see you have a folder names TG16…

1 Like

Beetle PCE Fast - it will play any/all turbo grafx/pc-engine games, including CD based roms.

1 Like

@Metalcory Im having trouble getting the icons to work. Im very new to this sort of thing, but was able to install multiple emulators and and roms with some considerable effort. Now my goal is to install icons for each of the emulators. I guess my question is where to put the png files of the icons when I connect to my Gameshell so that i can follow the steps in the terminal and assign them a location. Thanks in advance.

Franky

hi… when i type the code to the retro games 20 thing at the beginning, it says “-bash: cd: too many arguments”… please help

The error message means that the program expects 1 argument but it finds 2. program is cd

cd /home/cpi/launcher/Menu/GameShell/20_Retro\ Games/

My guess is that the space from 20_Retro Games messes it up (Which shouldnt because of the escape character \ )

Check if you didn´t miss the \ on 20_Retro\ Games or try

cd ‘/home/cpi/apps/launcher/Menu/GameShell/20_Retro Games/’

Edit:2019-02-12T00:00:00Z
I didnt have my cpi at hand and used the path from repo cd /home/cpi/apps/launcher/Menu/GameShell/20_Retro\ Games/
the correct one is:
/home/cpi/launcher/Menu/GameShell/20_Retro\ Games/
Also the second method i mentioned is with single quotes instead of double quotes:
cd '/home/cpi/apps/launcher/Menu/GameShell/20_Retro Games/'

Have you tried the Filezilla ftp method? GUI interface. Easy as drag and drop into the folders. Made it a lot easier to assign an icon for my emulators.

Guys how are you, maybe can you give some hits why it’s not working my build for GBA, this is my configuration for action.config file:

ROM=/home/cpi/games/GAME BOY
ROM_SO=/home/cpi/apps/emulators/mgba_libretro.so
EXT=gb,gbc,gba
LAUNCHER=retroarch -L
TITLE=GAME BOY
SO_URL=https://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/mgba_libretro.so.zip

i do the same steeps for SNES and its working fine any recomendations?

Thanks in advance.

Br,

[this is so embarrassing, i forgot to unzip the files, released when see the file extensions on the action.config file.

What core do you recommend for SNES? I’m trying the Core “snes9x” but I have a lot of problems with the sound … Does any other Core work better than this one?
And for Mega Drive and Mega 32X? I know there is a version of PicoDrive “Standalone”, but I would like to use them through RetroArch.

There is an optimized snes9x you can find on this forum same goes for picodrive there is a retroarch core in one of the threads

Hi.

I’m a noob when in comes to this coding stuff, and I came across a issue when following the tutorial.
There isn’t a directory in my GameShell that is the following:
/home/cpi/apps/launcher/Menu/GameShell/20_Retro\ Games/
This also doesn’t work when ‘20_Retro\ Games/’ is replaced with the listed alternatives.
Instead, I have the following:
/home/cpi/launcher/Menu/GameShell/20_Retro Games
I was wondering if this would be the directory that I would create the folder, and use when following all of the other steps.

Thanks!

I’m having the same issue. I was able to install a few emulators, but I used the new script on here to expand my memory card and now I don’t know how to install anymore emulators because the file structure is different

i also have this issue plus when I type the code without the apps word, it says “too many arguments”
pls help ASAP

I copied the path from the github repository (and there it was with apps) as I didn´t have my Clockwork at hand. So use this one:

cd /home/cpi/launcher/Menu/GameShell/20_Retro\ Games/

or

cd ‘/home/cpi/apps/launcher/Menu/GameShell/20_Retro Games/’

this works but I get the code “too many arguments”

Okay I found the reason…

The forum changes the ’ character because I used the blockqute instead of code format, try and copy this one.

cd '/home/cpi/apps/launcher/Menu/GameShell/20_Retro Games/'

image

I used this one and it worked:
cd /home/cpi/launcher/Menu/GameShell/20_Retro\ Games/

Thanks so much!