clockworkpi

Help: I want to creat ShortCuts for games, that appear on my homescreen

Hello there, i want to use some fancy icons, i made myself for some games i really love… But i am not aware of how to create the shortcuts, i am new to gameshell … but i would love if someone could help me out with a noob proof solution,

I am able to shh and stuff, but i am unaware with the system it self :smiley: BUT i dont give up that easily, i wanna play mother in a fancy fashion

Edit:
I want to use pocketsnes for snes games :smiley: if thats possible
not retroarch

Hello! Welcome to the forums.

So there was another user with a similar problem who I tried to help, but there was a bit of a communication problem.
Possibly have a look at this thread to see if you can make any sense of it.

Of course, knowing where you’re coming from, what OS, and any modifications would be very useful. I am of course biased when saying to use my custom DEOT+ v2 image, but I made it primarily to have people all starting on the same page, so I can hopefully help them easier.

See how you go, and good luck.

1 Like

ok well, thanks for heads up!

I am using the UNMODIFIED official image 0.5 from clockworkpi.
Fairly new to it, but all works…

Anyway, how can i create any shortcuts for games… i am still not sure how to do it, if you want, or if you can help me better with that, i would install your image for sure, BUT i would prefere to do it on the offical image, just for the sake of it :smiley:

have nice day by the way

All good! Just needed to know, since different versions have files in different places.

If you can take a screen shot of your SSH client showing the exact path/filename of your Roms you want a shortcut for, I can write it out for you, showing you along the way what I’ve written, and why I’ve written it.

Consider perhaps testing other custom images on a spare SD card. They’re cheap to buy practically anywhere.

In a nutshell, you basically need to write out a “bash” (.sh) script that references the path of the emulator you are wanting to use (pocket snes), then any parameters before including the path of the rom file. Don’t forget to include a shbang

To make the file exectuable, you’ll need to give it the executable bit, by changing its mode. Look that up in the forums. There are a lot of threads with info on how to do that.

The name of the file will determine its order initially, and will be alphabetical. You can override this by including a two digit number then an underscore before the file name. This won’t appear in the menu, and is purely for ordering. Make sure you don’t double up numbers!

For the icons, you’ll need to include this either in the directory of your shortcut you made, or in the mirrored directory structure of the skin you’re using. For now, just have it in the same directory as your script. The icon needs to have the same name as the script, just with the extension file as PNG, or whatever you use. You don’t need to include the number for ordering.

Okay! So basically, here is how your script file will need to look.

#!/bin/sh
cd /home/cpi/apps/YOURDIRECTORY/
./PocketSNES /home/cpi/games/SNES/ROMNAME.smc

First line: the shebang. See above.
Second line: changes directory to the path of PocketSNES.
Third line: the dot slash is the command to execute the app Pocket Snes, then the single space followed by the path of the Rom is provided, telling the script to use Pocket SNES to run the rom.

N.B. If you have spaces in names, you need to include back slashes to signify a space. Or you can just not have spaces.

Wherever you put the file is where you will see it on the launcher. Let me know if you need any help with knowing the file structure/hierarchy, and how to make the icon appear whenever you want it to.

1 Like

Man thank you very much for that clearification!

I am a complete noob in that so, if you would not mind, writing the script, i most certainly give you my file parth :smiley: haha thanks in advance for that!
Here s the parth for the emulator:
/home/cpi/apps/Menu/20_Retro Games/24_PocketSNES+

Here is the parth of the Game i want to “shortcut”:
/home/cpi/games/PocketSNES/Super Mario World USA.sfc
Thank you for your help here! I reall appreciate it

Just clarifying. Did you move the path of the emulator? From memory, it should just be in ~/apps/emulators/
Or was the path you gave me the place where you would want it to be?
Alternatively, was this the PocketSNES rom directory?

You did mention that it was an unmodified 0.5 installation you were using. Do you mean a stock image, or rather that you have freshly installed it, and haven’t moved things around.
It does sound like things have been moved, and when that happens, other things can go wrong.

Could you possibly send a screen shot instead? It’s not entirely clear if you’ve moved the directories around or anything else. This will clarify everything.

Just to make things easier, rename your rom to “supermarioworld.sfc” - there are too many spaces, and too many characters in its current form. This is will avoid problems later in with troubleshooting etc.

Note: this will mess with all of your save states and save Ram files; so either rename them too, or I can show you what to do with spaces/long names.

With what you’ve given me, this should be your script. Create a file called Mario.sh, and put this in it:

#!/bin/sh
cd /home/cpi/apps/Menu/20_Retro Games/24_PocketSNES+/
./PocketSNES /home/cpi/games/PocketSNES/supermarioworld.sfc

Wherever you have put the script, enter the directory, and then type:

sudo chmod +x Mario.sh

Reload the launcher, then test the file. If it works, put an icon with the name “Mario.png” in the same directory as the script, and reload the launcher. It should work.

If it doesn’t work, manually run the code in an ssh session m. It should make it run on your Gameshell. If it doesn’t, post the error message here.

export DISPLAY=:0
cd /home/cpi/apps/Menu/20_Retro Games/24_PocketSNES+/
./PocketSNES /home/cpi/games/PocketSNES/supermarioworld.sfc

I’m still not 100% convinced that the path did the emulator is right, unless potentially a recent update changed it in the stock image.

ok i am sorry for not clearifying it more specificly!

I didnt touch the os, and i freshly installed it on a 120gb microsd card
I ve not moved anything, its under apps emulators like the parth i sent in here
omg sorry i sent u the wrong one, i got confused because there are some parth as well for home…ups… u re right its the emulator parth… god damn :smiley:

its under ;
/home/cpi/apps/emulators/PocketSNES
thank you for pointing that one out for me, frustrating for me though xD

ok i did rename that now … so its without any spaces inbetween

i have no saves cuz i just want things to fit perfectly before i start enjoying :smiley: haha i learnt from previous failures

just to clearify where should i put the script ;D ? in the same folder as the mario game?

ok wait i ll try the script later! thanks for writing it all !

really appreciate it

and maybe you could rewrite the script again would be pretty awesome from you have a great new year btw ;D

Tada!! Happy new year!

As for where you want it, put it wherever you want it to appear in your launcher.

Basically, if you put it in “/home/cpi/launcher/Menu”, if will appear in the first menu when you turn on your gameshell. If you want it to appear before the first displayed icon, prefix it with a number, eg, 01_Mario.sh.
And of course if you want later, give a higher number. Just make sure you don’t double up numbers. Same can be done with folders too.

After you’ve put it wherever you want it, navigate to it, and perform the mode change, I’d chmod. See above.

amazing!
Thank you very much for your help here, i ll post results, when i finally can get to my gameshell:F haha

Happy new Year to you too! I wish that we can finally start travelling again, then i will most certainly take my gameshell with me :stuck_out_tongue:
Pics will be uploaded in a few days, so you can see what i ve done with your script writeup >;D

It does not work sadly…
I ve put my game into that specific folder i mentioned above, and i run the sh file, it did not give me any errors though.

I put it in a folder called favourites… btw
it gives me the loadingscreen and immediately exits to the home menu…

here is the shh session error i got

Here are my directories again with a screenshot:

game: grafik

The emulator:
grafik

Edit1:
I run the ssh session code you gave me: It started the game and sound was playing i was able to navigate, but no display … :smiley:

Edit2:
I wanted to provide the executable again… here s a screenshot… of the putty session and the chmode

Edit3:
I can not find the Retro Games folder in my Menu anymore… i
t disappeard it is still in the ssh … so strange see…
grafik

Thank you for providing the screen shots!! It really helps make sure we have the right info!

The fact there was sound playing but no display sounds like a potential PocketSNES configuration problem. Does SMW4 work on pocket snes, using the conventional navigation?

Potentially try and use different indexes for the “export display=:” - like replace with 1, of any other number going up. That’s just for testing mind you.

I’m seeing your edits happen just as I’m about to suggest things. Nice! I was going to double check the chmod. Looks like you have it. What happens when you run the script instead of manually running the contents of the script?

Ie,

cd home/cpi/apps/Menu/02_Favourite-Games/
./Mario.sh

In fact, does the shortcut script appear in your favourites folder? Try running it, and when it has an error, type this in your SSH session:

cat /tmp/x.log

Post what the results are and we should be able to work out the problem.

Side note. If you want to have the folder called “Favourite Games”, you can. You just need to type it like this in your ssh session

Favourite\ Games

Just to humour me, could you try and write my custom image to the stock 16GB Sd card the gameshell came with? Repeat the process to see if it works. I just am curious to see if perhaps there is something that may have broken in the official 0.5 image.

If you don’t have time, that’s all good! I’ll test my exact instructions out on my own gameshell. Admittedly I’m just going off the top of my head/from memory, and could have made a mistake!

Re: retro games vanishing, ah I remember there was a glitch regarding missing folders! I fixed it in my image. I logged the fix somewhere. Let me see if I can find it.

That was just the first result. It should have been something that was fixed. Try running the update script in the gameshell settings. This should update the launcher. Keep in mind, it can sometimes remove customisation you’ve made, and occasionally break your installation, so backup before updating.

hey again :smiley: no sleep ha?

Game works without any issue, i ll try earthbound later down the line… good that i can gladly say i ve those original games in my collection… anyway if that does not work it the scripting sadly… but i am certain we will fix it :smiley:

the shortcut appears in my fav section… when i click it, it just runs and closes … soo strange NO ERROR or smth… thats the weird part
so maybe its the pocket snes… umpf
may u write me a script with the retroarch emulation parth ? would be soo nice of you

i ll finish my workout and then i try the cat tmp thing and send u the results if needed!
many thanks for trying to help me!

i ll try ur custom image if nothing helps for sure mate! But i try to avoid opening the gameshell cuz it looks like there could break smth pretty fast if u ask me…

anywayy the fav folder is writen like Favourite-Games .,. so no worries with backslashing :smiley: haha i surely minded ur advice here bro

Folder disappearing:
Thanks i ll try that later down the road, BUT first i want that smooth image appear here ;D ahaha i ll try to put the shortcut in the mainfolder
best regards see you soon i suppose

edit1:
Folder disappear; updating the launcher was successfull but still folder is missing… strange

Try this:

retroarch -L /home/cpi/apps/emulators/snes9x2005_plus_libretro.so /home/cpi/games/PocketSNES/supermarioworld.sfc

It should all be on one line. You don’t need to directly specify the path of retroarch, since it’s in the usr bin area.

Re: missing retro games,

I open my gameshell a lot, and haven’t had any cables break, or SMDs come off. Then again, some people have consistent problems with this. It just comes down to how careful you are I guess.

Good luck!

Boy this has got to be the longest workout in history! 2 days non stop!

thanks for that scripting here !
i ll give it a shot then :smiley:

Edit :
Didnt work: i tried these :


i put it with filezilla into directory, switched to that one and chmod it with the sh filename…
i also tried:

i also think thats gonna work, i ll try it later today too ;D
and you re right, itz important to be carefullll … especially with those gameshells
Edit:
Didnt help, folder s still missing… sadly

Ahaha, yeah! it was well worth it… and i burnt 2000kcal :stuck_out_tongue:

1 Like

OH run Snes9x from the menu with Mario once to make sure the SO file has been downloaded. The initial running of the game sets that up. Same with Pocket SNES, but I guess if you got it running without sound, it means it exists.

Can you 100% confirm that you’re runnng 0.5? There were a lot of directory shuffles between versions. That could be the issue.

Can you also confirm that you can run the rom normally via the launcher menu? It could just be a corrupt rom this whole time.

Ideally, get a spare SD card and at least try my image freshly installed, without any modifications. It’s too hard to diagnose what else could be changed without seeing a cat log dump. If you do, let me know and I’ll provide a separate set of instructions.

Edit:
Using my custom image, I’ve just tested my scripts and they’re working. I’ll paste them here, in case you do decide to try using my ROM.

#!/bin/bash
cd /home/cpi/apps/emulators/
./PocketSNES /home/cpi/games/SNES/mariokart.smc

and

#!/bin/bash
retroarch -L /home/cpi/.config/retroarch/cores/snes9x2005_libretro.so /home/cpi/games/SNES/mariokart.smc

I tried mario kart, just because I happened to have the ROM handy.
There is a slightly different path for the ROMs in my image, as well as all of the Retroarch cores being in a different directory, so if you’re using a stock image, the script I just typed in this post won’t work.

Edit 2:
AHH! I just realised as well! The Retroarch SO name is different in my original post I gave you re: the file name. I forget what the stock 0.5 image downloads it as nowadays! The name that I provided was the stock buildbot file name, and not the custom link provided by the stock action.config file. I grabbed the file name from another older post, so it may have been wrong/outdated.

So, the reason i have my retroarch SO files in a different location, using the stock file names is so that they can each be updated via retroarch.

I’ll have to either ask you a lot more questions to verify each and every file’s location, your configurations, and what is and isn’t updated, and possibly instructions on how to update things if needed; that is, if you want to try and get things working using your stock image. Of course I’m biased in saying to just use my image, but it should be possible to get you on your feet with whatever setup you’ve got.

I just find it frustrating that we can’t get it working with what should be the correct script; but also that the last person I also tried to help ALSO couldn’t get it working using similar if not identical instructions. They were also adamant to not try installing an alternative operating system. I’m not saying to completely forego your own installation; simply requesting that you test it with a platform that is known to be working.

Anyway. Let me know where you want to go from here, especially re: possibly trying all of this on an alternative OS installation.

Edit 3:

Did you reload the launcher, or restart? You’ll need to do that to see changes happen. Again, it’s something I’ve fixed in my custom image, using the exact instructions quoted.

OK crazy things to report…
When i tried your script,. somehow the snes games all disappeared—
i can not select any snes games so far…
others seem fine though

Which script?
If you’re talking about this one:

It is only removing (rm) the retro games directory within the launcher. There shouldn’t have been any action files there, since by default all of them should be in “ /home/cpi/apps/Menu/GameShell/20_Retro\ Games/`
The removed folder is an empty redundant folder.

The other scripts are just running apps, so they shouldn’t have removed anything. Are you sure you haven’t done any changes or folder/file moving? It gets extremely hard to diagnose and help with problems when I don’t have a complete picture.

I’m actually thinking. It wasn’t my scripts that made snes games disappear, but potentially the launcher update. The action.config files specify what file type your emulators accept. Your file is a .sfc file. Perhaps they were for some reasons removed from the file type list? That would explain why they’re not visible. I mainly have smc (super magicom) of fig files for my SNES games. You can check this, by editing the action.config file.

Sounds like you’re still doing a workout, since I still haven’t seen your “cat /tmp/x.log” dump. If you can get that done ASAP, we can actually find out why things aren’t running.

Before I tell you to just flash my image, let me know if that’s just not something you’re going to do, just so I’m not repeating myself. It was something I made to help solve current and future problems for users with problems like yours.

na it wasnt ur script, writeup bro :smiley: was my failure, i was not thinking correctly… so i didnt asume ur s would fuck with my games :smiley: dont worry i just know how to provoke u it seems haha sorry ;D

my workout is still goin on and on i will give u a dump later to night, sorry but i installed ur custom img and i also set it up again, i will try the script also later .

anyway i used mariokart, and it was not working with sfc files and the other one, does not matter , and the chmod thing also is not doing anything, strange., i am not sure why its not working with mine. maybe u could give me ur img without the games ofcourse if you dont mind, just ur doom game ;D i wanted to try that out too soo it would be a winwin for me D; i ll write later, and give u a heads up
thanks btw for ur efford and will to fix that sh…

Edit 1; image is on a second sd… and i ll try that out still my first main sd is with the vanilla :wink:

Edit 2:
I tried to run that sh file:


it didnt work…
how i did it:
I shh my cpi and put the game into /home/cpi/games/SNES
then i put the script thing into : /home/cpi/launcher/Menu/GameShell
after that i putty … with sudo chmod …grafik
i run it … the script in the homemenu…
didnt help it just exited like the other times…

Edit 3 .
here is that log
[ 27.803]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[ 27.803] Build Operating System: Linux 4.9.0-8-arm64 armv8l Debian
[ 27.803] Current Operating System: Linux clockworkpi 5.7.0-clockworkpi-cpi3-g5c715d2cd-dirty #1 SMP Thu Jun 18 20:43:51 AWST 2020 armv7l
[ 27.804] Kernel command line: earlyprintk no_console_suspend fsck.repair=yes root=/dev/mmcblk0p2 rootfstype=ext4 rootwait init=/lib/systemd/systemd noinitrd panic=10 cma=256M
[ 27.804] Build Date: 05 March 2019 08:11:12PM
[ 27.804] xorg-server 2:1.20.4-1 (https://www.debian.org/support)
[ 27.804] Current version of pixman: 0.36.0
[ 27.804] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 27.804] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 27.805] (==) Log file: “/home/cpi/.local/share/xorg/Xorg.0.log”, Time: Tue Jan 5 22:05:32 2021
[ 27.825] (EE) Unable to locate/open config file: “~/launcher/.xorg_lima.conf”
[ 27.825] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 27.844] (==) No Layout section. Using the first Screen section.
[ 27.844] (==) No screen section available. Using defaults.
[ 27.844] (
) |–>Screen “Default Screen Section” (0)
[ 27.844] (**) | |–>Monitor “”
[ 27.846] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
[ 27.846] (==) Automatically adding devices
[ 27.846] (==) Automatically enabling devices
[ 27.846] (==) Automatically adding GPU devices
[ 27.853] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 27.873] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 27.873] Entry deleted from font path.
[ 27.896] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 27.896] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 27.896] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 27.896] (II) Loader magic: 0x5b4f98
[ 27.896] (II) Module ABI versions:
[ 27.896] X.Org ANSI C Emulation: 0.4
[ 27.897] X.Org Video Driver: 24.0
[ 27.897] X.Org XInput driver : 24.1
[ 27.897] X.Org Server Extension : 10.0
[ 27.902] (++) using VT number 1

[ 27.912] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[ 27.917] (II) xfree86: Adding drm device (/dev/dri/card1)
[ 27.921] (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 11 paused 0
[ 27.927] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 27.930] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 12 paused 0
[ 27.931] (II) no primary bus or device found
[ 27.931] falling back to /sys/devices/platform/display-engine/drm/card1
[ 27.931] (II) LoadModule: “glx”
[ 27.935] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 28.036] (II) Module glx: vendor=“X.Org Foundation”
[ 28.036] compiled for 1.20.4, module version = 1.0.0
[ 28.037] ABI class: X.Org Server Extension, version 10.0
[ 28.037] (==) Matched modesetting as autoconfigured driver 0
[ 28.037] (==) Matched fbdev as autoconfigured driver 1
[ 28.037] (==) Assigned the driver to the xf86ConfigLayout
[ 28.037] (II) LoadModule: “modesetting”
[ 28.038] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 28.044] (II) Module modesetting: vendor=“X.Org Foundation”
[ 28.044] compiled for 1.20.4, module version = 1.20.4
[ 28.044] Module class: X.Org Video Driver
[ 28.044] ABI class: X.Org Video Driver, version 24.0
[ 28.044] (II) LoadModule: “fbdev”
[ 28.045] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 28.059] (II) Module fbdev: vendor=“X.Org Foundation”
[ 28.059] compiled for 1.20.4, module version = 0.5.0
[ 28.059] Module class: X.Org Video Driver
[ 28.060] ABI class: X.Org Video Driver, version 24.0
[ 28.060] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 28.060] (II) FBDEV: driver for framebuffer: fbdev
[ 28.060] (II) modeset(0): using drv /dev/dri/card1
[ 28.061] (WW) Falling back to old probe method for fbdev
[ 28.061] (II) Loading sub module “fbdevhw”
[ 28.061] (II) LoadModule: “fbdevhw”
[ 28.061] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 28.064] (II) Module fbdevhw: vendor=“X.Org Foundation”
[ 28.064] compiled for 1.20.4, module version = 0.0.2
[ 28.064] ABI class: X.Org Video Driver, version 24.0
[ 28.064] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 28.065] (II) modeset(0): Creating default Display subsection in Screen section
“Default Screen Section” for depth/fbbpp 24/32
[ 28.065] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[ 28.065] (==) modeset(0): RGB weight 888
[ 28.065] (==) modeset(0): Default visual is TrueColor
[ 28.065] (II) Loading sub module “glamoregl”
[ 28.065] (II) LoadModule: “glamoregl”
[ 28.066] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[ 28.191] (II) Module glamoregl: vendor=“X.Org Foundation”
[ 28.191] compiled for 1.20.4, module version = 1.0.1
[ 28.191] ABI class: X.Org ANSI C Emulation, version 0.4
[ 28.668] (II) modeset(0): glamor X acceleration enabled on Mali400
[ 28.668] (II) modeset(0): glamor initialized
[ 28.675] (II) modeset(0): Output None-1 has no monitor section
[ 28.675] (II) modeset(0): EDID for output None-1
[ 28.675] (II) modeset(0): Printing probed modes for output None-1
[ 28.676] (II) modeset(0): Modeline "320x240"x59.8 5.80 320 326 328 388 240 242 244 250 +hsync +vsync (14.9 kHz eP)
[ 28.676] (II) modeset(0): Output None-1 connected
[ 28.676] (II) modeset(0): Using exact sizes for initial modes
[ 28.676] (II) modeset(0): Output None-1 using initial mode 320x240 +0+0
[ 28.676] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[ 28.676] (==) modeset(0): DPI set to (96, 96)
[ 28.676] (II) Loading sub module “fb”
[ 28.676] (II) LoadModule: “fb”
[ 28.687] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 28.693] (II) Module fb: vendor=“X.Org Foundation”
[ 28.693] compiled for 1.20.4, module version = 1.0.0
[ 28.693] ABI class: X.Org ANSI C Emulation, version 0.4
[ 28.694] (II) UnloadModule: “fbdev”
[ 28.694] (II) Unloading fbdev
[ 28.694] (II) UnloadSubModule: “fbdevhw”
[ 28.694] (II) Unloading fbdevhw
[ 28.998] (==) modeset(0): Backing store enabled
[ 28.998] (==) modeset(0): Silken mouse enabled
[ 29.018] (II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
[ 29.024] (==) modeset(0): DPMS enabled
[ 29.029] (II) modeset(0): [DRI2] Setup complete
[ 29.029] (II) modeset(0): [DRI2] DRI driver: sun4i-drm
[ 29.029] (II) modeset(0): [DRI2] VDPAU driver: sun4i-drm
[ 29.029] (II) Initializing extension Generic Event Extension
[ 29.031] (II) Initializing extension SHAPE
[ 29.033] (II) Initializing extension MIT-SHM
[ 29.036] (II) Initializing extension XInputExtension
[ 29.038] (II) Initializing extension XTEST
[ 29.046] (II) Initializing extension BIG-REQUESTS
[ 29.047] (II) Initializing extension SYNC
[ 29.048] (II) Initializing extension XKEYBOARD
[ 29.049] (II) Initializing extension XC-MISC
[ 29.050] (II) Initializing extension SECURITY
[ 29.050] (II) Initializing extension XFIXES
[ 29.051] (II) Initializing extension RENDER
[ 29.052] (II) Initializing extension RANDR
[ 29.054] (II) Initializing extension COMPOSITE
[ 29.054] (II) Initializing extension DAMAGE
[ 29.055] (II) Initializing extension MIT-SCREEN-SAVER
[ 29.056] (II) Initializing extension DOUBLE-BUFFER
[ 29.057] (II) Initializing extension RECORD
[ 29.058] (II) Initializing extension DPMS
[ 29.058] (II) Initializing extension Present
[ 29.059] (II) Initializing extension DRI3
[ 29.060] (II) Initializing extension X-Resource
[ 29.061] (II) Initializing extension XVideo
[ 29.062] (II) Initializing extension XVideo-MotionCompensation
[ 29.062] (II) Initializing extension SELinux
[ 29.062] (II) SELinux: Disabled on system
[ 29.062] (II) Initializing extension GLX
[ 29.063] (EE) AIGLX error: sun4i-drm does not export required DRI extension
[ 30.646] (II) IGLX: Loaded and initialized swrast
[ 30.646] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[ 30.647] (II) Initializing extension XFree86-VidModeExtension
[ 30.647] (II) Initializing extension XFree86-DGA
[ 30.648] (II) Initializing extension XFree86-DRI
[ 30.648] (II) Initializing extension DRI2
[ 30.659] (II) modeset(0): Damage tracking initialized
[ 30.659] (II) modeset(0): Setting screen physical size to 84 x 63
[ 31.258] (II) config/udev: Adding input device rancidbacon.com UsbKeyboard (/dev/input/event1)
[ 31.258] () rancidbacon.com UsbKeyboard: Applying InputClass “libinput keyboard catchall”
[ 31.258] (II) LoadModule: “libinput”
[ 31.258] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[ 31.343] (II) Module libinput: vendor=“X.Org Foundation”
[ 31.343] compiled for 1.20.4, module version = 0.28.2
[ 31.344] Module class: X.Org XInput Driver
[ 31.344] ABI class: X.Org XInput driver, version 24.1
[ 31.344] (II) Using input driver ‘libinput’ for ‘rancidbacon.com UsbKeyboard’
[ 31.347] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 24 paused 0
[ 31.347] (
) rancidbacon.com UsbKeyboard: always reports core events
[ 31.347] () Option “Device” “/dev/input/event1”
[ 31.348] (
) Option “_source” “server/udev”
[ 31.429] (II) event1 - rancidbacon.com UsbKeyboard: is tagged by udev as: Keyboard
[ 31.429] (II) event1 - rancidbacon.com UsbKeyboard: device is a keyboard
[ 31.437] (II) event1 - rancidbacon.com UsbKeyboard: device removed
[ 31.437] () Option “config_info” “udev:/sys/devices/platform/soc/1c1a400.usb/usb2/2-1/2-1:1.0/0003:4242:E131.0001/input/input1/event1”
[ 31.437] (II) XINPUT: Adding extended input device “rancidbacon.com UsbKeyboard” (type: KEYBOARD, id 6)
[ 31.437] (
) Option “xkb_model” “pc105”
[ 31.437] () Option “xkb_layout” “us”
[ 31.447] (II) event1 - rancidbacon.com UsbKeyboard: is tagged by udev as: Keyboard
[ 31.448] (II) event1 - rancidbacon.com UsbKeyboard: device is a keyboard
[ 31.458] (II) config/udev: Adding input device axp20x-pek (/dev/input/event0)
[ 31.458] (
) axp20x-pek: Applying InputClass “libinput keyboard catchall”
[ 31.458] (II) Using input driver ‘libinput’ for ‘axp20x-pek’
[ 31.461] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 27 paused 0
[ 31.461] () axp20x-pek: always reports core events
[ 31.461] (
) Option “Device” “/dev/input/event0”
[ 31.461] () Option “_source” “server/udev”
[ 31.467] (II) event0 - axp20x-pek: is tagged by udev as: Keyboard
[ 31.467] (II) event0 - axp20x-pek: device is a keyboard
[ 31.467] (II) event0 - axp20x-pek: device removed
[ 31.468] (
) Option “config_info” “udev:/sys/devices/platform/soc/1f03400.rsb/sunxi-rsb-3a3/axp221-pek/input/input0/event0”
[ 31.468] (II) XINPUT: Adding extended input device “axp20x-pek” (type: KEYBOARD, id 7)
[ 31.468] () Option “xkb_model” “pc105”
[ 31.468] (
) Option “xkb_layout” “us”
[ 31.480] (II) event0 - axp20x-pek: is tagged by udev as: Keyboard
[ 31.480] (II) event0 - axp20x-pek: device is a keyboard
[ 32.059] (II) modeset(0): Disabling kernel dirty updates, not required.