Keyboard connection problems

I’ve assembled my unit and I’m having trouble with the keyboard. In its assembled state the pogo pins don’t make a good contact with the motherboard, so to get it to work I need to push down on part of the keyboard near the pins for it to make contact.

It seems the case isn’t strong enough to hold it in place tightly enough.

Any suggestions what I can do to fix this? One option is to solder tiny wires to the pins and the contacts on the motherboard, but I’m not sure there’s enough room in the case for the wires.

Maybe @Godzil can give some insights about assembly. I would wait first to see if there are some assembly tricks to be performed before trying other hardware solutions like the wires.

1 Like

I’ve not had any problems with mine, so I think the design is sound. I would recommend you look carefully to make sure there is nothing in the way of closing like flashing from the molds, and that the front of the case is getting clipped together. Do any of your pieces appear warped?
If you do the solder route, I’ve had a lot of luck using polyimide (Kapton) tape to cover the solder joins and hold the wires in place. The tape also works as a mask to keep the hot iron from damaging nearby bits (as polyimide is very heat resistant). I’ve not soldered on my DevTerm yet, but I’ve done plenty on Pi0 and other projects, you can fit a lot of stuff in a small space if you use thin wires (30-gauge “wire wrap” solid wire for example). Use a fine gauge of Kynar (PVDF insulated) wire for good results.

The way the keyboard connect is a press fit solution. You need to apply a little bit of force (but not much) for both the keyboard and the orange layer to stick together in the right position.

If the keyboard is in the right position, closing the lid should be really easy and once the bottom hooks are set; it should stay flush with the bottom layer. If it does not, that mean that something is not in place.

The case should not really apply any force on the internal when you are closing it.


My keyboard also didn’t work at first. Then I tried to connect a keyboard via USB. But that didn’t work either. So I figured, that something else must be wrong.

I took out the CPU core module and re-seated it. That fixed it for me. It seemed to be a bad connection between the module and the socket.

1 Like

Interesting but make sense, as it use USB lines that are directly connected to the SoM, it can be dirty enough for the connection to be bad.

When you mount the SoM, make sure to not touch the golden connectors!

1 Like

I have the same problem, I don’t touch devterm for a while and then the keyboard lose connection. I have to take out the extention board and re-seated it, and then it works again.

Same problem for me. I cannot even use a peripheral mouse /keyboard to control the machine. I have tried 2.4G mouse and lined keyboard for each of the 3 USB port but no response at all. What I can do to my Devterm is only pressing the power btn to power on and long pressing to force power off. So frustrated.

My keyboard lose connection again. It seems a big issue.

I have the same problem, its intermittant, the keyboard stops working sometimes and I have to open the thing up, reseat it and it’s fine again.

Definitely a connection issue. I will see if adding a tiny bit more pressure between the case and the top of the keyboard might keep it seated better.

1 Like

I’m in the unreliable keyboard and mouse club as well. Even when I take the keyboard out and back in or apply pressure over the contact points, they won’t work. It seems that taking the whole darn thing apart and back together solves it temporarily. I’m not sure I want to deal with that a few times a day…

1 Like

After a day or 2 of this, I removed the core from the mainboard interface and gently cleaned the contacts with a cotton swab and 91% rubbing alcohol. I’ve not had the issue since. I’m not saying it’s a guaranteed cure, but the hints from previous posters with similar experience let me in this direction. So far, so good.

Have you put the screw to hold the core? Especially with the A06

So, I just had this problem today - but I am unsure if the issue is the same or different. I had left the device plugged in while I manipulated the configuration via SSH, however upon picking it up I noticed that the keyboard and mouse were not accessible. At first I had thought that it was related to some of these issues. Later, I plugged in a mouse and keyboard and it still did not work.

Finally, in an act of desperation, I flashed the microsd card and now everything works again. It’s possible in my case, somehow the software got corrupted somehow. It may be a hardware issue in my case, but it seems to coincidental so for folks struggling with this maybe you can try nuking the card (or at least inserting another flashed card) to see.

Yes. I always used the small screws on either side of the core module. (Good thing to point out, though…)

I point it because the A06 alone is quite a heavy module, especially compared to the CM3 or worse the dram the socket is made to hold, and if you put the heatsink (and you should put it) the weight will more likely make the module to get dislodged from the socket

So ok if you put the screws it is not linked with a potential misconnection when you move the device.

1 Like

i met this problem once before, mouse and keyboard had been lost.
but, all’s go fine after i reassembling the keyboard.

1 Like