Keypad not working

hardware

#1

Hi guys , im coming here after a while and tried everything possible .

Basically : my gameshell is working perfectly , ( os booting , screen working , … )

BUT the keypad is not working , tried to invert the cable , unplug / plug many times , tried to remove the battery , boot it without the keypad ( btw there is 2 led lighting on the keypad board )

Thanks to @Godzil who told me to plug it on my pc , is being detected on my pc .

So if @yong @hal have any solution for me , it would be great .

UPDATE : Tried this tutorial [Tutorial] How to compile and upload code to the keypad , it worked but the keypad still not working

UPDATE 2 : After some help from @Petrakis, we tried with debug 1 , the keypad IS working but seem like its the port from the motherboard !

Best regards , Lenux :wink:


#2

@hal / @yong After some debugging using the modifications to the code I made https://github.com/Mihaylov93/Keypad/blob/master/clockworkpi_keypad.ino

We tested that the keypad board works, the problem one of the following:

  • Cables not fully inserted.
  • Cable connector broken/defective.
  • Board connector broken/defective.

#3

We got your email, I’m sorry for this problem, we could send you a replacement cable, with connectors on both ends?
Is that OK?


#4

what if the connector won’t work :confused:
im really scared about this , but if it does work why not


#5

But how are the board connectors?


#6

Not working at all for the keypad


#7

But are they visually ok? If they are not a new cable wont do nothing


#8

yeah , so that mean i will need a new board ?


#9

@hal @yong

I encountered with the same problem BUT NO led lights on KeyPad board:

  1. tried another 4 pin cable , still NOT working.



#10

I asked for a new mainboard i should get mine soon


#11

@yong
I send email to help@clockworkpi.com 3 days ago ,and no reply yet.


#12

Just received the main board … Im quite deceived , after some try on the same problem repeat @yong i dont know where the problem is coming from … it worked for 4 touches then nothing .

Thanks for this product , was funny if it would have worked .

Anyways i might come back when the product WILL be ready and perfect .

EDIT : !!!After some retry it work i will get back soon if its not working everytime .


#13

That is weird, I mean one not working I can understand, replacement not working too, you may have a bigger problem.

What did they send you as a replacement? the keypad or the mainboard?

Have they sent you a set of wires too?


#14

After edit up it worked i just had to turn off / on again my gameshell @Godzil


#15

:smiley:

It is working! :slight_smile: :champagne:


#16

I 've got the new mainboard from clockpi t4eam

and some awesome new feature~~,

and works now~

Thanks yong! @yong


#17

I’m interested to know what this awesome new feature is :thinking:


#18