Gameshell keypad not working

So I can turn my gameshell on, but it will not respond to any button presses or anything. My cables are all connected but the keypad or the light key won’t work.

Mine, either. I tested it with my friend’s and found it is the mainboard’s problem. I planed to contact customer service after Spring Festival.

Can someone please help me!!!

I imagine this would be very annoying i’ll try and help with some basic questions as far as my knowledge goes.

Have you assembled the keypad block correctly? Do the buttons push down on the contact pads?
This one sounds dumb but have you got it plugged in? and is it the right way around? It shouldn’t be possible to plug it in the wrong way around but I think it could be forced.
Have you tried plugging in a normal usb keyboard and using the arrow keys and other keys?

I haven’t tried using a normal keyboard
And it’s plugged in the correct way, the contacts are all pushing down when I press too

And it’s weird because when I turn it on the time always says 12:58. It never changes

Hmmm, have you tried reflashing the msd card with the new image (0.3)?

No. Maybe that would help

I’ll have to do that when I get home.

Since you said that the time isnt changing it makes me think something is wrong with the image or maybe even the msd card, give it a go and let us know how it goes.

Do u know if there is a thread to show me how to flash the memory card?

I can tell you the basics, basically just get your sd card into your computer somehow, download the latest image, get a program called “etcher”, select the file you downloaded, select the sd card and then wait for it to do it’s thing, then just safely eject it and put it in your gameshell. :slight_smile:

EDIT: Here’s the link

Thanks @Joel I hope this works. I’ve had my gameshell two days now and haven’t been able to do anything but turn it on and off.

Hey did u ever figure out wats wrong with your gameshell?

Did anyone get their keyboards to work ?

Any luck ? Mine still isn’t working.

Hey Jay, you may want to check the connectors, the pins may be bent. That’s the problem I had with mine and I used a safety pin to bent it into place.

It was indeed bent!! Thanks a million. Cracked the keypad connector a little trying to straighten it out but it’s working nonetheless, thank you:):):):slight_smile:

Glad I could help dude. :v:t5: