Let's play Duke Nukem 3D!


#21

I got it working using the build from august. https://dukeworld.com/eduke32/synthesis/20180801-6962/eduke32_src_20180801-6962.tar.xz


#22

Works with the august build, thanks.

But where is the config file for the keymaping? I want to unbind in the options but I don’t know how :S


#23

Edit this file or remove to reset all keys:

~/.config/eduke32/settings.cfg

#24

Anyone tried to run NBlood?


#25

I got NBlood working on my Linux desktop. I can take a look at it for the GameShell after building a new eDuke32 for GameShell.


#26

I think im getting the same error as sjenkinsjr when I try to build.

Is this due to something with the 3.1 update?

cpi@clockworkpi:~/svn.eduke32.com/eduke32$ make
/bin/sh: 1: svn: not found
fatal: Not a git repository (or any of the parent directories): .git
Built object obj/duke3d/game.o
Built object obj/duke3d/global.o
Built object obj/duke3d/actors.o
Built object obj/duke3d/gamedef.o
Built object obj/duke3d/gameexec.o
Built object obj/duke3d/gamevars.o
Built object obj/duke3d/player.o
Built object obj/duke3d/premap.o
Built object obj/duke3d/sector.o
In file included from source/duke3d/src/anim.cpp:34:0:
source/build/include/animvpx.h:11:30: fatal error: vpx/vpx_decoder.h: No such file or directory

include <vpx/vpx_decoder.h>

                          ^

compilation terminated.
Failed building obj/duke3d/anim.o from source/duke3d/src/anim.cpp!
GNUmakefile:981: recipe for target ‘obj/duke3d/anim.o’ failed
make: *** [obj/duke3d/anim.o] Error 1


#27

You have to install these packages for building:

sudo apt install libflac-dev libsdl2-mixer-dev libvorbis-dev libvpx-dev

I found out a way to make the “Segment Fault” go away. I am now building it to share it.


#28

OKAY. Here is the new February release made user friendly!

Follow these instructions:

Feedback anyone? :slight_smile:


#29

working on it. Will message back in a few minutes.


#30

Works good for me. Definitely need the light key to play this one. So many keys to configure. Very easy. I had a hang up with the mv command, because I already had Duke3d in the games folder. I manually moved the eduke file and followed the rest of the instructions.

Thanks Oet :+1:


#31

Just followed the new tutorial.

I Reload the UI and I get the Duke icon as anticipated.

When I click on the duke icon I get

“Launching…”
“loading…” screen

then the screen goes completely black for about 3-4 seconds then it goes right back to the UI home screen.

Problem with the DUKE3D.GRP??


#32

If you followed the instructions type in this to find out:

DISPLAY=:0 "/home/cpi/apps/Menu/Duke Nukem 3D.sh"

#33

/home/cpi/apps/Menu/Duke Nukem 3D.sh: line 2: 1324 Segmentation fault ./eduke32


#34

Great… those are the hardest. :confused:

  1. Are you sure you are running that new binary of the zip file?

  2. If you compiled yourself, did you use:
    make USE_OPENGL=0

  3. Do you have the old or new GameShell motherboard?


#35
  1. I followed your new steps that you posted a little while ago

  2. lol I dont know, did I? Im super new to this and have VERY little linux experience about 18 years ago…

  3. Its a brand new GS as of 2 weeks ago.


#36

What size is this file?

ls -l ~/games/Duke3D/eduke32
-rwxr-xr-x 1 cpi cpi 1184008 Feb 16 00:59 /home/cpi/games/Duke3D/eduke32

#37

-rwxr-xr-x 1 cpi cpi 1548384 Feb 15 20:33 /home/cpi/games/Duke3D/eduke32


#38

I think you are running a different file (ca. 1.5 MB) than what is in the zip (ca. 1.2 MB)?


#39

So I deleted the file and redownloaded and everything is now working.

Thanks So much for all your help, Oet. Tomorrow night will be getting wolfenstein up and running. Cheers!


#40

I am your biggest fan! thank you cant wait till your next guide so easy to follow and everything just works!