Official Armbian 22 images

Hello here,

Just got my DevTem (A06) and the official image is based on an unsupported version, so I cannot upgrade or even install any package.

Is there a plan to provide an up to date image?



I’m super interested in this as well!
I got the latest armbian (DevTerm A06 – Armbian) and it works pretty well out of the box but not 100%
I took some steps out of the tutorial to build your own image(Create DevTerm A06 OS image from scratch · clockworkpi/DevTerm Wiki · GitHub)
with that I got the fan and power control working.

sudo apt install wget -y

wget -O - | sudo apt-key add -
echo "deb stable main" | sudo tee -a /etc/apt/sources.list.d/clockworkpi.list

sudo apt update
sudo apt remove linux-image*
sudo apt install devterm-kernel-current-cpi-a06 devterm-fan-daemon-cpi-a06 devterm-thermal-printer devterm-thermal-printer-cups devterm-wiringpi-cpi  devterm-first-start-a06


sudo apt install -y arandr chromium-browser vlc cpupower-gui xfce4-power-manager

But still broken are:

  • suspend (cannot wake up)
  • Thermal printer (shows in menu but does not print)
  • sound (volume is super low)

hope that helps at least a little bit.
If anybody has any extra help please let me know

You can get power working with just
sudo apt install xfce4-power-manager

I don’t know if that activates the fan.

I didn’t install the CPI armbian 21 kernel on 22 but if it works for you great.

I tried the Armbian 22.05 Jammy XFCE build, but after configuration when the desktop GUI is about to start I hear a pop coming from the device (maybe the speakers) and then the screen turns black. :worried:

Oh no ⊙﹏⊙
I hope your Hardware is not broken…
Did you do an integrity check on the image after downloading it?

You are totally right!
I made a mistake while typing that post it shoud say:

sudo apt install wget -y

wget -O - | sudo apt-key add -
echo "deb stable main" | sudo tee -a /etc/apt/sources.list.d/clockworkpi.list

sudo apt update
sudo apt install devterm-fan-daemon-cpi-a06 devterm-thermal-printer devterm-thermal-printer-cups devterm-wiringpi-cpi

I just received my A06 and ran into the same, extremely frustrating situation. Fortunately, and thanks to @Steven_Boger 's kind suggestion, I’m now happily trucking away on nightly Manjaro Sway builds, via this link..

BTW, what an absolute blast I’m having on this little machine. I love the tiling WM on Manjaro in particular, as it works well with all of the horizontal screen real estate.


Any idea if this will work on the A04? Or are we left out in the cold?

Since the AO6 and AO4 models are just two derivations of the same board, I “think” it should work. Let us know, will you?

BTW, sitrep on Manjaro/Sway on the AO6: Though I’ve got a strange keyboard configuration file anomaly warning at startup, things are working really well in terms of stability and performance. I also like having access to the latest packages this way.

The A04 is an Allwinner chip (H6?) and the A06 is a Rockchip RK3399 so they are very different (aside from both being ARM).

If the processor specific stuff is accounted for, the rest (clockwork pi + expansion board) should be pretty much the same.

All is good, turns out if was a power-supply issue.
Armbian 22.05 Jammy XFCE is working fine. I still have to try the printer.

here is the updated A06 os image , I just made with Armbian 22

with all the stuff in the old os image like kernel ,printer ,screen rotation ,pre-config of xfce4-power-manager ,etc

Armbian 22 use ubuntu 22.04 LTS , will end at 2037 ,so this version will last longer



Thanks @guu it’s nice to have Armbian 22 with working printer.

Thank you very much that you made this. still has the file DevTerm_A06_v0.1a.img.bz2
Can we expect that will also have the updated files?
Because not all users will find this thread and this forum.

1 Like

Has anyone encountered sound problems? It recall it worked out of the box for me but suddenly there’s no sound and playback is slightly sped-up.

I tried unmuting various things in alsamixer, set devices off and on again in pavucontrol, reseating the core module.
es8323 does show up in dmesg:

[   10.020260] input: rockchip,es8323-codec Headphone Jack as /devices/platform/es8323-sound/sound/card1/input2
[   10.047662] systemd[1]: Finished Load/Save Screen Backlight Brightness of backlight:backlight@0.
[   10.110580] brcmfmac: F1 signature read @0x18000000=0x15294345
[   10.112714] dw-apb-uart ff180000.serial: failed to request DMA
[   10.115507] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43456-sdio for chip BCM4345/9

What I did do is that I copied the whole image to another SD card and extended the partition/fs manually after the initial Armbian setup.

Hello, yes, I also have observed the same sound problem (no sound and speedup of playback). Usually reboot helps but that’s still annoying.
See this thread:

I did comment out the following in /etc/pulse/, killing and running it manually, rebooting. It works now.

### Automatically suspend sinks/sources that become idle for too long
-load-module module-suspend-on-idle
+#load-module module-suspend-on-idle

your solution is great

and os image link updated