So, are there any fixes yet?

Had my A04 for around two months. Shortly after it arrived I did an update that screwed wireless comms up and broke the ability to lock the screen. The advice I was given was “oh just reflash it” - which is a cop-out.

Is this software going to be updated, or the myriad bugs actually addressed? Right now I’m feeling like I’ve paid £200 for a paperweight. Sure, I can just about use it, but I either can’t update it or I can’t get online or lock it. Hell, the display driver itself is jank.

3 Likes

What debugging steps have you taken? Have you tried a USB wifi or ethernet adapter? Without an internet connection you won’t be able to do much to fix it…

1 Like

I flashed a second SD card, still got the original though. Though a fix could be rolled out as a package to be copied into the thing from a USB stick or something. What I’m hacked off about is that pretty much nothing has been done to address the issues in the OS - broken features are being left broken by CPI, and what fixes we can get are done by the community so I have to install them manually each time if something goes wrong and I have to start again.

I’ve not done a whole lot of debugging with it. I did my time with Linux years back and things have changed. I’ve got no interest in reaqcuainting myself with the internals of a Linux system just for the sake of having access to the basic functionality that was promised out of the box.

I suspect it’s something to do with drivers, like I suspect the display issue is something to do with badly-configured drivers too, but I’ve got better things to do than sit opening each config file and trying to parse and correct it, or rebuilding driver packages, recompiling them into the kernel, whatever.

2 Likes

You bought a devterm but you have no interest in being acquainted with Linux internals? :wink:

also what does “i did an update” mean?

1 Like

Not any more, no. I bought it as a tool to use. I am already well-enough acquainted with Linux but don’t have any desire to spend time I could spend doing things I actually enjoy doing on learning how to mitigate the issues in a janky and broken operating system which should have worked out of the box. I’m not sure what makes that difficult to understand. This thing is marketed as a tool for people who like old-style portable computers, not a fixer-upper for people who enjoy rewriting drivers. The model I ordered is described on the front page as “suitable for general purposes […] such as writing” - except it isn’t.

And “I did an update” means… I did a fxin update. The OS image that is provided is outdated and I ran the upgrade when the OS offered it. That’s what “I did an update” usually means, no?

2 Likes

Same here, very disappointed by the a04 core, it’s not really suited for general purposes as written in the product page, too hot and shuts down when all the cores are enabled after a while. There is a huge gap between a04 and a06.
Maybe a new custom os could fix our lovely a04

That’s sad to hear. I just went with the A06 and it’s great. Everything is working on mine - with the expectation that it’s a snap-together system for developers/hackers. It’s basically a portable raspberry pi, not a laptop.

Note, “armbian-config” shouldn’t be used. Don’t use armbian-config to set wireless either - just do it through the network-manager gui.

As for updates, this is a custom build of armbian - clockworkpi make a few tweaks to it, but 5 of the 6 repo’s defined are directly from armbian. They are regularly updated from upstream debian sources. (depending on OS version…)

A quick read of the A04 discussions leads me to believe the A04 OS build may be a little more unstable. But I’m willing to help you if there is a real issue. I’m not connected with Clockworkpi, btw.

So, try this…

  • Get a fresh sd card. Install the newest A04 build from here: http://dl.clockworkpi.com/DevTerm_A04_v0.1a.img.bz2
  • Setup wifi through the Network Manager gui. Don’t run armbian-config.
  • Perform a system update and a performance improvement patch: sudo apt-add-repository ppa:aglasgall/devterm-a04-xorg && sudo apt update && sudo apt upgrade
  • reboot

What’s the behavior afterward? Xwindows should be much faster. Wifi should still be working.

You should also get familiar with the “gearbox” program that set’s the A04’s four cpus on and off, and to different speeds. My A06 starts in power-saving mode, without all the cores running. It’s much more useable after I bump them up.

  • sudo apt install devterm-gearbox-a04
  • sudo devterm-a04-gearbox -s 4 # performance mode forA04

There’s a third-party gui version:

image

-Steven

5 Likes

I’ve done all the steps suggested by Steven_Boger. That brings the A04 in a somewhat usable state. It is OK is for everyday news reading or as a 3rd screen for your favorite chat.

As someone said: I think of it as a Raspberry in a fancy shell. If I really want a device to be productive and to earn money with I’ll always stick with my trusty ThinkPad (or insert your favorite manufacturer here ^^).

Unboxing and building was really good. The handbook is well put together. I would even say the same for the hardware: it’s well put together if you consider the price, chip shortage and probably batch size.

But beyond that:

  • If CPI communicates it’s through this forum. And at least it feels rare.
  • It seems there is no firmware that makes the mousewheel really usable. Even the improved user-firmware scrolls choppy. At least for me and some other users. That really makes the device somewhat unusable (except terminal use or with an external mouse).
  • I tried to take a look into the keyboard firmware. But CPI only provides some heartless codedrop with some random firmware state as it looks like.
  • Documentation on how to upgrade the firmware? Or even build it yourself? Well: Good luck. Maybe something is in the forum. I mean: I can guess it’s Arduino. But 1/2 screen page on how to build it wouldn’t hurt.
  • Same for the Armbian: What we get is Ubuntu 21.04. That not even LTS. It was out of support a few weeks after I got the device. Now I have to make sure it’s not exposed to anything Internet at all to not risk being part of a RaspberryPI style botnet? Maeh.
  • Is there a strategy to go forward? I don’t know. I haven’t found anything on that topic in the forum. Or in the git repo…
  • I can’t even build the Image myself. For the Armbian there is at least some (incomplete and wrong!) README. With some bits (again from the forum) I can at least start the build process. How does CPI build their images? By luck? Golden Image on a golden computer? From what I have seen so far: I fear the worst.
  • But my build process fails when building Uboot. Seems I have to learn Armbian now.

I really hope that the community brings this device forward. I don’t have the feeling that CPI will help us make it more than an outdated paperweight.

3 Likes

Yeah. I’m disheartened by the shipment of an EOL Armbian release. What makes it even worse is that I can’t build a new image using the same outdated release of Armbian, let alone a new one.

Additionally, ClockworkPi explicitly picked Armbian and doesn’t appear to be directly contributing back to the Armbian project, neither in terms of monetary contributions nor even code/maintenance for their boards, or anything else.

Hopefully I’m wrong and they’re in the process of getting that ramped up…

Given the age of this thread I’m bugging them on twitter as well.

@guu thank you. That, in part, addresses the issue created on Github.

However, that doesn’t address other concerns posted here and elsewhere on the forum.

  1. Are there plans to get a newer OS image for the DevTerms that address the issues brought up on the forum?
  2. What about the issue with shipping and providing a download link for an EOL OS image?
  3. Will ClockworkPi be officially providing support (either financially or as a maintainer for their boards) to Armbian?
  4. Or will Manjaro or something else be the officially recommended distribution?

It’s disheartening to see ClockworkPi not being a good member of the OSS community. Hopefully I’m wrong on this point, though.

I don’t know your level of involvement with ClockworkPi, so if you can’t answer these questions I’d like someone from CPI to do so.

I dumped Armbian on my A06 in favor of Manjaro Linux. Even in its pre-release state, it’s more than stable enough for my needs.

5 Likes

What works and what doesn’t?

I haven’t tried the printer yet so I don’t know about that, but otherwise everything I’ve tried seems to work fine, no driver issues that I’m aware of. I’ll try to play with the CPU gearshift in the next few days. So far, so good.

Interesting. Any idea if it’ll work on the A04? I’m downloading the x64 version now to play with in a VM, if I like it I might see about putting it on the DT.

I don’t think they have a version for the A04 yet, just the A06, but I could be wrong.

1 Like

OK - I’ve done this, and everything seems to be working. Sound works too, which must be in the update you mentioned because it didn’t work out of the box when I first got it. Only problem now is that, even though the sound is working, the speakers are constantly squeaking, sounds like a wheel turning on a rusty axle. Would you happen to know anything about that?

Edit: probably should ignore this actually, it only happens when it’s plugged in.

1 Like

Good! See - computers don’t work unless we do exactly what they want. :wink:

I only own an A06 and don’t have speaker issues, sorry. In fact, I’m surprised at how loud they are for the size. You could double check the physical placement of them to make sure you fitted them properly - however if both are producing sound, then that’s not the issue. The “prongs” should both be facing outward toward the edges of the case.

(colons are the prongs)

:[|||||||] … [|||||||]:

-S

1 Like

Note, since building the Devterm A06 OS image was mentioned here, I’ll say that I submitted a pull-request to fix the build. It’s working now. I also updated the instructions in the readme.