DevTerm OS A06 image files

Unless you want to Create DevTerm A06 OS image from scratch. We will use this page to share our official DevTerm A06 CM3 image files here:

IMG_A06

Download:
http://dl.clockworkpi.com/DevTerm_A06_v0.1a.img.bz2 ==> Mirror #1 ==> Torrent
md5sum: 3a027da4f1d0110bc89062f90ac34418
Size: 1.4G
v0.1 latest release note:

Based on the Armbian 21.08.0 Trunk Hirsute ARM64 system
Linux Kernel v5.10  
Lightweight Xfce4 desktop environment
Rechargeable battery energy management
Standard CUPS thermal printer driver support
(Both username and password for the default user is pi, if not modified during initial boot)
Following the principle of [minimal changes from scratch](https://github.com/clockworkpi/DevTerm/wiki/Create-DevTerm-A06-OS-image-from-scratch)
**A BIG THANK YOU** to the open source ecosystem and all supporters from around the world!
10 Likes

Adding it to my seed server.

3 Likes

@yong or anyone else who can assist—
All three links are, as of this moment, broken. (Including the torrent, sadly, as there’s no accompanying magnet link.) I’d like to flash my own SD card (to increase IO speed and also give myself a bunch more local storage—wow SD card costs have gone through the floor recently) on my AO6 DevTerm, but I need a link!

Thanks muchly.

http://dl.clockworkpi.com Should be working, we use the torrents normally to offload come traffic from CPI but those are direct links and should be always available.

1 Like

Thanks @Petrakis! For some reason, in my browser (Chrome, so… not non-standard) when I click the dl.clockworkpi.com link in the OP, it opens a new tab and then immediately closes—but when I just go to dl.clockworkpi.com from your link, I’m able to download the image with no issues. Much appreciated!

Weird, glad it worked.

Maybe it was cached or something :smiley:

A kernel update for A06
to support suspend on A06

sudo apt update 
sudo apt install devterm-kernel-current-cpi-a06

if apt failed with unexpected error like has misum,etc,try refresh the apt repo with

wget -O - https://raw.githubusercontent.com/clockworkpi/apt/main/debian/KEY.gpg | sudo apt-key add -
sudo apt-key del 57B7A98BBEBA8C10CA4458810DD08811478B1249
sudo apt update

cpi apt repo has re-generated recently

Important notes about this update:

  1. only device suspend support,not the MIPI screen suspend or power saving ,so try not to enable Display power management

  2. suspend icon/button had disabled/hidden before,here is how to enable them back
    goto Left-top corner,Applications->Settings->Settings Editor

find the xfce4-session ,on the right ,scroll to bottom ,find ShowSuspend,enable it

another suspend icon/button is on the right-top corner, the user menu,it needs editor to edit xfce4 config files manually, file location is: ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml

set -suspend to +suspend

after reboot ,suspend icon/button should return back

patch original is from

https://patchwork.kernel.org/project/linux-rockchip/list/?series=554547

all patches are in GitHub now

2 Likes

So after I updated the kernel (and restarted) whole keyboard stop to respond. Anyone had same problem?

update kernel won’t effect the keyboard

if you want to wake up from suspend,just press once on power button

if your keybard just stopped respond ,how about replug the keyboard for a try ?

@yong Hi. Are there any plans to upstream support for the ClockworkPi Core A-06 board into upstream Armbian?

It would give me a lot more confidence to go ahead with buying the DevKIt if I knew a more mainstream Arm64 distribution (especially since Deban’s aarch64 packages are apparently supported?) also had support.

2 Likes

The base image is still from September 2021 ?
Still no official Armbian?

2 Likes