What's your experience getting audio software to run on DevTerm?

Been using a A04 DevTerm for about a week and I am enjoying it so far! I was wondering about getting it to work as a portable software synth setup. Has anyone got any luck with linux / Raspberry Pi version of audio software to work on DevTerm? Could you please share your experience / setup?

So far I’ve tried (using Clockwork OS A04 distro):

ORCA - can install from terminal, haven’t tried using it with other hardware/software yet though
purr-data - some packages that are required for install are incompatible with DevTerm, no luck with Raspbian / Debian versions so far

Also Patchbox OS - I flashed an SD card, but when trying to boot with DevTerm, nothing happens (black screen, no audio/video output)

I am also planning to test:

Sonic Pi
Anything else I’m missing? Max MSP doesn’t seem to support arm architecture from what I could find


I don’t own a devterm, so can’t share any experience, but you can give sunvox a try, it supports a lot of different architectures.
Also it was possible to run samplerbox on a gameshell as it’s just a python script, so I guess it should also be possible to run it on a devterm. Here’s a thread about it on GS. I think it might pair nicely with ORCA :slight_smile:

I have installed schism tracker as it is in ubuntu repos and has full keyboard-only workflow. It works without any problems

also, theoretically, pure data vanilla has more chances of running than purr data