Why doesn't my shortcut work

Here’s my shortcut:

retroarch -L /home/cpi/apps/emulators/snes9x2005_plus_libretro.so

Doesnt work not surprisingly only goes to Retroarch with no game.

I have no cores in /home/cpi/.config/retroarch/cores so I’m using the path i got from the action.config for SNES9X.

I did CHMOD+X the sh file. Not sure what is the deal, but it was a hell of a time getting my shortcuts to work before i formatted and now I’m back where I started…

Do you have the command as a single line or 2 lines as shown in your post?

IIRC it should be a single line with the two paths separated by a single space like this:
retroarch -L /home/cpi/apps/emulators/snes9x2005_plus_libretro.so /home/cpi/games/PocketSNES/SMW2YoshisIsland.sfc

That still looks like 2 lines to me, and when I copy and paste it it’s 2 lines. But I tried it anyway with a single line separated by a single space like you said, still no luck.

Also if it helps, I have my shortcut in the “Launcher” folder, not “LauncherGo” or anywhere else. I wonder should it be in another location ?

The format should look like this as a single line

retroarch -L /path/to/core.so /path/to/game.sfc

I dont know about the location, but you can test if the command works by popping it into the terminal. You could try making a copy of another working shortcut and modifying it to launch what you want?