Arch Linux Install Guide for DevTerm A06

Hey Everyone,

I’m working on a guide to install Arch Linux on the A06, and I feel like I’m getting close but it’s still not booting. I know it’s a lot, but wanted to see if anyone in the community might know where I’m going wrong.

Hoping to get the DevTerm officially supported by Arch ARM when I get this working! Thanks.

7 Likes
1 Like

Thank you guu. I’ve received a lot of helpful support from the Manjaro community. I have Arch Linux working using their u-boot and kernel, and I plan to use it as a test bed for fully porting it to Arch Linux ARM.

For others just wanting to get something working. This is a great option in the meantime.

2 Likes

Release 1.0 Is Live!

First and foremost, a huge thanks to the Manjaro community and to @m4xm4n from the Discord. They deserve all the credit for the kernel and bootloader, for which I only made very minor changes.

You can report issues, download the V1.0 root filesystem, or build your own from the following project:

Enjoy!

7 Likes

Interesting.

I was looking for dan solution and look I found a ready to use one.

Can also be

sudo systemctl enable devterm-fan-temp-daemon-a06 --now

I will test this package and maybe push it Manjaro upstream repo.

1 Like

Nice work porting the Arch kernel on this sweet device.

I’m currently using your v1.0 rootfs, ant it seems like the fan daemon isn’t working. The python script /usr/local/bin/temp_fan_daemon_a06.py uses the gpio command which is available with WiringPi.

I found clockwork’s fork of WiringPi on GitHub : https://github.com/clockworkpi/DevTerm/tree/main/Code/devterm_wiringpi_cpi

… but fails to build. Here’s the full error :

/usr/bin/ld: wpiExtensions.o:(.bss+0x408): multiple definition of `comDat'; drcNet.o:(.bss+0x400): first defined here
collect2: error: ld returned 1 exit status
make: *** [Makefile:93: libwiringPi.so.2.50] Error 1

I looked it up on AUR, and there’s a wiringpi-git package there. I downloaded the PKGBUILD, and tried to build again with - and without - the PKGBUILD’s specific patch for Arch, but it it’s working. Only the error doesn’t output after applying the patch.

Do your fan runs okay? Can you access gpios?

Hey! I’m aware of this and looking to add it to that repo. You can actually build the patched version successfully from the DevTerm repo, but the install script needs to be ported to PKGBUILD, which is what I’m working on right now. To make it build successfully, you need the make flag “-fcommon”.

Added to the list I also need to get the GPU and Audio working. Progress has been slow since I’m changing jobs rights now. :slight_smile:

Feel free to always put a PR on the repo! Otherwise I’ll get around to these fixes as soon as I can.

Could you tell me how you built it? I tried adding -fcommon to both CFLAGS and BUILD_CFLAGS but no luck.

I’m willing to PR the PKGBUILD if I succeed in making the fan work.

Yeah I’m not the biggest fan in how the build script is written. What I did is in the project directory, find all instances of the “make” command, and then add “-fcommon” to each line. I’m away from my computer this week, but I might have the “sed” command I used to do this somewhere. Will look.

Audio is working out of the box for me. Had to unmute Left Mix and Right Mix in alsamixer, then everything worked.

I think my speakers may be broken. They don’t work in the official image either. Thanks for testing and great to know!

You can use the following sed command in the wiringPi project directory to get it to build:
sed -i 's/-fPIC/-fPIC -fcommon /g' Makefile

2 Likes

All discussed changes have been implemented in the new release! This adds wiringpi for fan control and audio fixes thanks to @lonewsk :slight_smile:

3 Likes

Hello,

I followed the instructions starting with “preparing the SD card” using your 1.1 fs release. The device hangs on boot with a “_” prompt that eventually freezes. I’m trying Arch because the stock image has a kernel panic randomly on boot, or after a few minutes of device usage. I’m starting to wonder if they sent me a bad core.

Hey thanks for giving it a try! Would you mind raising an issue on the repository with some more details? I’m going to try another clean install test soon on my A06.

I’ll give it a shot once I get a replacement board. The kernel panics I’m getting with the default image pointing to a bad core. I saw another post from December with my same issue… solution was a replacement.

Hi there, I followed the guide here using the pre-built filesystem. It booted and then I used the Network Manager as you mentioned (sudo nmtui) to get the WiFi going. Then I did the always-tricky-on-arch pacman -Syyu and it is up-to-date now and still booting. Thanks, great job!

After this I enabled and started the fan service as described here but it does not start when I raise the temps using stress -c 6 so maybe something is still missing.

For readers who stumble upon this: I used Release 1.1 and you need to login using alarm/alarm since the root password is missing :slight_smile:

Just wanted to say thanks. I got up and running on release 1.1.

Made a few mistakes first time around setting up the sd card. It might be worth mentioning for others to be careful with which commands need sdX (block0) and which need the first partition sdX1. But, I fixed my mistakes and got up and running, thanks!

Thank you for your efforts on making Arch possible on this device!
Here’s some note that may be useful to someone jumping onboard:

Don’t try to prepare the image yourself if your host machine is running zfs or other exotic kernel modules. mkinitcpio in chroot doesn’t like that. The prebuilt image is fine :slight_smile:

The installation is very smooth. When I was wondering why the log messages are not printed, it boots into a login screen already :smiley:
(note, to enable the console logs, edit /boot/extlinux/extlinux.conf and remove “console=…”)

By default, all 6 cores are enabled, but stuck at lowest freq because of “powersave” governor.
This can be tweaked in the fan control daemon script.

I also notice that the thermal tripping point for this kernel is different from armbian stock that it throttles the cores at 70C. I’m definitely sure I’ve seen temp. being pushed to 80C on armbian.
So here’s some tweaks for the gearbox: gearbox: add thermalzone trip point settings · yatli/DevTerm@f93a0d0 · GitHub

1 Like

Now that the DevTerm is officially supported, an alternative to @css’s guide is just using the Manjaro ARM Installer. It’s an interactive script which does all the setup (user/pass and xfce/gnome/kde), formatting, copying and updating for you.

The only downside is that the script does all the work directly on the SD card (and does not differentiate sd card from internal hard drive, so watch out when choosing /dev/sdX), so you won’t benefit from a computer with an SSD. It took ~1h for me from start to finish, I think. It might feel like the script hangs up on some parts, but it’s just the SD card read/write speed…