clockworkpi

Arduboy Games on the GameShell

SDLK_z => SDLK_u
SDLK_x => SDLK_i

SDLK_q => SDLK_ESCAPE

but not tested yet

Thanks, the key binding works but it have to be changed before compiling.
So now controls works but gameplay is weird. The game freeze every 10 seconds. I tried without lima activated but its worst.

Any Idea?

Well as it is made for full size computer, it may not be superwell optimised for small system like the Gameshell. Hard to tell.

You should try it on another SBC like a Raspberry Pi to see if it behave the same.

I would try to disable that function:

Just adding a simple return; after the struct timespec tp; to see.

If it never happen, this function is buggy, he may never encounter it on a fast system, but could creep in case of a slow or overloaded system.

This is not a fix for the issue as it will induce some other after, but a quick and easy test to see if it is this function that cause the issue you run into.

Wonderfull! It works :slight_smile:
Thanks Godzil and Guu!

I just hope they will emulate the sound soon.

  • combined fixes for key mapping and slow work,
  • fixed display resolution,
  • added an instruction for CPI (with required files to launch it like other “preinstalled” emulators on CPI).

so now we finally can try to play ArduBoy games in easy way on GameShell!

Ho Yeah! Thanks M8 :slight_smile:
So I tried it, had to change the launcher a bit. Most games works but there are still many that do not works (freeze). I love the fact that the width of the screen is used entirely.

I have found an emulator for the GameBuino also. Is it possible?

Hey, how do you transfer hex flies to the Arduboy emulator on the GameShell?

The same way you do any games on your GameShell. Create a folder in /home/cpi/games called ArduBoy and put all your Hex in it. Then make sure your launcher point to it.

You do not flash them like a real Arduboy of course :slight_smile:

1 Like

I’ve tried that but it wouldn’t show up on the GameShell. I’ll send pictures of it.

@Tariq, it must be “hex”-files (on pictrure you attached it is “.arduboy” file),
and the folder must be named “ArduBoy” (case sensitive)
just follow “How to install” section in README

tip: after copying hex-files, restart Launcher (“Reload UI”)

it require “Node.js”
never tried on GameShell,
but here some reply on this

Thanks. I got the hex files, but they’re not starting on the emulator is there anything i did wrong?

it’s hard to guess…
if you follow exactly every step in the “How to install” instruction, then it should work… i verified every step when wrote it…
but, you could also try to rebuild “ArduBoy” by yourself. maybe it will help…
also, it worth to mention, that NOT every game(hex-file) will work, i tried the “ardynia.hex”, but it never worked on that emulator.

Tariq, try a game I know is working:
https://www.dropbox.com/s/gf6yykx03c3nrgv/FirePanic.hex?dl=1

1 Like

The emulator takes me back to the home screen regardless of what game i try.

did you tried to rebuild emulator by yourself?
if ‘yes’, and it still not working,
make sure, you switched to the Lima GPU driver via Settings->GPU Driver Switch->Lima driver (with Fbturbo, emulator either running too slow, or not starting at all).

if it still not working,
try restart your GameShell, make attempt to start some ArduBoy game, then SSH to GameShell, and run a command

cat /tmp/x.log

paste the result here

Thanks but Lix helped me with it