Audible or Visual warning if the batttery is about to give out

Thanks Develroo!

I finally got the update to take and it worked beautifully… Until I updated the source.list and installed the update via apt-get. What resulted was an updated system, but all network connections disabled. No WiFi or USB-ETH. I ended up having to start from scratch and try again.

This time, when I got to the final update process, I fixed the source.list with:

sudo sed -i – ‘s/[us]’ /etc/apt/sources.list

And then I used aptitude to successfully update:

sudo aptitude update
sudo aptitude full-upgrade


Anyone interested in making up a GSNotify script for when you are at 100% charge!?

What exactly did you change in the sources.list file? I got an unknown command error when running your sudo sed command.
sed: -e expression #1, char 1: unknown command: ?’ `
this is what my sources.list file looks like now:

# deb stretch main

deb stretch main
deb-src stretch main

deb stretch/updates main
deb-src stretch/updates main

# stretch-updates, previously known as 'volatile'
deb stretch-updates main
deb-src stretch-updates main


I’ve gone through this guide (except for changing source.list to buster) but I think I may have messed something up along the way. I used to just get stuck on a loading screen (similar to @nouty) when booting the gameshell but now I just get stuck on a linux screen. I ran that same DISPLAY=:0 ./ command and got this error:



Edit: I realized that I do have an empty Menu folder since I did this command:

Are we supposed to move everything from these folders

into the new /home/cpi/apps/Menu folder?

I think this error means your X is down, there is no gui in the gameshell now ,right?

so I recommend to re-flash the tf card of gameshell with os v0.4

that would be easier to fix the problem

1 Like