Batteries drain whilst switch

I have discovered that if the DevTerm is powered off and lefy for a few days the batteries go flat, is this expected ?

1 Like

I’ve left my DT switch off for a full week and the battery are not flat.

Are you sure it was fully off when you left it?

Is it possible that the batteries you are using do not have protection circuit/board?

1 Like

I have the problem that if I leave it for a while, it seems discharged because it powers on for a few seconds then shuts off. but when I plug it in and look the battery is still charged. I left it unplugged for almost a week and it says 98% charged once I finally boot it.
Do you think it’s possible that you’re seeing the same issue that I am?

1 Like

Lights out, no activity, no presence on network. I’m going to test it again.

1 Like

They are protected batteries

1 Like

I met the problem same as you described.
When i pressed and hold the button to start,the switch light went on for a few seconds and went off.I pluged with usb adapter and the DT boot on normally. The battery indicator said that there was over 90% left.

1 Like

I’ve noticed the same with two different sets of batteries (one protected, one not). I’ve started removing and storing the batteries when I don’t intend to use the device again within a few hours.

1 Like

I had the same issue, but I wasn’t using protected cells as the manual doesn’t say it’s required (and all the protected cells I tried wouldn’t fit).

After ~7 days the cells are reading 3.2v

  1. Why is there so much drain? – By default there isn’t standby draw is 0.000A draw via PSU
  2. Is there no battery management? – There most certainly is, and it looks good
  3. Is it safe to charge unprotected cells? – Definitely should be fine

Edit: Incorrectly said the cells were drained. Turns out I just cannot use a multimeter. Also answered my own questions. Still no idea why the cells are at 3.2v after a week.

Edit2: There is a 170mw (0.041A @ 4v) draw after turning on and then off the DevTerm. So about 3 days for a single 18650. Does the PMIC need to be put back into a sleep/standby mode after power off?


  1. Hooked up bench power supply to single 18650 connector.
  2. PSU is set to 4v and limit of 2A
  3. After turning the PSU on, there is a 0.002A draw for a couple of seconds. Then it’s too low to see
  4. Turning on the DevTerm using the button results in expected power usage
  5. After turning off the DevTerm (via soft shutdown) results in a consistent (at least for 15min draw of 0.042A)
  6. Turning off the DevTerm using the ‘hardware’ button while it’s booting (hopefully skipping the OS) still results in the 0.042A draw.
  7. Turning off the PSU, and then back on results in 0.002A draw for few second and then returns to drawing 0.000A until power button is pressed again.
1 Like

I have not been able to reproduce my original problem.

1 Like

thats good news i think!

Point 6, you mean pressing the button for 20 or so seconds until the DevTerm stop?

A potential interesting point, what SoM (the core module) are you both (you and @Andrew_Holt) are using?

Though if what your point 6 is what I think it is, the AXP228 should put itself in the OFF mode…
This is tricky, but not going fully in “OFF” mode is a possibility, would be interesting to check if there is any voltage rail still on.

40mA is a lot though.

And thanks for the test you ran, it could be helpful to find the issue :slight_smile:

1 Like

Point 6, you mean pressing the button for 20 or so seconds until the DevTerm stop?

Yes, I just double checked that by disabling the soft power down in /etc/systemd/logind.conf and holding the button for ~10seconds. Still 0.042A draw.

Edit 2: I’m a little confused. The manual says 20s too, but the power seems to cut at ~8-10 seconds and holding it any longer does not do anything. It’s definitely not doing a soft shutdown though.

A potential interesting point, what SoM (the core module) are you both (you and Andrew_Holt) are using?

I’m using the RPI-CM3 core module

Edit 1: I cannot tell my ohms from my amps, so take this with a grain of salt… But SY7215 appears to be outputting 5v when the board is in the off-but-not-off state. Guess DCDC1 is on too?

(Why is everything so teeny-tiny)

Edit 3: Can you tell I’m bored? Manually telling the AXP228 to turn off has the same 0.042mA draw: i2cset -f -y -m 0x80 0 0x34 0x32 0xff. (i2c bus 0, address 0x34, register 0x32, set the highest bit to 1 [0x80 & 0xff]).

What does this mean? Probably that I don’t know what I’m doing.

And that the driver is probably doing the right thing? AXP228 is being told to turn everything bar LDO1/RTC off. But something is still running

Edit 4: This is a lot more fun when you’re not the one having to fix it. I’m a software person, and not a good one at that… Grain of salt etc. etc.

SY7215 appear to be enabled using 3v3 from DCDC1. In the off-but-not-off state the 3.3v line appears to measure 1v and SY7215 is happy keeping the 5V rail up. Manually pulling the enable-pin to ground turns off SY7215.

Schematics for R108 say it should be 100k, but when measured in circuit says 10k. Minor thing… maybe…?

I did get my board (without keyboard) to draw 2mA after shutdown. No idea why. Put it all back together, and it was back to 42mA.

(I’m going to bed now, and I promise to leave you all alone)

1 Like

So the recommended way to turn off the DevTerm is to press and hold the power button for 20sec? That sounds like a rather long time… Is there a way to change that length of time in software by editing a config file or something?

I haven’t received mine yet but I’ve been trying to keep up with the forum discussions in the hope that I might be able to use it properly when it arrives. The power discussions and battery issues people have mentioned made it unclear the best way to power off or shut it down completely. I’m curious what the equivalent to the 20 second button press is in a command – would that be a “sudo shutdown” or something else?

No that is not what I said. The 20s long push is a “emergency off” command that most PMIC use.
This is NOT meant to be used in normal circumstances.

It is useful for example when your device is locked and can’t switch it off in a normal way.

You use the shutdown command or similar from any menu to switch of your device. Forced shutdown is not a normal one.

We are talking about a bug here either hardware or software that I think only touch the CM3.


Has anyone figured out anything yet? I have the CM3 module in my DT and it flattens batteries as listed here. The USB ports do measure 5V even when powered off.

Any progress on this?

with CM3?

Here is my note from June 10th 2022.

I finally got time to look into this. Looking at the schematic of the power section, R107 and R108 create a divider that feeds pin 11 of the SY7215 part. Starting then turning off the system, I went to measure the voltage on the junction of R107 and R108. This caused the system to shut down. Found that odd, so I tacked a 1 Meg resistor on top of R108 to drop the 100K value just a bit. The meter should be about 10M so thought this would do it, it didn’t. I next reduced R108 down to 68K by putting in parallel a 220K resistor. This resolved the problem and the system now shuts down as expected.

1 Like