clockworkpi

Batteries do not appear to charge in DevTerm

I just assembled my devterm, and put in two charged 18650 cells oriented correctly. The system will not power up unless it has a usb c charger plugged in. It refuses to boot if there is no charger, and when raspberry pi OS boots up the batteries indicate they are charging but at 0%

I have tried reseating the 18650 board but it does not seem to make a difference. What else should I check?

1 Like

do you have any cells of a different manufacturer to test?

Most likely your battery are not making proper contact.

Can you post a photo of them? And one with the batteries in the socket

Also be really careful of the polarity!

1 Like

Yes. I was using cells I purchased through DigiKey marked as being from SparkFun. Apparently they were not holding much of a charge even though my 18650 charger claimed they were fully charged. When I put a multimeter on them (which I should have done before I posted) I saw they were well undervoltage. Not sure why.

I had Samsung 26C cells that I had pulled out of a laptop battery pack and they already had a much higher charge. They did charge in the DevTerm, but only after I was able to properly seat the 18650 board (the blade connectors took much more effort than I wanted to expend to get them to make a good, solid connection.

Thanks for the suggestion!!!

1 Like

Thank you for the suggestion. The batteries were seated properly every time I tested, disassembled and retested the DevTerm, as far as polarity was concerned.

After swapping for batteries that were much older that I had salvaged out of a laptop battery, the DevTerm was working properly! While the batteries were seated properly, it took about two times’ worth of disassembly and reassembly of the device down to the battery charging board before I realized the blade connectors were not properly seated, and it took a few tries and lots of gently but consistently firm pressing and rotating of the CM3 host board and the 18650 with the blade connector as the pivot point. (I did this after removing both boards from the devterm of course.)

Thanks for making the suggestion that there was something not properly connecting!

I replied to both users that responded to me because each helped me find a part of things I had missed.

I would also like to add here that if there are no batteries present in the DevTerm, or if, like me your cells are dead, OR if the blade connectors at J1 and J2 are making proper connection, as of the build of Raspberry Pi OS for the DevTerm as of 9-5-2021, the Menu Bar (in windows what I would call a “task bar”) flashes about 5 times and disappears. I have no way to prove this, but I have a feeling it may have something to do with the battery status monitor that is part of the menu bar. It’s just a hunch based on my IT experience. While I was having the bad battery/bad connection issue, I attempted to solve the flashing menu bar by reading lots of Stack Overflow for linux sites, and none of the tricks I tried fixed things. Fortunately fixing my two battery issues did. :smiley: Anyhow, thanks for viewing, and I will go see if I can somehow mark this thread resolved.

1 Like

thanks for documenting the process for us. this could help out a lot of people.