Bluetooth device on gameshell

bluetooth
tinkering
hardware

#1

I tried to use the bluetooth on gameshell, but it seems the system cannot find it.
I used hcitool dev and rfkill list to list devices, but got no bluetooth device.

Is anyone able to use the bluetooth? Thanks!


Trying to configure Bluetooth on GameShell
Trying to configure Bluetooth on GameShell
#2

Hi!

I’ve always been wondering if Bluetooth functions can be used.
I tried using Bluetooth service with apt-get, but it remains inactive.

Blockquote
cpi @ clockworkpi: ~ $ systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man: bluetoothd (8)
Blockquote

In case
Do I have to reconfigure the kernel?
I would like to use the Bluetooth controller for 2P control.


#3

We have updated the kernel and some necessary files for Bluetooth.


#4

@hal Thanks! I have control! but, buttons.


#5

This is great! Except… The bluetooth kernel breaks the USB-ETH. I need both!

LasVegas


#6

Once I turned off Wi - Fi, I could not scan. I can use USB-ETH…


#7

Sorry, “sudo rfkill unblock wifi” I can connect Wi-Fi again.
Is the setting item of the launcher not following it?


#8

I follow the wiki on https://github.com/clockworkpi/bluetooth, but when i use “connect xx:xx:xx:xx:xx:xx” command, i got “Failed to connect: org.bluez.Error.Failed” …
“pair xx:xx:xx:xx:xx:xx” is ok.
I donnot know why…


#9

xx: xx: xx: xx: xx: xx is same value?
Is not it connected?


#10

xx: xx: xx: xx: xx: xx is my wifi mac address…
After I install pulseaudio pulseaudio-module-bluetooth, now gameshell can connect my Bluetooth headset, but there is no sound.


#11

Hello.
I am trying to connect the game pad 2 days ago, but it will not work.
Like a movie, the D-Pad moves, but the button does not work.

The game pad is 8 Bitdo Zero.

Bluetooth connection is done.

There seems to be a driver for this pad in retroarch.


I changed the setting-Driver-Joypad Driver to “udev”.

Add /etc/udev/rules.d/10-local.rules file,
SUBSYSTEM == “input”, ATTRS {name} == “8 Bitdo Zero GamePad”, MODE = “0666”, ENV {ID_INPUT_JOYSTICK} = “1”.

Add /etc/udev/rules.d/99-evdev.rules file,
KERNEL == “event *”, NAME = “input /% k”, MODE = “666”.
https://docs.libretro.com/guides/input-joypad-drivers/

User “cpi” has not been added to “input” group. Do I need it?
Please let me know if there is anything else I can do.


#12

maybe this will be useful …

input_select_btn = "Space"
input_start_btn = "Enter" 
input_x_btn = "U"
input_y_btn = "I"
input_a_btn = "J"
input_b_btn = "K"
input_l_btn = "Home"
input_r_btn = "End"

#13
sudo su

cat <<EOF >/etc/rc.local
#!/bin/sh -e
sleep 15
brcm_patchram_plus --patchram /lib/firmware/brcm/bcm43438a0.hcd --enable_hci --bd_addr B0:F1:EC:2D:07:5B --no2bytes --tosleep 5000 /dev/ttyS1 &
EOF
chmod +x /etc/rc.local
systemctl daemon-reload
systemctl start rc-local
systemctl status rc-local

systemctl enable bluetooth
reboot

use rc.local to auto set bluetooth everytime rebooted

rc.local is being deprecated in debian9 ,so first get it back

add two lines in /etc/systemd/system/dbus-org.bluez.service

Restart=always
RestartSec=3

under [Service] section
after line ProtectSystem=full

to prevent bluetoothd unexpected crash


#14

As I was told, I rewrote 8 Bitdo_Zero_BT.cfg but it did not work. I tried sudo apt-get install joystick, but it did not change. / dev has no joystick directory, is that something like that?


#15

I did it!

But, This is recognized as 1 controller. purpose as a 2 controller.