Trying to configure Bluetooth on GameShell


#1

Hello everyone!

I have being trying to activate Bluetooth. I am no expert, but I think I am good searching stuff.

Check all these links first:
https://forum.clockworkpi.com/t/bluetooth-device-on-gameshell/617
https://www.raspberrypi.org/forums/viewtopic.php?t=138307
http://troglobit.com/2017/01/03/trust-bluetooth-4.0-adapter-in-linux/

Turns out that using this line “worked”:
cpi@clockworkpi:~$ sudo apt-get install bluetooth

However, after trying to start it and retrieve its status, looks dead:

cpi@clockworkpi:~$ sudo service bluetooth status
● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:bluetoothd(8)

Also I created the rules.d files (97-hid2hci.rules) in /etc/udev/rules.g and /lib/udev/rules.g.

Currently it is not working.

Feel free to comment!


#2

Hello everyone!

I have being trying to activate Bluetooth. I am no expert, but I think I am good searching stuff.

Check all these links first:
https://forum.clockworkpi.com/t/bluetooth-device-on-gameshell/617 1
https://www.raspberrypi.org/forums/viewtopic.php?t=138307
http://troglobit.com/2017/01/03/trust-bluetooth-4.0-adapter-in-linux/

Turns out that using this line “worked”:
cpi@clockworkpi:~$ sudo apt-get install bluetooth

However, after trying to start it and retrieve its status, looks dead:

cpi@clockworkpi:~$ sudo service bluetooth status
● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:bluetoothd(8)

Also I created the rules.d files (97-hid2hci.rules) in /etc/udev/rules.g and /lib/udev/rules.g.

Currently it is not working.

Feel free to comment!

Update:

Found this link, it mentions to do this:

sudo apt-get install bluetooth bluez blueman
sudo reboot

Wait for restart.

After that…
cpi@clockworkpi:~$ sudo bluetoothctl
Waiting to connect to bluetoothd…

Then and I stood up, cooked something and when I returned 30 min later, it still displays the same.

Seems like this is beyond me, or Bluetooth is not included.

To the Linux jedis around here, please help me to undo what I have done.


#3

Update:

Found this link, it mentions to do this:

sudo apt-get install bluetooth bluez blueman
sudo reboot

Wait for restart.

After that…
cpi@clockworkpi:~$ sudo bluetoothctl
Waiting to connect to bluetoothd…

Then and I stood up, cooked something and when I returned 30 min later, it still displays the same.

Seems like this is beyond me, or Bluetooth is not included.

To the Linux jedis around here, please help me to undo what I have done.

Another update!!!

Could you please help me understand this?

I got this weird authentication request. I typed “cpi” and got ==== AUTHENTICATION COMPLETE ===, but the service still inactive.

Sad.


#4

I think you need to recompile the kernel for that


#5

Correct! It is not included there yet.


#6

Great places to start:


#7

We have updated the kernel and some necessary files for Bluetooth.


#8

I follow the wiki on https://github.com/clockworkpi/bluetooth, but when i use “connect xx:xx:xx:xx:xx:xx” command, i got “Failed to connect: org.bluez.Error.Failed” …
“pair xx:xx:xx:xx:xx:xx” is ok.
I donnot know why…


#9

/etc/init.d/bluetooth start


#10

Thanks.
After I install pulseaudio pulseaudio-module-bluetooth, now gameshell can connect my Bluetooth headset, but there is no sound.


#11

maybe it can only use HID device ,no sound