Bootup CPU governor and scaling

Hello folks. I’m having a weird issue with my Devterm: the default governor is always schedutil and CPU speed is always 1 Ghz, regardless of what I configure in armbian-config. I can do a sudo systemctl restart cpufrequtils to force the CPU settings to what I want, but it seems something else is fighting this in the boot sequence and I’m not sure what. Any suggestions?

1 Like

I assume you are on A06 module because you mention armbian-config instead of raspbian-config.

For the A06 there is this gearbox script DevTerm A-06 core CPU frequency scaling - #3 by yong to change the cores.

Or this GUI I made Gearbox GUI program for the Devterm A06

To change the governor from the terminal you can do:

echo performance | sudo tee /sys/devices/system/cpu/cpufreq/policy0/scaling_governor

To change the frequency:
Make sure the core is online state
echo 1 | sudo tee /sys/devices/system/cpu/cpu0/online
Then set the frequency
echo 1416 | sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

1 Like

Yes, A06.

Oh, I know how to change the governor, and the settings I want are stored in /etc/default. cpufrequtils is supposed to be affirming these settings on startup, it’s just… not (until I manually restart it). And I want to fix that, rather than adjusting the settings myself or putting a workaround hack in /etc/rc.local or something. At least until I know what’s going on.

Figured it out. It’s (in /usr/local/bin). I just commented out the set_gov and set_performance lines so that cpufrequtils could handle things the “normal” way.


Thank you!! I was grinding my teeth trying to figure out where that setting was being modified. :+1: