Bug in Launcher 1.23

I just installed the newest Launcher update into ClockworkOS 1.21. Now every time it boots it starts up in a windowed mode, displaying the launcher in a window titled “pygame window”. If I switch to LauncherGo, it reboots into the normal display, but looses a lot of features in Settings.

need a little fix in /home/cpi/.bashrc

remove bottom part of .bashrc, starts at this line to the end

if [ -f /tmp/autologin ]
	rm -f /tmp/autologin
	mpd ~/.mpd.conf
	startx -- -nocursor > /dev/null 2>&1 

Replace with:

if [ -f ~/launcher/.cpirc ]; then
   . ~/launcher/.cpirc

In os v0.21 image, we changed ~/.bashrc

launchergo will have full features very soon


Thanks guu! That solved it!

heya !

happy is fixed and about to be closing thread.

i just permit myself to add this before

i got figured out same problem tonigth and dint know where and how do it so there is a video helped me do it in a basic way via ssh terminal

Linux Commands for Beginners: 22 - The .bashrc File

hoping it will helps other to more people easily access it .

have fun ! :slight_smile:

I tried changing the .bashrc file. When I reloaded the UI, nothing happened, and when I rebooted, the terminal shows up. Any help?

This appears to show that there’s a mistake in your .bashrc file. The instructions indicate to remove everything from the line:

if [ -f /tmp/autologin ]

… to the end of the file. Then add the three line indicated.

You can still access your GameShell via SSH in its current state.

could anyone post the original file on pastebin so I can check what I’ve done wrong?


I have no old .bashrc right now

so I pasted the latest .bashrc for you ,hope it can help