clockworkpi

Can't connect to WiFi

Hello All,
I just received my GameShell and can’t seem to get the WiFi working. My local router has an unsecured connection but has a MAC filter. I have turned the filter off and the network should be wide open. I tried to connect and the Gameshell shows connecting, putting interface down, putting interface up and then it goes back to the Scan wifi screen. If I select “Y” then it shows being not connected. I connected directly to the Gameshell through USB Ethernet and used wicd-curses to manually connect. I changed the saved connection to my network to be unsecured and saved. When I try to connect through wicd-curses it shows all of the above feedback and it also shows “Obtaining IP Address” for several seconds until it shows not connected. I thought maybe I couldn’t connect through USB and WiFi at the same time so having saved the connection information to my network I tried disconnected through my USB and have the same results. Does anyone have any ideas?? When I select update is shows my version is stable 1.24 Any help would be greatly appreciated.

wifi and usb-ethernet can connect at the same time for sure

launcher is just a frontend to the wicd, like wicd-curses

the gameshell does NOT like open networks. something that should be addressed but it seems development is working on hammering out the issues first.

it may also be an issue with wpasupplicant.

Since I can connect through SSH shouldn’t I be able to create a configuration file for my network? I see that no matter what I put for my network in the wicd-curses interface the configuration file in /var/lib/wicd/configurations still shows a key_mgmt even if I deselect encryption. Is there some way I can manually create a configuration file for my network? Or maybe even define an unsecured entry in wicd that I can select as a choice?

indeed you CAN, but the problem is the launcher at this point as it deletes and rewrites the file i believe. so maybe if you were to go into the python for the launcher and comment out the wifi section entirely or at least the portion that deletes and re-creates the configuration files?

of course I could be WAY off base lol. i’ve only touched on the launcher code

Thanks ducky!! I’ll look in to the launcher code. What about my other idea? Is there a way I can create another entry into the encryption definitions that doesn’t have any encryption and select that one in wicd-curses? I can see the encryption directory with all of the choices and it looks like the active file contains all of the choices that are available. Would this possibly be more trouble than its worth?

Also, please excuse my ignorance, but where does the launcher code live?

/home/cpi/launcher/
but beware there be dragons. you break it and its annoying to find and fix. (although a git clone will always be able to reset it)