Change desktop environments

i’m not a fan of LXDE or XFCE, and after running tasksel I see that KDE, Gnome, and Cinnamon among others are available. I was able to install their associated display managers, and even changed the x-session-manager settings to boot into one of the new DE’s. But there must be a auto-login script written by the clockwork team thats automatically booting me into XFCE. I guess the reason for this is because XFCE/LXDE are the only desktop environments that actually work, but, I want to see for myself and I run Cinnamon on everything so I miss it. Anyone know what I should grep search for? what directories to look into? Just so I can boot into LightDM and select a different DE. I’m totally fine with messing up this install of XFCE.

Edit /etc/lightdm/lightdm.conf.d/12-autologin.conf and comment out the three lines – that’s how I got i3 working.


Pretty funny how autologon is a default setting on de uConsole, I also had to dig for this file to turn it off.

where exactly is “12-autologin.conf” and what “three lines” do i need to comment out? I can’t find it. In “lightdm.conf” i uncommented all 4 of the lines pertaining to autologin and it didn’t do anything.

shit, i think the A06 image and CM4 have different setups

try sudo find /etc -name "*.conf" -exec grep -l autologin {} \; i think and you should be able to find the file

(if the command doesn’t work, my bad, i wrote it without testing :P)

1 Like

so i ran that command, and it worked, and i found a .conf file in the etc/system/systemd folder. that conf file only had two lines, and commenting them somehow turned on the screen reader program (like the kind for blind people) so that didn’t help lol.
What did work though, was sudo tasksel (make sure you sudo apt-get update -y && sudo apt-get upgrade -y if this is a fresh install or else you’ll get an error!) and then in tasksel i selected my DE of choice with the spacebar, tab to “ok” and hit enter. Then, I ran sudo apt-get install gdm3 which is the gnome display manager. After running that command was run the system asked me which display manager i wanted to use and i picked GDM3. Then, i rebooted, and the system showed me the GDM3 log in screen! clicked my user account, and on the bottom right, in the settings menu, was able to select the Cinnamon desktop environment, and its been running smoothly ever since.
In my other thread on programs/games not downloading or running correctly i said i was having issues, turns out they run just fine in Cinnamon. Must be a XFCE/LXDE problem.

1 Like

try find autostart and desktop.conf in /etc/xdg/lxsession/LXDE-pi
comment the first and second lines in autostart
in desktop.conf chamge the windows_manager = matter to = i3
this makes my I3 work