DevTerm R01 - Miscellaneous Initial Configuration Questions


I just got my R01 last night, and I’ve been busy setting it up to do console app development. I’d like to change a few things, and I’m struggling to figure out where to look:

  1. Change the default autologin user from cpi to my personal userid. I looked in the normal “Ubuntu” places where these configurations might be found (because this OS announces itself as “Ubuntu”), but couldn’t find what I was looking for. Where would I do this?

  2. I want to disable a number of things at boot up: (a) The XFCE desktop launch, (b) the Avahi daemon, and (c) the cups daemon. With regard to XFCE, I tweaked both the gdm3 default and the xfce4 default files, but the desktop still starts automatically. With regard to the services list, I modified what would normally stop these services from auto-starting, but the auto-started anyway.

  3. Given that this is a custom port of the ubuntu repositories, for RiscV64, what is the normal path for package and or os udpates/upgrades? The usual “apt update” to get a list of available upgrades, just results in an explosion of error messages.

Any thoughts?

1 Like

I’ve been tinkering with mine since last week, and I don’t have answers here yet, but want to join in and learn.

I think avahi is disabled by default (at least the wiki said that was the intention). You should be able to use systemctl to stop/start/enable/disable I think - is that what you tried?

As for the user environment, mine was set to run twm (not xfce) out of .xinitrc. I switched to i3, but now I’m finding that it boots to a terminal, rather than to a desktop, which is baffling me - I don’t think I changed the default runlevel.

1 Like

On the upgrade question, it should (!) let you do upgrades, albeit you have to accept a switch to the Kinetic repos; you will also need to re-set the extlinux file afterwards, per this comment.

Avahi was active initially. Both the “service” command and the “systemctl” command do work. But when I reboot, the services are started again. There’s a config in xinit to set the default states. But that didn’t seem to stop them from starting on bootup :frowning:

You may be right about twm. I’m not sure exactly which DE was started. I guess I just assumed it was xfce. I’ll have to take another look at that.

I’m able to install/update individual packages ok. But when I try to do a global update, it looks like its calling out to repos that it’s not supposed to be. I skimmed the sources.list files last night, but didn’t get a chance to really dig in.

1 Like

I got mine recently as well. It is still a very new image, and board.
If the .xinitrc is removed you get put into an XFCE desktop environment.
I was a bit surprised on how much breaks with the simple update/upgrade.
I’ve been trying to pair down what is installed; like removing snapd, fwupd, etc
Maybe see if you can uninstall Avahi; probably leave XFCE alone for now.

My current issue is the thermal printer will print half of the text and then return an error code.
I know this isn’t exactly helpful, but more data points.

1 Like

Ah, that explains how that could come about! Although, I’ve not discovered why I no longer get into a desktop at all now, all I did was change twm to i3…

I’ve seen the thermal printer behave oddly, it definitely prints very slowly, and sometimes not at all. I’ve tried both via cups and by echoing directly to the device. It could be useful to document the “ideal way” to use it, and also, any control codes for the device (it would be helpful to be able to linefeed to spool the paper, for example).

I know at one point i removed xinit or startx, whatever the .xinitrc was trying to use to start the DE, by accident when trying remove other programs. Might want to check if all of the commands .xinitrc are still installed.

I’ve figured it out! I switched to zsh (from bash), and failed to notice that in the default setup, the .bash_profile was invoking startx. I’ve moved that into .zprofile and now it boots to X, with i3 (which is what I want, at this point in my experimentation).

I ended up completely deleting Xorg, gdm3, and xfce4. I’m running entirely from the console, and that’s fine with me. I was able to use dpkg-reconfigure to resize the console text to keep myself from going completely blind. :smiley:

The user autostart was actually in /etc/systemd/system/getty…

I should have read the README they through up in my face when I first started the machine up!

1 Like