clockworkpi

ClockworkPi Gameshell crashes in 10 seconds

So I’ve been working on a ClockworkPi Gameshell issue with the support team, but also wanted to check with the community to see if anyone else was seeing the issue I’m seeing. I absolutely love the Gameshell, especially as a PICO-8 device, but am at my wit’s end with this device I got only 3 months ago. I’ve searched these forums but don’t see anyone having quite the same issue I’m having.

In short … my Gameshell powers on for about 10 seconds, then the screen goes black, then you hear a high pitch noise … and then it completely shuts down. When this happens a few times in a row, the CPU gets incredibly hot (there are a few threads on this forum about this), but they’re usually centered around installing a heatsink to reduce heat, but I don’t see any reports about crashing within seconds of boot. So that symptom may be unrelated.

Regardless, I’ve tried the following steps to troubleshoot:

  • Use a separate SDCard with a fresh copy of the 0.4 image written to it. No change … still crashes.
  • Tried with and without the battery plugged in, as well as with and without the AC adapter plugged in … no change.
  • Unplugged and reconnected all of the different plugs inside the shell

Regarding the LED lights … when the issue occurs, the ClockworkPi boots with both yellow and green lights, then just yellow … and then crash. The unit will at this point either turn off or the yellow light will be displayed after it locks up. The power button is unresponsive, so you actually have to remove the AC adapter as well as unplug the battery to get it to power down.

Anyone else seeing this issue?

so three months?
send email to help@clockworkpi.com

1 Like

Already done :slight_smile: Waiting to hear back on at least exchanging the main board and/or the battery.

1 Like

Was it the revised 3.1 board, or the older one? Re: heat sinks, I’ve never really had issues with heat making things break, and I’m on a 3.1. I live in Australia, which is basically a desert. (40 deg celcius FML)
I’m guessing the heat sink posts were to do with the older one.

Out of interests, to isolate the problem, what happens when you run it, plugged in via USB? Just to make sure it’s not a battery current problem. Over heating on a hardware level sounds like a power source problem.
If you have the means, see if you can replace the cable going from the battery to the main board. Some people have also reported the cable being sub par, even having problems compiling until they replace it.

I did try it plugged into the AC adapter, with both the battery connected as well as disconnected, and the results were still the same. Crash within 10 seconds. I’ve tried a total of 5 different MicroSD USB cables as well, with the same behavior … almost immediate crash.

RE: the revision…Is there a way I can tell the board revision by physically looking at the board?

1 Like

A super easy way to check to see what version you have is to check the connectors. The new 3.1 board has a HDMI connection.
The order of interfaces from the power button should be:

  1. Power
  2. HDMI
  3. USB Micro
  4. 3.5 multimedia jack

Of course, you can also check in the settings menu, going into “about” - but I’m guessing your machine doesn’t stay on long enough to do that :confused:

I checked. It’s 3.1. Thanks for the tip!

Just got word from ClockworkPi support that they’re sending me a replacement.

1 Like

Niiice! Hopefully you get it as soon as possible! Meantime, have you checked to see if any pins are potentially bent? Sometimes two jumpers can end up in one header; especially for things like the keyboard. The build up of heat, and shutdown after a certain point definitely sounds like something is shorting.
No harm checking it while the replacement comes in the mail. :wink: