Gameshell won't react/boot anymore

Hi there,
I have a gameshell since the beginning (kickstarter); it worked fine ever since.
Last week I noticed some instability (after not using it for half a year or so) but I could play games. I noticed that there is a new Clockwork OS (version 0.5) so I decided to grab the sd card, delete everything that’s on it, burn the newest image on it and after puting it back; it won’t react in any way anymore.
I’m quite familiar with linux, hardware, software etc but I have no clue what might be happening here.
Any clues where to start looking? I have a digital scope and a multimeter available if that is needed.

Any help is highly appreciated!

Me too
No Led blink, No Boot, Nothing work

Try reinstall OS

yeah, I forgot to mention, indeed no led (even when trying to charge!) etc.

But I found some sort of sollution; Yesterday I went to the store and found a cheap new SD card. I flashed version 0.4 and somehow it seems to work. At this moment I’m flashing version 0.5, hopefully it will work! I’ll post my findings later (this evening or somewhere this week)

Everything works fine at least.
What I did was use a new SD card. I read somewhere online that while flashing, something might be corrupted in the files. So, somewhere this week I will try to format my old SD card and try to install the newest version of the OS without any errors and I will try to boot with that old SD card.
But for now everything works and I can continue play games!

For you all the best Maverick, good luck finding a solution, hope it works anytime soon!

Same problem here, GS not booting anymore. No more green light, nothing happens whatsoever. Tried another SD card, won’t work.

Is the motherboard dead?

what worked in my situation was with the new SD card, an older OS version (0.4) and trying to power it on and in the mean time pressing the reset button on the bottom of the mainboard. (I guess I did something like that) and then everything was fine again.
Browsing and searching here on this forum learned that something might go wrong with the file system and/or with the files on the SD card. You have to do some specific steps to (re)format the SD card in a way that that corrupt file/filesystem is not present anymore. I haven’t done that, because I used a fresh SD card.

Me either. Solved booting problem.