[CM3/Raspbian] How to use HDMI output?

Hello,

I have a Devterm with an XFCE4 desktop environment.

Using “vc4-fkms-v3d” option only shows the raspberry pi boot screen on the external monitor.

And the desktop works on the internal LCD monitor.

I can’t find the external one in this case.

On the other hand, only the external monitor works when using “legacy” driver.

The internal LCD monitor just blank screen.

Is it possible to use an external monitor with the KMS option?

1 Like

I have the same issue. When booting using the standard SD card the external HDMI monitor shows the boot messages, but sideways. It seems to be in portrait mode. After booting it shows the raspberry pi splash screen. The devterm itself shows the desktop as expected.

It is a pure software issue, both display works, you need to set Xorg to use both screen, which may be a bit tedious to do on Raspbian, not sure if xrandr is installed by default.

Haven’t been able to test HDMI yet as my cable is yet to be found.

In my case, Xwindow shows on DevTerm, but external monitor shows console log.
No addtional settings added in /boot/config.txt ( “vc4-fkms-v3d” is on )

Is it possible to post the config.txt file? I have some problems getting some HDMI output.

@michael_mayer if you said to me, my config.txt is same as devterm distribution image.
Because I use Lubuntu with sddm display manager, I added xrandr in /usr/share/sddm/scripts/Xsetup

#!/bin/sh
xrandr --output DSI-1 --rotate right

Multiple xrandr lines can be added so that external monitor can also show corecttly. But I just didn’t.

So did a quick test yesterday as I found my microHDMI cable, and it was working as a second screen in xorg, you should check. I can’t do more test at the moment with the CM3 sadly.

Also @Glbr_Hanson, I’m pretty sure you need the GPU driver to be vc4-kms-v3d, not the “fake KMS” one.

1 Like

I figured out what my problem was. The micro hdmi connector is to short to reach the connector on the board propertly. Trying it with removed case I have at least shown an image. I think i need a better hdmi cable or adapter with a longer plug.
Same issue as @Gibr_Hanson tough. Checking xrandr next.

2 Likes

Can somebody step me through this? If I’m using the CM3 version and I’m on the default distro, what are the steps to get it to work?

Currently, when the cable is plugged in, I get to see some sideways console text on the external monitor when booting. Then it sitches back to LCD screen and HDMI stays blank. In the display manager there is an HDMI entry in the menu but the sub-menu is empty. I cannot do anything to activate or configure.

That has something to do with Xorg, I would google how to edit the Xorg.config for external monitors

https://wiki.archlinux.org/title/Multihead

Having done a little research, I thought I’d drop a note here for other people that might have the same problem I did. I had to remove the port cover to use my existing micro HDMI adapter. (I’m using an A06 DevTerm)

BUT I found an adapter that works without removing the cover by buying several and trying them. The iBirdie brand on Amazon had an HDMI micro jack that was just slightly longer than my other adapters, which made it long enough to use with my DevTerm without removing the outside jack cover. “Micro HDMI to HDMI Female Cable” by iBirdie on Amazon. I hope this helps someone else!

3 Likes

Confirmed! Yeah it turns out it’s a cable / connection issue for me too.

@Starblade42 ! Very interesting- I couldn’t get my HDMI adapter to work. Can you elaborate on what you mean by port cover? Is there something on the board I need to remove? Like everyone here - I plug in the cable and no workie. Sounds like the plug is not long enough but as far as I can tell it looks normal and no cover?

Sorry it took me so long to reply! So, I got my other micro HDMI cables to work on my DevTerm by removing the greyish plastic rectangle that has labels on it for “USB, Power Type-C, Micro HDMI, Audio” that is inserted as part of case assembly. You can see the particular rectangle I’m talking about on the very left-hand-most side here:

Removing that gave me another ~1.5 mm to be able to push the HDMI micro adapter into the port, and I got a solid signal that way. With that little port lable/board cover on, the micro port couldn’t go far enough into the port to make a clean contact with the pins, though I still felt a bit of a “click” that made me think it was engaged. So if you can’t get it to work with that thingy on, you can take the case partly apart and use the ports bare, but that sucks. Thus why I thought it would be useful to know that the “iBirdie” brand I bought has slightly longer jacks so it works even with the case fully assembled.

3 Likes

Thanks for posting about that cable adapter with the longer jack. I bought one before my A06 arrived, and it’s been working great!

I am having an A04 model, removing the grey panel wouldn’t solve the problem. Plug in micro hdmi and get no response.

The other thing I’ve seen suggested was to plug in the micro hdmi before the DevTerm is on, and then turn on the DevTerm. I’m not entirely sure I’ve had to do that with my Devterm. I haven’t used it with a monitor for while now that I solved the jack length mystery. I also had to go into the monitor settings to turn on the external monitor, I don’t think it just started displaying automatically the first time I tried.

xrandr shows no external monitor, and in display setting also no monitor detected. Should I do something else to enable it?

I have tried many things.
And finally, It worked after some apt updates.
InkedScreenshot_2022-01-13_09-11-51_LI

There’s a thread about A04 lacking HDMI output - No HDMI on A04?