CM4 8GB/32GB eMMC, official Bullseye image: error installing upgrade to devterm-thermal-printer

I just did a

sudo apt update
sudo apt upgrade

and accepted everything. And the printer still works! I didn’t use apt-mark hold as you mentioned above, @RaelZero and it still kept the cm4 package and didn’t install the other one and break things. I also didn’t need to downgrade anything, just needed to remove devterm-thermal-printer.

Incidentally, when I say the printer worked, I mean I successfully printed the test page from Preference->Print Settings. And I also successfully ran the test print command from the terminal:
echo -en "\x12\x54" > /tmp/DEVTERM_PRINTER_IN

Can confirm that it did work for me, too, @adcockm by uninstalling devterm-thermal-printer and updating the other two packages.

WiFi now works, and everything seems in order. Many thanks!

Incidentally, could you send a picture of your test print?

In particular, I’m curious about the last "checkerboard pattern, which seems to be quite wrong on my printer…?

These are two test prints I made: it looks like when a line that is supposed to be fully black, the paper isn’t advanced at the right pace? Not 100% sure, but noticed that on other test prints with full-black lines that I tried to make.


its ink blobs on the printer head, you can clean them with a cotton swab and alcohol

Here’s what mine looks like…

And here’s the Print Settings test from cups. It’s rather small and fuzzy, but I figure it wasn’t designed to be printed in such a small space.

1 Like

I installed the 64-bit version because it’s a 64-bit machine. There is no conceivable reason the device having eMMC would cause this to happen. I also did not have to change the parameter mentioned in order to get the WiFi antenna to work.

Hate to necro this again but its still a problem.
To simplify the instructions on CM4:

sudo apt remove devterm-thermal-printer -y
then update as you normally do.

As an aside this image needs to be updated and posted somewhere on a dedicated software page and not have to dig through the forums for it. Also many links for the download are not working and the one that does (the first one) is an unsecured download and browsers will not download it without forcing a download. The image also was not working for me once downloaded and I had to use an image I had downloaded months ago on another pc.