DevTerm OS CM4 image files

Official DevTerm CM4 image files here:

WechatIMG24

Download:
http://dl.clockworkpi.com/DevTerm_CM4_v0.1.img.bz2 ==> Mirror #1 ==> Torrent
md5sum: 7938ed1cdda98ba6f28049a819c12dc1
Size: 3.2G

v0.1 latest release note:

. Based on the Raspberry Pi OS* ARM32 system
· Linux Kernel v5.10.17
· Friendly LXDE desktop POWERED BY Raspberry Pi 
· Rechargeable battery energy management
. Standard CUPS thermal printer driver support

A BIG THANK YOU to the open source ecosystem and all supporters from around the world! :heart: :heart: :heart:

4 Likes

it works! :purple_heart:

2 Likes

Nice!

Do I understand it correctly, that this is a 32bit OS?

2 Likes

yes, that is 32 bit os

Why would this not be 64-bit? :pensive:

1 Like

Two questions. The shop pages says:

For all CM4 EMMC versions, will NOT be able to use the clockworkPi mainboard v3.14 SD card function

So, should I use the one without EMMC?

Q2, are the printer and the HDMI output working?

printer and HDMI are working as sure

EMMC can work theoretically, you need to reduce the image size, or because emmc is quiet small, you need to use the minimized version of rpi os with the dt kernel package

Slightly off topic, but is the Pi CM4 more performant than the A06? I’d also be interested in hearing if anyone who has a CM4 adapter can report how snappy (or not) using it with an eMMC module on the DevTerm is? I was hoping loading of programs was significantly faster.

64-bit image is out here now:

1 Like

Sorry I’m being a little slow here. What model of CM4 should I get?

I have just received a CM4 with Wifi and 8gb eMMC, but that’s too small to store the system in the installer. Is 16Gb eMMC the recommended minimum?

I now have a CM4 with 16Gb of eMMC, and have installed DEVTERM_CM4_V0.1 on it by connecting the CM4 module to a carrier board. However, the CM4 won’t boot in the DevTerm; when connected to a display on the carrier board it displays an error message “software is out of date”. Any clues as to how to install the OS? (and I’m assuming from the various specs that putting it on the eMMC is the right thing, as the SD card isn’t supported).

Aside: the CM4 carrier board came with a small copper sheet and some sticky pads but no slimline heatsink. Also, should the antenna replace the existing one, or can I leave it floating in case I want to go back to the A6 at some point?

Update: I tried again with the 64 bit image and it worked! Also, wow, but it screams! So fast! Now I’m definitely worried about a heatsink. What is the recommend thing to do for a CM4?

1 Like

Wow, how were you able to find the CM4 boards?!

Any tips on getting installed? I hope to set mine up this weekend…!

I still do not clearly understand whether this should be installed to SD card, or to eMMC.

I got my CM4 by checking https://rpilocator.com daily!

The story is a little confusing, or least I was confused :slight_smile: You need a version of the CM4 with eMMC storage, as that is where the OS needs to be installed. The CM4 doesn’t have an SD card reader on it, and it cannot access the DevTerm’s one (for some reason). Using the eMMC seems to really speed things up, but note that the default version of the OS for the DevTerm requires an eMMC with MORE than 8Gb storage. I have a 16Gb model. I found the 64 bit version worked just fine, the 32 bit version I had tried first didn’t work (I probably did something wrong).

Note: See later comments in this thread. Only CM4 devices with an eMMC cannot read the SD. The CM4 Lite models which do not have eMMC can use the SD.

You do need a way of getting the OS onto the CM4’s eMMC (f you are using a CM4 with eMMC). I used a cheap (< $20) CM4 carrier board from Amazon which included a USB3 port. Once hooked up, and connected to my computer, I used the usbboot software (search YouTube for a Jeff Geerling video that explains it in detail) and was able to install the OS as if it were an SD card.

Hardware installation seems easy enough: the CM4 clips into the new DevTerm carrier board, and that in turn fits into the usual socket on the DevTerm board. Remember to remove any insulating protective tape that might be covering the CM4 carrier board pins!

The two screws used to hold in the other boards will not fit, and won’t be used.

The CM4 requires another antenna, and that’s included. Clip it onto the CM4 board. I was able to place the antenna between the existing antenna and the battery casing and it seems to work fine.

I found the heatsink story the most confusing. The heatsink consists of a thin piece of copper material and two sticky pads. I attached the sticky pads to the top of the CM4, and placed the copper sheet in the bottom case as per the diagram included. When assembled, the sticky pads are pressed to the sheet (I guess). The instructions said to remove the protective sheet from the copper - I really tried but couldn’t peel anything off the copper, so hope that’s not going to cause issues.

Well shoot - I have a CM4 but it is a Lite version without eMMC, and I’d been hoping to re-use that in the DevTerm. I wasn’t clear from the site / forum that the SD slot is not accessible at all from the CM4, I thought I understood it was not accessible if you’re booting from eMMC. Darn :frowning:

It’s entirely possible I’m wrong. Try it?

I really hope you are wrong.
Cause that was indeed my plan as well :smiling_face_with_tear:

I can confirm that I cannot read any SD card slotted into the DevTerm when it’s booted from the CM4 with eMMC.
I can read USB flash drives. This makes me suspect that you really do need an eMMC CM4.

Edit: Later comments on the thread / website indicate you can install the OS on a SD card if your CM4 is the Lite version without an eMMC. If the model of CM4 you have has an eMMC, you must use the eMMC as it cannot access the SD card.

1 Like

The website very much indicates the opposite and if a lite version doesn’t work with an SD card then there is a big problem. They literally recommend to use a CM4 lite.

  • For all CM4 EMMC versions, will NOT be able to use the clockworkPi mainboard v3.14 SD card function.
  • The CM4 Lite and the CM4 with 8GB EMMC or higher are recommended.
2 Likes

So a CM4 without eMMC will work with the SD slot, but a CM4 with eMMC will not. Makes sense! The eMMC seems faster so worth the inconvenience for me.

Confirmed that I now have a CM4 Lite (4Gb / Wifi / no eMMC) running with the 64-bit OS image on an SD card. It took me several attempts of installing and reseating the module, thinking it wasn’t working, taking it out and booting it on a separate carrier board, reflashing the SD image, etc. but I now have the basics working.

There are quite a few things broken in the ClockworkPi additions (e.g. fan), I’m working on identifying and maybe then fixing them at the moment.

2 Likes