Device locks up when trying to connect to Wifi

wifi

#1

Hey guys!

Yesterday I received my Clockwork Pi, which turned my face very happy according to my girlfriend. So I went on and carefully assembled it, and booted it up, ready to play around with it. First things first: connect to wifi. There are a few networks available here, 2 of which are mine, so I selected one, typed the password, and then… nothing. At first, it would try to connect, apparently without success, and I just got returned to the menu without any message. But after a few tries, when I now try to connect to the same network, the device will just lock up (or at least, it stops responding to any of the keys). The only thing I can do is reboot the device by holding down the power key a few seconds.

So today I thought I should just try again. This time I picked the other network, entered the password, and to my surprise, after hitting “(Y) done”, it was trying to connect to ANOTHER network than the one I selected! No wonder it failed to connect! I hadn’t noticed this before, but the same may have happened yesterday. Looks like the device actually tries to connect to the strongest network, i.e. the first in the list. Definitely a bug if this is true.

Another try: I decided to just physically go stand next to my access point so its signal will be the strongest. And there we go again: the device hangs trying to connect. So I’m kinda stuck here. I suppose I can modify some things directly in the file system by mounting the SD card physically in my laptop (maybe that’s the only way forward), but I’d appreciate some sort of other solution.


#2

I managed to have it connect ONCE through my laptop using “mobile hotspot” on Windows 10. Once. Now when I try, it waits for some time during “obtaining IP address”, but it times out and I’m not getting a connection. I can see the device show up in the “mobile hotspot” settings page.

update: I can get a connection to my laptop by disabling and re-enabling “mobile hotspot” mode. Seems I have to do this every time I reboot the cpi though, so hardly a solution.


#3

Thank you for your report, If possible please let us know the specific model of your wireless router then we can try to reproduce this issue.

In addition, we will release the OTG Ethernet soon (In fact we have developed this feature and we are working on the documentation), this means that we can connect to the GS with a USB cable.


#4

Yes please! My WiFi connection is poor… ssh works, but slowly and sometimes it loses connection. Being able to do Ethernet over USB would really help.


#5

Ethernet over USB would be a very nice addition indeed, I was hoping this would become a feature.

My router is a ZTE H369A, running firmware V1.01.01T01.9. It’s provider managed, so I don’t control the firmware version and some of the settings are locked and/or hidden. The router may affect the problem, but like I wrote in my previous message, connecting to my Windows laptop requires soft “resetting” the connection every time as well (by a disable/enable cycle of the mobile hotspot) if I want the connection process to succeed.

I did find that the settings for one of my wifi networks is actually stored in the wicd settings. It didn’t have a hostname listed for my device (as opposed to some leftover configurations from what I gather are your internal wifi networks you used for testing the device). I noticed this after seeing in the logs that DHCP was being used without a hostname, so I thought this may be part of the problem. So, I added a name to the config section, but it’s still making the device unresponsive as soon as I select the network and hit the button to connect.


#6

NB: I found that the SSH connection is slow for me even if I use the device right next to my laptop, which is acting like a hotspot (see above), with key presses often taking seconds to get a response for. I didn’t investigate this any further though.


#7

Hi - I just received and assembled my GamesShell and it seems like everything works!

  • Sound works.
  • LightKey lights up (Is there any default software that recognizes Lightkey buttons?)
  • Brightness works.
  • FreeDoom runs great.
  • The other software runs but lacks the CORE or ROMs to try out.

But connecting to WiFi does NOT work.

Notes

  1. It seems highlighting different wifi routers doesn’t matter. It seems to only go to the topmost wifi router.
  2. It seems to get stuck at “: Validating authentication…” for a while. Then the message disappears. And the wifi symbol at the top of the screen still indicates no connection. (And I’m right next to the router) – and yes, I am connected and using the selected wifi right now.
  3. The wifi interface isn’t intuitive to me. It seems the “scan wifi” screen should have a connect (selected wifi) button - Maybe the Start button could be the connect function?

Router information - Using AT&T router in USA.
Manufacturer - Pace Plc
Model - 5268AC

Thanks,
– Tony


#8

Please create your own topic and not hijack an existing one for asking your question


#9

I thought it was related but sure thing.


#10

Solved #2.

ClockworkPi cannot handle a WiFi point that has both 2.4 and 5Ghz.

It worked for me when used a pure 2.4 WiFi point.


#11

I’m having the same issues. Wifi connects maybe once out of 5 tries. Changing the router to separate 2.4G and 5G does not resolve the issue. My router is the Netgear R7000.


#12

Same issue here, Wifi 2.5 and GameShell frozen


#13

Same issue here. All buttons stop working.


#14

I have to force reboot it, my GS works only with my phone wifi hotspot. It can’t connect my other 2 wifi routers.


#15

I’ve determined that I can only connect to my router if I’m right next to it with a 95+% signal. Once connected, it works when I walk away, until it looses the connection. Then I have to go back to the office and connect again. I’m thinking of adding an old 2.4G router as an access point in the Livingroom…


#16

There’s a trick on this forum that might help:

How to disable wifi power save to prevent disconnects


#17

When the machine is freezing in the wifi setting screen (actually the clock is still working), I put it close to my wifi router (apple time machine), all buttons will resume working and system will also auto connect to the wifi. Basically the machine will freeze when connecting to a signal under 70% in the wifi setting screen.


#18

update now
wifi ui blocking is fixed


#19

I thought it was related too… I’m having the same problems with mine. However I’m learning lots from just reading this particular topic, to be honest. Doesn’t help that the wifi in my home is weak(!)